summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-01-29 20:56:14 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-01-29 20:56:14 +0000
commit0361808df67c71c642ed3722c803678ffe72bcca (patch)
treefe447e922b33fc74f65f58baae5e1e24677add3e /dev-ruby/wikicloth
parentBump. Adds udev touchpad database. (diff)
downloadgentoo-2-0361808df67c71c642ed3722c803678ffe72bcca.tar.gz
gentoo-2-0361808df67c71c642ed3722c803678ffe72bcca.tar.bz2
gentoo-2-0361808df67c71c642ed3722c803678ffe72bcca.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/wikicloth')
-rw-r--r--dev-ruby/wikicloth/ChangeLog9
-rw-r--r--dev-ruby/wikicloth/wikicloth-0.8.2.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-ruby/wikicloth/ChangeLog b/dev-ruby/wikicloth/ChangeLog
index 854aa5b5efbd..87e627132e46 100644
--- a/dev-ruby/wikicloth/ChangeLog
+++ b/dev-ruby/wikicloth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/wikicloth
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/wikicloth/ChangeLog,v 1.1 2014/06/06 14:43:56 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/wikicloth/ChangeLog,v 1.2 2015/01/29 20:56:14 mrueg Exp $
+
+*wikicloth-0.8.2 (29 Jan 2015)
+
+ 29 Jan 2015; Manuel Rüger <mrueg@gentoo.org> +wikicloth-0.8.2.ebuild:
+ Version bump.
*wikicloth-0.8.1 (06 Jun 2014)
diff --git a/dev-ruby/wikicloth/wikicloth-0.8.2.ebuild b/dev-ruby/wikicloth/wikicloth-0.8.2.ebuild
new file mode 100644
index 000000000000..910e82567c21
--- /dev/null
+++ b/dev-ruby/wikicloth/wikicloth-0.8.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/wikicloth/wikicloth-0.8.2.ebuild,v 1.1 2015/01/29 20:56:14 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README README.textile"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A mediawiki parser"
+HOMEPAGE="https://github.com/nricciar/wikicloth"
+SRC_URI="https://github.com/nricciar/wikicloth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/builder
+ dev-ruby/expression_parser
+ dev-ruby/rinku"
+ruby_add_bdepend "test? (
+ dev-ruby/activesupport
+ dev-ruby/test-unit
+ dev-ruby/i18n )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/[Bb]undler/d' \
+ -e "/require 'simplecov'/d" \
+ Rakefile || die "sed failed"
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/wiki_cloth_test.rb || die
+}