summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-15 07:47:46 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-15 07:47:46 +0000
commit0671eb11497002d028d88085ed36ed8b4de145c4 (patch)
treed9af668d41bb0d7d4e499c7ca153be719716c137 /dev-ruby
parentVersion bump for rails 2.3.10. (diff)
downloadgentoo-2-0671eb11497002d028d88085ed36ed8b4de145c4.tar.gz
gentoo-2-0671eb11497002d028d88085ed36ed8b4de145c4.tar.bz2
gentoo-2-0671eb11497002d028d88085ed36ed8b4de145c4.zip
Version bump for rails 2.3.10.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-2.3.10.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 71ac050392bb..fa113d14b78f 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.159 2010/09/29 22:27:37 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.160 2010/10/15 07:47:46 graaff Exp $
+
+*actionpack-2.3.10 (15 Oct 2010)
+
+ 15 Oct 2010; Hans de Graaff <graaff@gentoo.org> +actionpack-2.3.10.ebuild:
+ Version bump for rails 2.3.10.
29 Sep 2010; Brent Baude <ranger@gentoo.org> actionpack-2.3.8.ebuild:
Marking actionpack-2.3.8 ~ppc64 for bug 322175
diff --git a/dev-ruby/actionpack/actionpack-2.3.10.ebuild b/dev-ruby/actionpack/actionpack-2.3.10.ebuild
new file mode 100644
index 000000000000..578a776ced0b
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-2.3.10.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-2.3.10.ebuild,v 1.1 2010/10/15 07:47:46 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 jruby"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+#RUBY_PATCHES=( "${P}-custom-cookie-fix.patch" )
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ >=dev-ruby/rack-1.1.0"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/activerecord:${SLOT}
+ dev-ruby/actionmailer:${SLOT}
+ !dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+
+ # This tries to load a “vendorized” copy of activerecord that we
+ # will never have. It can now also use a normally installed
+ # version but these tests fail.
+ sed -i -e '/PATH_TO_AR/s:^:#:' -e 's/self.able_to_connect = true/self.able_to_connect = false/' test/active_record_unit.rb || die
+
+ # Fix the testsuite, the symlink is not present in the gem for
+ # some reason
+ ln -s ../../symlink_parent test/fixtures/layout_tests/layouts/symlinked
+
+ # MemCacheStore tests no longer fail gracefully, and it's unlikely for
+ # someone to have them running anyway, so remove them for now.
+ rm test/controller/session/mem_cache_store_test.rb || die
+}