summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-28 08:09:15 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-28 08:09:15 +0000
commit0cbc68a10f26fff59c2255c63af5707833468360 (patch)
treebf2409f600bf9651ea05d8a9e7da8c38630d2243 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-0cbc68a10f26fff59c2255c63af5707833468360.tar.gz
gentoo-2-0cbc68a10f26fff59c2255c63af5707833468360.tar.bz2
gentoo-2-0cbc68a10f26fff59c2255c63af5707833468360.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/json/ChangeLog7
-rw-r--r--dev-ruby/json/json-1.5.1.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index c118d98ef3ec..bb3f4bfcd9c6 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.56 2011/01/23 11:33:31 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.57 2011/01/28 08:09:15 graaff Exp $
+
+*json-1.5.1 (28 Jan 2011)
+
+ 28 Jan 2011; Hans de Graaff <graaff@gentoo.org> +json-1.5.1.ebuild:
+ Version bump.
23 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org> json-1.4.6.ebuild:
ppc64 stable wrt #343473
diff --git a/dev-ruby/json/json-1.5.1.ebuild b/dev-ruby/json/json-1.5.1.ebuild
new file mode 100644
index 000000000000..3c3dd800fe7f
--- /dev/null
+++ b/dev-ruby/json/json-1.5.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.5.1.ebuild,v 1.1 2011/01/28 08:09:15 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A JSON implementation as a Ruby extension."
+HOMEPAGE="http://json.rubyforge.org/"
+LICENSE="|| ( Ruby GPL-2 )"
+SRC_URI="mirror://rubygems/${P}.gem"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND}"
+DEPEND="${DEPEND}
+ dev-util/ragel"
+
+ruby_add_bdepend "dev-ruby/rake
+ test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # Avoid building the extension twice!
+ # And use rdoc instead of sdoc which we don't have packaged
+ sed -i \
+ -e 's| => :compile_ext||' \
+ -e 's| => :clean||' \
+ -e 's|sdoc|rdoc|' \
+ Rakefile || die "rakefile fix failed"
+}
+
+each_ruby_compile() {
+ # Since 1.5.0 a Java extension is provided but it does not compile.
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ${RUBY} -S rake compile_ext || die "extension compile failed"
+ fi
+}
+
+each_ruby_test() {
+ JSON=pure \
+ ${RUBY} -Iext:lib -S testrb tests/*.rb || die "pure ruby tests failed"
+
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ JSON=ext \
+ ${RUBY} -Iext:lib -S testrb tests/*.rb || die "ext ruby tests failed"
+ fi
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
+ ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
+ fi
+}