summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-02-22 07:18:06 +0000
committerHans de Graaff <graaff@gentoo.org>2012-02-22 07:18:06 +0000
commit5d830f345f793d55a32160aa85f22632287cf727 (patch)
treee677a49592e704a8a9000a7b2160ff99493aaf30 /dev-ruby
parentRestricting jython (diff)
downloadgentoo-2-5d830f345f793d55a32160aa85f22632287cf727.tar.gz
gentoo-2-5d830f345f793d55a32160aa85f22632287cf727.tar.bz2
gentoo-2-5d830f345f793d55a32160aa85f22632287cf727.zip
Version bump.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/amatch/ChangeLog9
-rw-r--r--dev-ruby/amatch/amatch-0.2.10.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-ruby/amatch/ChangeLog b/dev-ruby/amatch/ChangeLog
index 2c32f337ed92..2c56c3a712b9 100644
--- a/dev-ruby/amatch/ChangeLog
+++ b/dev-ruby/amatch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/amatch
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amatch/ChangeLog,v 1.27 2011/11/20 14:08:12 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amatch/ChangeLog,v 1.28 2012/02/22 07:18:06 graaff Exp $
+
+*amatch-0.2.10 (22 Feb 2012)
+
+ 22 Feb 2012; Hans de Graaff <graaff@gentoo.org> +amatch-0.2.10.ebuild:
+ Version bump.
20 Nov 2011; Hans de Graaff <graaff@gentoo.org> -amatch-0.2.6.ebuild,
-amatch-0.2.7.ebuild:
diff --git a/dev-ruby/amatch/amatch-0.2.10.ebuild b/dev-ruby/amatch/amatch-0.2.10.ebuild
new file mode 100644
index 000000000000..09fb45242f07
--- /dev/null
+++ b/dev-ruby/amatch/amatch-0.2.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amatch/amatch-0.2.10.ebuild,v 1.1 2012/02/22 07:18:06 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Approximate Matching Extension for Ruby"
+HOMEPAGE="http://flori.github.com/amatch/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/tins-0.3"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext
+ cp ext/amatch_ext$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb tests/* || die
+}