summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-04 20:40:07 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-04 20:40:07 +0000
commit6531b9276d12c8a648b0e6dc3d8dff319929d573 (patch)
treea29d516704ae527d52ded1f0f0e4c70b6ce73012 /dev-ruby
parentx86 stable wrt bug #347709 (diff)
downloadgentoo-2-6531b9276d12c8a648b0e6dc3d8dff319929d573.tar.gz
gentoo-2-6531b9276d12c8a648b0e6dc3d8dff319929d573.tar.bz2
gentoo-2-6531b9276d12c8a648b0e6dc3d8dff319929d573.zip
Version bump.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/thor/ChangeLog7
-rw-r--r--dev-ruby/thor/thor-0.14.6.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-ruby/thor/ChangeLog b/dev-ruby/thor/ChangeLog
index bb081a30a98d..248b780a360a 100644
--- a/dev-ruby/thor/ChangeLog
+++ b/dev-ruby/thor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/thor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/ChangeLog,v 1.6 2010/12/04 20:29:05 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/ChangeLog,v 1.7 2010/12/04 20:40:07 graaff Exp $
+
+*thor-0.14.6 (04 Dec 2010)
+
+ 04 Dec 2010; Hans de Graaff <graaff@gentoo.org> +thor-0.14.6.ebuild:
+ Version bump.
04 Dec 2010; Hans de Graaff <graaff@gentoo.org> -thor-0.14.2.ebuild:
Remove old version.
diff --git a/dev-ruby/thor/thor-0.14.6.ebuild b/dev-ruby/thor/thor-0.14.6.ebuild
new file mode 100644
index 000000000000..a96aed853ccf
--- /dev/null
+++ b/dev-ruby/thor/thor-0.14.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.14.6.ebuild,v 1.1 2010/12/04 20:40:07 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md"
+RUBY_FAKEGEM_BINWRAP="thor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A scripting framework that replaces rake and sake"
+HOMEPAGE="http://github.com/wycats/thor"
+
+SRC_URI="http://github.com/wycats/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/wycats-${PN}-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/fakeweb dev-ruby/rspec:2 )
+ doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ # Remove Bundler
+ rm Gemfile Gemfile.lock || die
+ sed -i -e '/[Bb]undler/d' Thorfile || die
+
+ # Remove mandatory coverage collection using simplecov which is not
+ # packaged.
+ sed -i -e '3,7d' spec/spec_helper.rb || die
+}
+
+all_ruby_compile() {
+ if use doc; then
+ ruby -Ilib bin/thor rdoc || die "RDoc generation failed"
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib/ bin/thor spec || die "Tests for ${RUBY} failed"
+}