summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-06 14:47:18 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-06 14:47:18 +0000
commit67824911e6aa2d8566cf4ed322cea1bfa3a544d0 (patch)
tree0db196034e25a166c3b9e8b8464c941337ea877a /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-67824911e6aa2d8566cf4ed322cea1bfa3a544d0.tar.gz
gentoo-2-67824911e6aa2d8566cf4ed322cea1bfa3a544d0.tar.bz2
gentoo-2-67824911e6aa2d8566cf4ed322cea1bfa3a544d0.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/gherkin/ChangeLog7
-rw-r--r--dev-ruby/gherkin/gherkin-2.3.7.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index a9ddad1f2e88..58c02e8f8753 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/gherkin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.18 2011/04/20 05:27:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.19 2011/05/06 14:47:18 graaff Exp $
+
+*gherkin-2.3.7 (06 May 2011)
+
+ 06 May 2011; Hans de Graaff <graaff@gentoo.org> +gherkin-2.3.7.ebuild:
+ Version bump.
*gherkin-2.3.6 (20 Apr 2011)
diff --git a/dev-ruby/gherkin/gherkin-2.3.7.ebuild b/dev-ruby/gherkin/gherkin-2.3.7.ebuild
new file mode 100644
index 000000000000..be756b08bd3e
--- /dev/null
+++ b/dev-ruby/gherkin/gherkin-2.3.7.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.3.7.ebuild,v 1.1 2011/05/06 14:47:18 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="-Ilib -rgherkin/version -f tasks/rdoc.rake rdoc"
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
+HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
+LICENSE="MIT"
+SRC_URI="https://github.com/aslakhellesoy/gherkin/tarball/v${PV} -> ${P}.tgz"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="${DEPEND} dev-util/ragel"
+RDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/aslakhellesoy-gherkin-*"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ test? (
+ >=dev-ruby/awesome_print-0.3
+ >=dev-ruby/builder-3.0.0
+ >=dev-util/cucumber-0.10.0
+ >=dev-ruby/rspec-2.5.0
+ >=dev-ruby/term-ansicolor-1.0.5
+ )"
+
+ruby_add_rdepend ">=dev-ruby/json-1.4.6"
+
+all_ruby_prepare() {
+ # Remove Bundler-related things.
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
+ rm Gemfile || die
+
+ # Don't use compile dependencies to avoid building again for specs.
+ sed -i -e '/:compile/d' Rakefile
+
+ # Remove feature that depends on direct access to the cucumber
+ # source We could probably set this up by downloading the source
+ # and unpacking it, but skipping this now in the interest of time.
+ rm features/pretty_formatter.feature || die
+
+ # We need to remove this tasks during bootstrapping since it tries
+ # to load cucumber already but we can be sure it isn't installed
+ # yet.
+ if ! use test ; then
+ rm tasks/cucumber.rake || die "Unable to remove cucumber tasks."
+ fi
+}
+
+each_ruby_compile() {
+ ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S rake spec || die "Specs failed"
+ CUCUMBER_HOME="${HOME}" ${RUBY} -S rake cucumber || die "Cucumber features failed"
+}