summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-06-26 08:32:27 +0000
committerHans de Graaff <graaff@gentoo.org>2015-06-26 08:32:27 +0000
commit67916cbe65ae9067bc55f54cc9e6acef345a8999 (patch)
tree7ed6a664010a59c8c8ddf286d41b078f87328ab4 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-67916cbe65ae9067bc55f54cc9e6acef345a8999.tar.gz
gentoo-2-67916cbe65ae9067bc55f54cc9e6acef345a8999.tar.bz2
gentoo-2-67916cbe65ae9067bc55f54cc9e6acef345a8999.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionview/ChangeLog7
-rw-r--r--dev-ruby/actionview/actionview-4.2.3.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/actionview/ChangeLog b/dev-ruby/actionview/ChangeLog
index e4e766a72726..59a873ebe232 100644
--- a/dev-ruby/actionview/ChangeLog
+++ b/dev-ruby/actionview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionview
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/ChangeLog,v 1.25 2015/06/26 06:26:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/ChangeLog,v 1.26 2015/06/26 08:32:27 graaff Exp $
+
+*actionview-4.2.3 (26 Jun 2015)
+
+ 26 Jun 2015; Hans de Graaff <graaff@gentoo.org> +actionview-4.2.3.ebuild:
+ Version bump.
*actionview-4.1.12 (26 Jun 2015)
diff --git a/dev-ruby/actionview/actionview-4.2.3.ebuild b/dev-ruby/actionview/actionview-4.2.3.ebuild
new file mode 100644
index 000000000000..719f6c282bfb
--- /dev/null
+++ b/dev-ruby/actionview/actionview-4.2.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/actionview-4.2.3.ebuild,v 1.1 2015/06/26 08:32:27 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Simple, battle-tested conventions and helpers for building web pages"
+HOMEPAGE="https://github.com/rails/rails/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1:* =dev-ruby/builder-3*:*
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/rails-html-sanitizer-1.0.1:1
+ >=dev-ruby/rails-dom-testing-1.0.5:1
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activemodel-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+}