summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-27 06:56:41 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-27 06:56:41 +0000
commit67e2852b5da03a7ca7801537a5274d6334809075 (patch)
tree96f19595637c7cdf807d9ac08be823dce0785814 /dev-ruby
parentadding ~arm (diff)
downloadgentoo-2-67e2852b5da03a7ca7801537a5274d6334809075.tar.gz
gentoo-2-67e2852b5da03a7ca7801537a5274d6334809075.tar.bz2
gentoo-2-67e2852b5da03a7ca7801537a5274d6334809075.zip
Version bump. Add ruby21.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/serialport/ChangeLog7
-rw-r--r--dev-ruby/serialport/serialport-1.3.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/serialport/ChangeLog b/dev-ruby/serialport/ChangeLog
index 93a96b2080a5..710231d54dcc 100644
--- a/dev-ruby/serialport/ChangeLog
+++ b/dev-ruby/serialport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/serialport
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/serialport/ChangeLog,v 1.14 2014/04/24 16:45:53 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/serialport/ChangeLog,v 1.15 2014/07/27 06:56:41 graaff Exp $
+
+*serialport-1.3.1 (27 Jul 2014)
+
+ 27 Jul 2014; Hans de Graaff <graaff@gentoo.org> +serialport-1.3.1.ebuild:
+ Version bump. Add ruby21.
24 Apr 2014; Manuel Rüger <mrueg@gentoo.org> serialport-1.3.0.ebuild:
Remove ruby18 support.
diff --git a/dev-ruby/serialport/serialport-1.3.1.ebuild b/dev-ruby/serialport/serialport-1.3.1.ebuild
new file mode 100644
index 000000000000..08a422f641f9
--- /dev/null
+++ b/dev-ruby/serialport/serialport-1.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/serialport/serialport-1.3.1.ebuild,v 1.1 2014/07/27 06:56:41 graaff Exp $
+
+EAPI=5
+
+# jruby → uses native library
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="a library for serial port (rs232) access in ruby"
+HOMEPAGE="http://rubyforge.org/projects/ruby-serialport/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Fix the miniterm script so that it might actually work, we'll
+ # install it as example.
+ sed -i -e 's:\.\./serialport.so:serialport:' test/miniterm.rb || die
+}
+
+each_ruby_configure() {
+ cd ext/native || die
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ pushd ext/native &>/dev/null
+ emake V=1
+ popd &>/dev/null
+
+ # Avoids the need for a specific install phase
+ cp ext/native/*$(get_modname) lib/ || die "extension copy failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # don't compress it
+ insinto /usr/share/doc/${PF}/examples
+ doins test/miniterm.rb
+}