summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-03-01 07:16:48 +0000
committerHans de Graaff <graaff@gentoo.org>2011-03-01 07:16:48 +0000
commit9550f5d190d0ff6a5854b9728a6bc388f360b69e (patch)
tree6588f3ca8275b74e9f8cd9020b68b4a4fce3fb07 /dev-ruby
parentVersion bump. The sound USE flag is global now. (diff)
downloadgentoo-2-9550f5d190d0ff6a5854b9728a6bc388f360b69e.tar.gz
gentoo-2-9550f5d190d0ff6a5854b9728a6bc388f360b69e.tar.bz2
gentoo-2-9550f5d190d0ff6a5854b9728a6bc388f360b69e.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hpricot/ChangeLog7
-rw-r--r--dev-ruby/hpricot/hpricot-0.8.4.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/hpricot/ChangeLog b/dev-ruby/hpricot/ChangeLog
index c27d2f86680d..74643286adae 100644
--- a/dev-ruby/hpricot/ChangeLog
+++ b/dev-ruby/hpricot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hpricot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/ChangeLog,v 1.27 2011/01/15 12:11:47 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/ChangeLog,v 1.28 2011/03/01 07:16:48 graaff Exp $
+
+*hpricot-0.8.4 (01 Mar 2011)
+
+ 01 Mar 2011; Hans de Graaff <graaff@gentoo.org> +hpricot-0.8.4.ebuild:
+ Version bump.
15 Jan 2011; Hans de Graaff <graaff@gentoo.org> -hpricot-0.8.2-r1.ebuild,
-hpricot-0.8.2-r2.ebuild:
diff --git a/dev-ruby/hpricot/hpricot-0.8.4.ebuild b/dev-ruby/hpricot/hpricot-0.8.4.ebuild
new file mode 100644
index 000000000000..a64cbe0c5faf
--- /dev/null
+++ b/dev-ruby/hpricot/hpricot-0.8.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.4.ebuild,v 1.1 2011/03/01 07:16:48 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A fast and liberal HTML parser for Ruby."
+HOMEPAGE="http://wiki.github.com/hpricot/hpricot"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# Probably needs the same jdk as JRuby but I'm not sure how to express
+# that just yet.
+DEPEND="${DEPEND}
+ dev-util/ragel
+ ruby_targets_jruby? ( >=virtual/jdk-1.5 )"
+
+ruby_add_bdepend "dev-ruby/rake
+ dev-ruby/rake-compiler
+ test? ( virtual/ruby-test-unit )"
+
+each_ruby_compile() {
+ case $(basename ${RUBY}) in
+ jruby)
+ ${RUBY} -S rake compile_java || die "rake compile failed"
+ ;;
+ *)
+ ${RUBY} -S rake compile || die "rake compile failed"
+ ;;
+ esac
+}