summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-04-23 11:01:51 +0000
committerTom William Payne <twp@gentoo.org>2003-04-23 11:01:51 +0000
commita15953eb4fab837fe00b5a20c4ca4e5b1d795ec3 (patch)
tree3b7945155da41c46f0f3244174f3d689b7f8ece4 /dev-ruby
parentbash can be upgraded (diff)
downloadgentoo-2-a15953eb4fab837fe00b5a20c4ca4e5b1d795ec3.tar.gz
gentoo-2-a15953eb4fab837fe00b5a20c4ca4e5b1d795ec3.tar.bz2
gentoo-2-a15953eb4fab837fe00b5a20c4ca4e5b1d795ec3.zip
Version bump.
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/fxruby/ChangeLog8
-rw-r--r--dev-ruby/fxruby/files/digest-fxruby-1.0.212
-rw-r--r--dev-ruby/fxruby/fxruby-1.0.21.ebuild26
3 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/fxruby/ChangeLog b/dev-ruby/fxruby/ChangeLog
index 19dcf0d2571a..31915b9c7a6f 100644
--- a/dev-ruby/fxruby/ChangeLog
+++ b/dev-ruby/fxruby/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for dev-ruby/fxruby
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.2 2003/02/12 06:35:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.3 2003/04/23 11:01:33 twp Exp $
+*fxruby-1.0.21 (23 Apr 2003)
+
+ 23 Apr 2003; Tom Payne <twp@gentoo.org> fxruby-1.0.21.ebuild :
+
+ Version bump. Minor ebuild tidying. Bug # 19476.
+
*fxruby-1.0.17 (27 Dec 2002)
27 Dec 2002; Ryan Phillips <rphillips@gentoo.org> : Initial release. Submitted by: Holden Glova
diff --git a/dev-ruby/fxruby/files/digest-fxruby-1.0.21 b/dev-ruby/fxruby/files/digest-fxruby-1.0.21
new file mode 100644
index 000000000000..58acc1df10c4
--- /dev/null
+++ b/dev-ruby/fxruby/files/digest-fxruby-1.0.21
@@ -0,0 +1,2 @@
+MD5 2635be8817a910689b8c0e0ccd243b3f /fxruby-1.0.21.ebuild 812
+MD5 109c04b84e8dec98013518468cf93c97 FXRuby-1.0.21.tar.gz 1736131
diff --git a/dev-ruby/fxruby/fxruby-1.0.21.ebuild b/dev-ruby/fxruby/fxruby-1.0.21.ebuild
new file mode 100644
index 000000000000..25cfc3b08c29
--- /dev/null
+++ b/dev-ruby/fxruby/fxruby-1.0.21.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.0.21.ebuild,v 1.1 2003/04/23 11:01:33 twp Exp $
+
+MY_P=FXRuby-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="FXRuby is the Ruby language binding to the FOX GUI toolkit."
+SRC_URI="mirror://sourceforge/fxruby/${MY_P}.tar.gz"
+HOMEPAGE="http://www.fxruby.org/"
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+DEPEND=">=dev-lang/ruby-1.6
+ >=x11-libs/fox-1.0.29"
+
+src_compile() {
+ ruby install.rb config --prefix=${D}/usr || die "Failed to configure FXRuby"
+ ruby install.rb setup || die "Failed to setup FXRuby"
+}
+
+src_install() {
+ ruby install.rb install || die "Failed to install FXRuby"
+
+ dodoc [A-Z]*
+ cp -dr examples doc ${D}/usr/share/doc/${PF}
+}