summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2013-10-06 10:21:21 +0000
committerMatti Bickel <mabi@gentoo.org>2013-10-06 10:21:21 +0000
commitb40eca7b587d9013640d531134ec1ee12a316bf9 (patch)
tree4658b4617040c458091802e13e4829f0f6e81404 /dev-ruby
parentStable for ia64, wrt bug #386335 (diff)
downloadgentoo-2-b40eca7b587d9013640d531134ec1ee12a316bf9.tar.gz
gentoo-2-b40eca7b587d9013640d531134ec1ee12a316bf9.tar.bz2
gentoo-2-b40eca7b587d9013640d531134ec1ee12a316bf9.zip
fix compile error by referencing fxscintilla.so instead of non-existent fxscintilla-1.6 (bug #430526)
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key 0x4849EC6C)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/fxruby/ChangeLog7
-rw-r--r--dev-ruby/fxruby/fxruby-1.6.25.ebuild4
-rw-r--r--dev-ruby/fxruby/fxruby-1.6.28.ebuild4
3 files changed, 8 insertions, 7 deletions
diff --git a/dev-ruby/fxruby/ChangeLog b/dev-ruby/fxruby/ChangeLog
index 84432b49e183..c7b55410cdae 100644
--- a/dev-ruby/fxruby/ChangeLog
+++ b/dev-ruby/fxruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fxruby
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.114 2013/09/05 00:04:43 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.115 2013/10/06 10:21:21 mabi Exp $
+
+ 06 Oct 2013; Matti Bickel <mabi@gentoo.org> fxruby-1.6.25.ebuild,
+ fxruby-1.6.28.ebuild:
+ fix compile error by referencing fxscintilla.so instead of non-existent
+ fxscintilla-1.6 (bug #430526)
05 Sep 2013; Manuel Rüger <mrueg@gentoo.org> -fxruby-1.6.26.ebuild,
-fxruby-1.6.27.ebuild:
diff --git a/dev-ruby/fxruby/fxruby-1.6.25.ebuild b/dev-ruby/fxruby/fxruby-1.6.25.ebuild
index 53503db547ec..d2b4c72b0ebf 100644
--- a/dev-ruby/fxruby/fxruby-1.6.25.ebuild
+++ b/dev-ruby/fxruby/fxruby-1.6.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.25.ebuild,v 1.10 2013/01/08 08:47:15 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.25.ebuild,v 1.11 2013/10/06 10:21:21 mabi Exp $
EAPI=4
USE_RUBY="ruby18 ruby19"
@@ -31,8 +31,6 @@ ruby_add_bdepend "dev-ruby/hoe"
all_ruby_prepare() {
sed -i -e '/\[:compile\]/d' Rakefile || die
- sed -i -e 's:libs, "fxscintilla":libs, "fxscintilla-1.6":g' \
- ext/fox16/extconf.rb || die "sed error"
einfo "Avoid -O0 builds"
sed -i -e 's:-O0 -I:-I:' \
ext/fox16/extconf.rb || die "Can't fix forced -O0"
diff --git a/dev-ruby/fxruby/fxruby-1.6.28.ebuild b/dev-ruby/fxruby/fxruby-1.6.28.ebuild
index ced851c9b3a2..f4cc92253f24 100644
--- a/dev-ruby/fxruby/fxruby-1.6.28.ebuild
+++ b/dev-ruby/fxruby/fxruby-1.6.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.28.ebuild,v 1.1 2013/07/17 06:44:59 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.28.ebuild,v 1.2 2013/10/06 10:21:21 mabi Exp $
EAPI=5
USE_RUBY="ruby18 ruby19"
@@ -31,8 +31,6 @@ ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
all_ruby_prepare() {
sed -i -e '/\[:compile\]/d' Rakefile || die
- sed -i -e 's:libs, "fxscintilla":libs, "fxscintilla-1.6":g' \
- ext/fox16_c/extconf.rb || die "sed error"
einfo "Avoid -O0 builds"
sed -i -e 's:-O0 -I:-I:' \
ext/fox16_c/extconf.rb || die "Can't fix forced -O0"