summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-30 21:35:42 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-30 21:35:42 +0000
commitb63c0cfbb88487ee739fa018f1a89042ecdc367d (patch)
tree5ee70b432a6c66bd291d607b70ffd648802b2593 /dev-ruby
parentDeal with github changing their tarball generation. (diff)
downloadgentoo-2-b63c0cfbb88487ee739fa018f1a89042ecdc367d.tar.gz
gentoo-2-b63c0cfbb88487ee739fa018f1a89042ecdc367d.tar.bz2
gentoo-2-b63c0cfbb88487ee739fa018f1a89042ecdc367d.zip
Fix documentation build if RSpec is not present.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/oauth2/ChangeLog6
-rw-r--r--dev-ruby/oauth2/files/oauth2-0.0.8-gentoo.patch31
-rw-r--r--dev-ruby/oauth2/oauth2-0.0.8.ebuild4
3 files changed, 38 insertions, 3 deletions
diff --git a/dev-ruby/oauth2/ChangeLog b/dev-ruby/oauth2/ChangeLog
index 563acf540e62..e7430abc79c9 100644
--- a/dev-ruby/oauth2/ChangeLog
+++ b/dev-ruby/oauth2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/oauth2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.2 2010/04/30 20:24:03 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.3 2010/04/30 21:35:42 flameeyes Exp $
+
+ 30 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org> oauth2-0.0.8.ebuild,
+ +files/oauth2-0.0.8-gentoo.patch:
+ Fix documentation build if RSpec is not present.
30 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org> oauth2-0.0.8.ebuild:
Add Ruby 1.9 support.
diff --git a/dev-ruby/oauth2/files/oauth2-0.0.8-gentoo.patch b/dev-ruby/oauth2/files/oauth2-0.0.8-gentoo.patch
new file mode 100644
index 000000000000..633338d8cb30
--- /dev/null
+++ b/dev-ruby/oauth2/files/oauth2-0.0.8-gentoo.patch
@@ -0,0 +1,31 @@
+diff --git a/Rakefile b/Rakefile
+index 0667c9c..0a135d5 100644
+--- a/Rakefile
++++ b/Rakefile
+@@ -15,10 +15,13 @@ begin
+ # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
+ end
+ Jeweler::GemcutterTasks.new
++
++ task :spec => :check_dependencies
+ rescue LoadError
+ puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
+ end
+
++begin
+ require 'spec/rake/spectask'
+ Spec::Rake::SpecTask.new(:spec) do |spec|
+ spec.libs << 'lib' << 'spec'
+@@ -31,9 +34,10 @@ Spec::Rake::SpecTask.new(:rcov) do |spec|
+ spec.rcov = true
+ end
+
+-task :spec => :check_dependencies
+-
+ task :default => :spec
++rescue LoadError
++ puts "RSpec (or a dependency) not available. Install it with: gem install rspec"
++end
+
+ require 'rake/rdoctask'
+ Rake::RDocTask.new do |rdoc|
diff --git a/dev-ruby/oauth2/oauth2-0.0.8.ebuild b/dev-ruby/oauth2/oauth2-0.0.8.ebuild
index 4f4c87e4fc9b..d559ae8bf455 100644
--- a/dev-ruby/oauth2/oauth2-0.0.8.ebuild
+++ b/dev-ruby/oauth2/oauth2-0.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.0.8.ebuild,v 1.2 2010/04/30 20:24:03 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.0.8.ebuild,v 1.3 2010/04/30 21:35:42 flameeyes Exp $
EAPI="2"
@@ -26,5 +26,5 @@ ruby_add_rdepend "dev-ruby/faraday"
ruby_add_bdepend test ">=dev-ruby/rspec-1.2.9"
all_ruby_prepare() {
- sed -i -e '/check_dependencies/d' Rakefile || die
+ epatch "${FILESDIR}"/${P}-gentoo.patch
}