summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-06-24 05:37:27 +0000
committerHans de Graaff <graaff@gentoo.org>2015-06-24 05:37:27 +0000
commitd4f4cda34f49b7a2aa764a166c7e8bbe4302ca63 (patch)
treebc4a0dab7cdc4fecec1d83de5576d3bd06991c37 /dev-ruby
parentEmit PIC when USE=qt5 (bug #552440 by octoploid). (diff)
downloadgentoo-2-d4f4cda34f49b7a2aa764a166c7e8bbe4302ca63.tar.gz
gentoo-2-d4f4cda34f49b7a2aa764a166c7e8bbe4302ca63.tar.bz2
gentoo-2-d4f4cda34f49b7a2aa764a166c7e8bbe4302ca63.zip
Version bump. Add ruby22.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/gherkin/ChangeLog8
-rw-r--r--dev-ruby/gherkin/files/gherkin-2.12.2-ruby21.patch44
-rw-r--r--dev-ruby/gherkin/gherkin-2.12.2.ebuild93
3 files changed, 144 insertions, 1 deletions
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index 84f5047c9e88..7384f6a30153 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/gherkin
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.85 2015/06/07 17:51:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.86 2015/06/24 05:37:27 graaff Exp $
+
+*gherkin-2.12.2 (24 Jun 2015)
+
+ 24 Jun 2015; Hans de Graaff <graaff@gentoo.org> +gherkin-2.12.2.ebuild,
+ +files/gherkin-2.12.2-ruby21.patch:
+ Version bump. Add ruby22.
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-ruby/gherkin/files/gherkin-2.12.2-ruby21.patch b/dev-ruby/gherkin/files/gherkin-2.12.2-ruby21.patch
new file mode 100644
index 000000000000..f767b1f1a2e4
--- /dev/null
+++ b/dev-ruby/gherkin/files/gherkin-2.12.2-ruby21.patch
@@ -0,0 +1,44 @@
+commit 021309d273960bb5625f8072b8366eab7d077d25
+Author: Cédric Boutillier <boutil@debian.org>
+Date: Fri Apr 25 13:34:41 2014 +0200
+
+ change regexp matchin Ruby versions to support Ruby2.1
+
+diff --git a/lib/gherkin/formatter/pretty_formatter.rb b/lib/gherkin/formatter/pretty_formatter.rb
+index 28c8b54..ff13c70 100644
+--- a/lib/gherkin/formatter/pretty_formatter.rb
++++ b/lib/gherkin/formatter/pretty_formatter.rb
+@@ -199,7 +199,7 @@ module Gherkin
+ end
+ end
+
+- if(RUBY_VERSION =~ /^1\.9|2\.0/)
++ if(RUBY_VERSION =~ /^(1\.9|2\.)/)
+ START = /#{'^'.encode('UTF-8')}/
+ TRIPLE_QUOTES = /#{'"""'.encode('UTF-8')}/
+ else
+diff --git a/ragel/lexer.rb.rl.erb b/ragel/lexer.rb.rl.erb
+index 7fd85b4..4be053e 100644
+--- a/ragel/lexer.rb.rl.erb
++++ b/ragel/lexer.rb.rl.erb
+@@ -165,7 +165,7 @@ module Gherkin
+ utf8_pack(rest[0..rest.index(10)||-1]).strip # 10 is \n
+ end
+
+- if (RUBY_VERSION =~ /^1\.9|2\.0/)
++ if (RUBY_VERSION =~ /^(1\.9|2\.)/)
+ def utf8_pack(array)
+ array.pack("c*").force_encoding("UTF-8")
+ end
+diff --git a/spec/spec_helper.rb b/spec/spec_helper.rb
+index 72333a7..0f6e3ae 100644
+--- a/spec/spec_helper.rb
++++ b/spec/spec_helper.rb
+@@ -6,6 +6,6 @@ def silence_warnings(&block)
+-if RUBY_VERSION =~ /1\.9|2\.0/
++if RUBY_VERSION =~ /^(1\.9|2\.)/
+ silence_warnings do
+ Encoding.default_external = Encoding::UTF_8
+ Encoding.default_internal = Encoding::UTF_8
+ end
+ end
diff --git a/dev-ruby/gherkin/gherkin-2.12.2.ebuild b/dev-ruby/gherkin/gherkin-2.12.2.ebuild
new file mode 100644
index 000000000000..d17ea0db5eae
--- /dev/null
+++ b/dev-ruby/gherkin/gherkin-2.12.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.12.2.ebuild,v 1.1 2015/06/24 05:37:27 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast Gherkin lexer and parser based on Ragel"
+HOMEPAGE="https://github.com/cucumber/gherkin"
+LICENSE="MIT"
+SRC_URI="https://github.com/cucumber/gherkin/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="${DEPEND} dev-util/ragel"
+RDEPEND="${RDEPEND}"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ test? (
+ >=dev-ruby/builder-2.1.2
+ >=dev-util/cucumber-1.1.3
+ >=dev-ruby/rspec-2.6.0
+ >=dev-ruby/term-ansicolor-1.0.5
+ )
+ doc? ( >=dev-ruby/yard-0.8.3 )"
+
+ruby_add_rdepend ">=dev-ruby/multi_json-1.3"
+
+RUBY_PATCHES=( ${P}-ruby21.patch )
+
+all_ruby_prepare() {
+ # Remove Bundler-related things.
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
+ rm Gemfile || die
+
+ # Don't use compile dependencies to avoid building again for specs.
+ sed -i -e '/:compile/d' Rakefile
+
+ # Keep this hardcoded -O0 optimization level since
+ # https://github.com/cucumber/gherkin/issues/182#issuecomment-6945009
+ # hints at the fact that removing it might cause the mysterious
+ # Lexer errors that hapen intermittently.
+ # sed -ie -e 's/-O0//' tasks/compile.rake || die
+
+ # Remove feature that depends on direct access to the cucumber
+ # source. We could probably set this up by downloading the source
+ # and unpacking it, but skipping this now in the interest of time.
+ rm features/pretty_formatter.feature || die
+
+ # We need to remove these tasks during bootstrapping since it tries
+ # to load cucumber already but we can be sure it isn't installed
+ # yet. Also remove other rake tasks for which we may not yet have
+ # dependencies.
+ if ! use test ; then
+ rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
+ fi
+
+ # Avoid dependency on yard if USE=-doc
+ if ! use doc ; then
+ rm tasks/apidoc.rake || die
+ fi
+
+ # Avoid implicit dependency on git
+ sed -i -e 's/git ls-files/echo/' gherkin.gemspec || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die
+ fi
+}
+
+each_ruby_compile() {
+ ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I lib -S rspec-2 spec || die "Specs failed"
+ CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
+}