summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2010-08-30 22:30:08 +0000
committerMark Loeser <halcy0n@gentoo.org>2010-08-30 22:30:08 +0000
commitefdd4195a081417cabac15a581768d72a2cba4ba (patch)
treeab9bf6aeb5e5f4d7aec3a1e7ea6e0343c15ede65 /dev-ruby
parentVersion bump that works with newer x11-drivers/nvidia-drivers that provides i... (diff)
downloadgentoo-2-efdd4195a081417cabac15a581768d72a2cba4ba.tar.gz
gentoo-2-efdd4195a081417cabac15a581768d72a2cba4ba.tar.bz2
gentoo-2-efdd4195a081417cabac15a581768d72a2cba4ba.zip
Add version 1.2.2 back since app-admin/chef-* depends upon it
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/json/ChangeLog5
-rw-r--r--dev-ruby/json/json-1.2.2.ebuild65
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index b703c7f267ae..80218ade17b4 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.41 2010/08/28 14:22:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.42 2010/08/30 22:30:08 halcy0n Exp $
+
+ 30 Aug 2010; Mark Loeser <halcy0n@gentoo.org> +json-1.2.2.ebuild:
+ Add version 1.2.2 back since app-admin/chef-* depends upon it
*json-1.4.6 (28 Aug 2010)
diff --git a/dev-ruby/json/json-1.2.2.ebuild b/dev-ruby/json/json-1.2.2.ebuild
new file mode 100644
index 000000000000..12fa8c6c369c
--- /dev/null
+++ b/dev-ruby/json/json-1.2.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.2.2.ebuild,v 1.8 2010/08/30 22:30:08 halcy0n Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A JSON implementation as a Ruby extension."
+HOMEPAGE="http://json.rubyforge.org/"
+LICENSE="|| ( Ruby GPL-2 )"
+SRC_URI="mirror://rubygems/${P}.gem"
+
+KEYWORDS="amd64 ~hppa ia64 ~ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND}"
+DEPEND="${DEPEND}
+ dev-util/ragel"
+
+ruby_add_bdepend "dev-ruby/rake
+ test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # Avoid building the extension twice!
+ sed -i \
+ -e 's| => :compile_ext||' \
+ -e 's| => :clean||' \
+ Rakefile || die "rakefile fix failed"
+}
+
+each_ruby_compile() {
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ${RUBY} -S rake compile_ext || die "extension compile failed"
+ fi
+}
+
+each_ruby_test() {
+ # We have to set RUBYLIB because otherwise the tests will run
+ # against the sytem-installed json; at the same time, we cannot
+ # use the -I parameter because rake won't let it pass to the
+ # testrb call that is executed down the road.
+
+ RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
+ ${RUBY} -S rake test_pure || die "pure ruby tests failed"
+
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
+ ${RUBY} -Ilib:ext/json/ext -S rake test_ext || die " ruby extension tests failed"
+ fi
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ruby_fakegem_newins ext/json/ext/generator.so lib/json/generator.so
+ ruby_fakegem_newins ext/json/ext/parser.so lib/json/parser.so
+ fi
+}