summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-15 07:49:10 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-15 07:49:10 +0000
commitf2b35cea595347855f533aca030dba8f7c2f954c (patch)
treedc7ae7ae71ece0fc653a656f2ab3542330aabac8 /dev-ruby
parentVersion bump for rails 2.3.10. (diff)
downloadgentoo-2-f2b35cea595347855f533aca030dba8f7c2f954c.tar.gz
gentoo-2-f2b35cea595347855f533aca030dba8f7c2f954c.tar.bz2
gentoo-2-f2b35cea595347855f533aca030dba8f7c2f954c.zip
Version bump for rails 2.3.10.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-2.3.10.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 079cdb610c7f..6324d0ea876b 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.68 2010/09/29 22:28:47 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.69 2010/10/15 07:49:10 graaff Exp $
+
+*activeresource-2.3.10 (15 Oct 2010)
+
+ 15 Oct 2010; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-2.3.10.ebuild:
+ Version bump for rails 2.3.10.
29 Sep 2010; Brent Baude <ranger@gentoo.org> activeresource-2.3.8.ebuild:
Marking activeresource-2.3.8 ~ppc64 for bug 322175
diff --git a/dev-ruby/activeresource/activeresource-2.3.10.ebuild b/dev-ruby/activeresource/activeresource-2.3.10.ebuild
new file mode 100644
index 000000000000..05a1bc966ce8
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-2.3.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-2.3.10.ebuild,v 1.1 2010/10/15 07:49:10 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ !dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}