summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-04 15:46:19 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-04 15:46:19 +0000
commitff154cc1e5b0c1e87614727d66b6e04f515835bc (patch)
tree00940dd64b04647a247ea241cd4a71568ec5eee4 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-ff154cc1e5b0c1e87614727d66b6e04f515835bc.tar.gz
gentoo-2-ff154cc1e5b0c1e87614727d66b6e04f515835bc.tar.bz2
gentoo-2-ff154cc1e5b0c1e87614727d66b6e04f515835bc.zip
Version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/parser/ChangeLog7
-rw-r--r--dev-ruby/parser/parser-2.2.0_pre5.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ruby/parser/ChangeLog b/dev-ruby/parser/ChangeLog
index b45c6c244d30..df67f35ce406 100644
--- a/dev-ruby/parser/ChangeLog
+++ b/dev-ruby/parser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/parser
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parser/ChangeLog,v 1.2 2014/09/04 01:50:18 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parser/ChangeLog,v 1.3 2014/10/04 15:46:19 mrueg Exp $
+
+*parser-2.2.0_pre5 (04 Oct 2014)
+
+ 04 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +parser-2.2.0_pre5.ebuild:
+ Version bump.
04 Sep 2014; Manuel Rüger <mrueg@gentoo.org> parser-2.2.0_pre4.ebuild:
Fix typo.
diff --git a/dev-ruby/parser/parser-2.2.0_pre5.ebuild b/dev-ruby/parser/parser-2.2.0_pre5.ebuild
new file mode 100644
index 000000000000..f766bb439347
--- /dev/null
+++ b/dev-ruby/parser/parser-2.2.0_pre5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parser/parser-2.2.0_pre5.ebuild,v 1.1 2014/10/04 15:46:19 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_VERSION="${PV/_pre/.pre.}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A production-ready Ruby parser written in pure Ruby"
+HOMEPAGE="https://github.com/whitequark/parser"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest:5
+ dev-ruby/racc
+ dev-ruby/cliver )"
+ruby_add_rdepend "dev-ruby/ast
+ dev-ruby/slop:3"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/simplecov/,+35d" test/helper.rb || die
+}