summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2011-08-13 11:41:37 +0000
committerAkinori Hattori <hattya@gentoo.org>2011-08-13 11:41:37 +0000
commit61e78dacecd2850426fb90fe83660dfe9b1131c4 (patch)
tree603602a89bac4172e687072ca1dbf0ccfe0995f4 /dev-scheme/c-wrapper/files
parentmake eclass ready for 4.8.0_beta releases (diff)
downloadgentoo-2-61e78dacecd2850426fb90fe83660dfe9b1131c4.tar.gz
gentoo-2-61e78dacecd2850426fb90fe83660dfe9b1131c4.tar.bz2
gentoo-2-61e78dacecd2850426fb90fe83660dfe9b1131c4.zip
update to EAPI 4. depend on dev-libs/libffi for fixing runtime error.
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'dev-scheme/c-wrapper/files')
-rw-r--r--dev-scheme/c-wrapper/files/c-wrapper-system-libffi.diff33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-scheme/c-wrapper/files/c-wrapper-system-libffi.diff b/dev-scheme/c-wrapper/files/c-wrapper-system-libffi.diff
new file mode 100644
index 000000000000..7ee9a4011ef3
--- /dev/null
+++ b/dev-scheme/c-wrapper/files/c-wrapper-system-libffi.diff
@@ -0,0 +1,33 @@
+--- c-wrapper-0.6.1.orig/configure.ac
++++ c-wrapper-0.6.1/configure.ac
+@@ -53,6 +53,7 @@
+
+ dnl Check for libraries
+ dnl Add your macro calls to check required libraries, if you have any.
++PKG_CHECK_MODULES([FFI], [libffi])
+
+ dnl Platform-dependent configuration.
+ AC_ARG_ENABLE(objc, [ --enable-objc turn on Objective-C support])
+--- c-wrapper-0.6.1.orig/src/Makefile.in
++++ c-wrapper-0.6.1/src/Makefile.in
+@@ -20,9 +20,9 @@
+ GAUCHE_PACKAGE = @GAUCHE_PACKAGE@
+ INSTALL = @GAUCHE_INSTALL@
+
+-CPPFLAGS = -I./libffi/include -DGAUCHE_API_0_8_8 @CPPFLAGS@
++CPPFLAGS = -DGAUCHE_API_0_8_8 @FFI_CFLAGS@ @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+-LIBS = libffi/.libs/libffi.a @LIBS@
++LIBS = @FFI_LIBS@ @LIBS@
+
+ YACC = @YACC@
+
+@@ -38,7 +38,7 @@
+ SCMFILES =
+ HEADERS =
+
+-TARGET = libffi/.libs/libffi.a $(ARCHFILES)
++TARGET = $(ARCHFILES)
+ GENERATED = libffi
+ CONFIG_GENERATED = libffi/Makefile Makefile cwcompile
+