summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-09-02 11:43:22 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-09-02 11:43:22 +0000
commit8dd109bdcb48f6f8cb782aa388ae65189373c2f3 (patch)
tree54dd79f9d54b5fac0c04ba63eb91f1a46af59765 /dev-scheme/gambit
parentParallel make seems to fail as per bug #134802. Disable it. (diff)
downloadgentoo-2-8dd109bdcb48f6f8cb782aa388ae65189373c2f3.tar.gz
gentoo-2-8dd109bdcb48f6f8cb782aa388ae65189373c2f3.tar.bz2
gentoo-2-8dd109bdcb48f6f8cb782aa388ae65189373c2f3.zip
add static use flag and move the gambcext config file to /etc where it should be automatically config-protected (both after a request from Etienne Bergeron <bergeret@iro.umontreal.ca>). Don't force -O1 anymore and move single-host to big-iron as otherwise it crashes my machine as it runs out of memory. Fix big-iron for beta22.
(Portage version: 2.1.3.7)
Diffstat (limited to 'dev-scheme/gambit')
-rw-r--r--dev-scheme/gambit/ChangeLog10
-rw-r--r--dev-scheme/gambit/gambit-4.0.0.ebuild32
-rw-r--r--dev-scheme/gambit/gambit-4.0_beta22.ebuild4
3 files changed, 33 insertions, 13 deletions
diff --git a/dev-scheme/gambit/ChangeLog b/dev-scheme/gambit/ChangeLog
index 7fc065eec61a..64164bfe37c0 100644
--- a/dev-scheme/gambit/ChangeLog
+++ b/dev-scheme/gambit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-scheme/gambit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.10 2007/08/26 09:49:51 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.11 2007/09/02 11:43:22 hkbst Exp $
+
+ 02 Sep 2007; Marijn Schouten <hkBst@gentoo.org> gambit-4.0_beta22.ebuild,
+ gambit-4.0.0.ebuild:
+ add static use flag and move the gambcext config file to /etc where it
+ should be automatically config-protected (both after a request from Etienne
+ Bergeron <bergeret@iro.umontreal.ca>). Don't force -O1 anymore and move
+ single-host to big-iron as otherwise it crashes my machine as it runs out of
+ memory. Fix big-iron for beta22.
*gambit-4.0.0 (26 Aug 2007)
diff --git a/dev-scheme/gambit/gambit-4.0.0.ebuild b/dev-scheme/gambit/gambit-4.0.0.ebuild
index 746c946411ad..05e28aea7245 100644
--- a/dev-scheme/gambit/gambit-4.0.0.ebuild
+++ b/dev-scheme/gambit/gambit-4.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0.0.ebuild,v 1.1 2007/08/26 09:49:51 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0.0.ebuild,v 1.2 2007/09/02 11:43:22 hkbst Exp $
inherit eutils elisp-common check-reqs autotools multilib
@@ -22,19 +22,25 @@ SITEFILE="50gambit-gentoo.el"
S=${WORKDIR}/${MY_P}
-IUSE="emacs big-iron"
+IUSE="big-iron emacs static"
pkg_setup() {
if ! use big-iron; then
- ewarn "not using gcc specific optimizations and not compiling syntax-case macro system"
+ ewarn "NOT compiling each Scheme module as a single C function"
+ ewarn "NOT using gcc specific optimizations"
+ ewarn "NOT compiling syntax-case macro system"
ewarn "approximately 0.5GB ram will be needed"
- ewarn "if you experience thrashing, try disabling parallel building"
+ ewarn "if you experience thrashing, try disabling parallel building or setting -O1"
# need this much memory in MBytes (does *not* check swap)
CHECKREQS_MEMORY="768" check_reqs
else
- ewarn "using gcc specific optimizations and compiling syntax-case macro system"
- ewarn "this will cause approximately 2GB ram to be used instead of 0.5GB."
- ewarn "this will cause heavy thrashing of your system unless your system is big iron"
+ ewarn "compiling each Scheme module as a single C function"
+ ewarn "using gcc specific optimizations"
+ ewarn "compiling syntax-case macro system"
+ ewarn "approximately 2GB ram will be needed instead of 0.5GB"
+ ewarn "this will cause heavy thrashing of your system"
+ ewarn "and may cause your compiler to crash when it runs out of memory"
+ ewarn "unless your system is BIG IRON"
# need this much memory in MBytes (does *not* check swap)
CHECKREQS_MEMORY="2560" check_reqs
fi
@@ -45,12 +51,15 @@ src_unpack() {
# cp configure.ac configure.ac.old
sed -e 's:PACKAGE_SUBDIR="/$PACKAGE_VERSION"::' \
-e 's:#PACKAGE_SUBDIR="":PACKAGE_SUBDIR="":' -i configure.ac
+ #don't force -O1
+ sed 's:$DASH_O1::' -i configure.ac
eautoreconf
# diff -u configure.ac.old configure.ac
}
src_compile() {
- econf --enable-shared --enable-single-host $(use_enable big-iron)
+ econf $(if use static; then echo --disable-shared; else echo --enable-shared; fi) \
+ $(use_enable big-iron single-host) $(use_enable big-iron gcc-opts)
emake || die "emake failed"
if use emacs; then
@@ -99,8 +108,11 @@ src_install() {
dosym gsi usr/bin/gambit-interpreter
# automatically load syntax-case for r5rs+ goodness
- dodir /etc/env.d/ && echo "GAMBCOPT=\"=/usr/\"" > ${D}/etc/env.d/50gambit
- echo "(load \"/usr/$(get_libdir)/syntax-case\")" > ${D}/usr/gambcext
+# dodir /etc/env.d/ && echo "GAMBCOPT=\"=/usr/\"" > ${D}/etc/env.d/50gambit
+ echo "GAMBCOPT=\"=/usr/\"" > "${T}/50gambit" && doenvd "${T}/50gambit"
+
+ dosym /etc/gambcext /usr/gambcext
+ echo "(load \"/usr/$(get_libdir)/syntax-case\")" > ${D}/etc/gambcext
}
pkg_postinst() {
diff --git a/dev-scheme/gambit/gambit-4.0_beta22.ebuild b/dev-scheme/gambit/gambit-4.0_beta22.ebuild
index e2fab9b276a2..b0af7743ad12 100644
--- a/dev-scheme/gambit/gambit-4.0_beta22.ebuild
+++ b/dev-scheme/gambit/gambit-4.0_beta22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0_beta22.ebuild,v 1.7 2007/07/09 13:37:31 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0_beta22.ebuild,v 1.8 2007/09/02 11:43:22 hkbst Exp $
inherit eutils elisp-common check-reqs autotools multilib
@@ -47,7 +47,7 @@ src_unpack() {
}
src_compile() {
- econf --enable-shared --enable-single-host $(use_enable big-iron)
+ econf --enable-shared --enable-single-host $(use_enable big-iron gcc-opts)
emake || die "emake failed"
if use emacs; then