summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-05-25 12:54:36 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-05-25 12:54:36 +0000
commitc7f35f01fa419af82ffdc86ecd0659ddc1c1047a (patch)
treeef111a55d2240f0953ac4968922f4538a213c98b /dev-scheme/guile
parentAdd missing gettext dep for bug 179675. (diff)
downloadgentoo-2-c7f35f01fa419af82ffdc86ecd0659ddc1c1047a.tar.gz
gentoo-2-c7f35f01fa419af82ffdc86ecd0659ddc1c1047a.tar.bz2
gentoo-2-c7f35f01fa419af82ffdc86ecd0659ddc1c1047a.zip
add freebsd fixes from flameeyes, bug 179728
(Portage version: 2.1.2.8)
Diffstat (limited to 'dev-scheme/guile')
-rw-r--r--dev-scheme/guile/ChangeLog7
-rw-r--r--dev-scheme/guile/files/guile-1.8.1-clog-cexp.patch43
-rw-r--r--dev-scheme/guile/files/guile-1.8.1-defaultincludes.patch12
-rw-r--r--dev-scheme/guile/guile-1.8.1-r3.ebuild10
4 files changed, 69 insertions, 3 deletions
diff --git a/dev-scheme/guile/ChangeLog b/dev-scheme/guile/ChangeLog
index a75b93a9b6a2..0097bda8e202 100644
--- a/dev-scheme/guile/ChangeLog
+++ b/dev-scheme/guile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/guile
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.18 2007/05/25 12:17:16 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.19 2007/05/25 12:54:36 hkbst Exp $
+
+ 25 May 2007; Marijn Schouten <hkBst@gentoo.org>
+ +files/guile-1.8.1-clog-cexp.patch,
+ +files/guile-1.8.1-defaultincludes.patch, guile-1.8.1-r3.ebuild:
+ add freebsd fixes from flameeyes, bug 179728
25 May 2007; Marijn Schouten <hkBst@gentoo.org> guile-1.6.8.ebuild:
re-enable -j1 for 1.6.8, bug 179738
diff --git a/dev-scheme/guile/files/guile-1.8.1-clog-cexp.patch b/dev-scheme/guile/files/guile-1.8.1-clog-cexp.patch
new file mode 100644
index 000000000000..24ada81d7471
--- /dev/null
+++ b/dev-scheme/guile/files/guile-1.8.1-clog-cexp.patch
@@ -0,0 +1,43 @@
+Index: guile-1.8.1/configure.in
+===================================================================
+--- guile-1.8.1.orig/configure.in
++++ guile-1.8.1/configure.in
+@@ -602,6 +602,7 @@ AC_CHECK_HEADERS([assert.h crt_externs.h
+ # (DINFINITY and DQNAN are actually global variables, not functions)
+ # chsize - an MS-DOS-ism, found in mingw
+ # clog10 - not in mingw (though others like clog and csqrt are)
++# clog,cexp - not in FreeBSD (though others are, like cabs)
+ # fesetround - available in C99, but not older systems
+ # ftruncate - posix, but probably not older systems (current mingw
+ # has it as an inline for chsize)
+@@ -614,7 +615,7 @@ AC_CHECK_HEADERS([assert.h crt_externs.h
+ # isblank - available as a GNU extension or in C99
+ # _NSGetEnviron - Darwin specific
+ #
+-AC_CHECK_FUNCS([DINFINITY DQNAN chsize clog10 ctermid fesetround ftime ftruncate fchown getcwd geteuid gettimeofday gmtime_r ioctl lstat mkdir mknod nice readdir_r readlink rename rmdir select setegid seteuid setlocale setpgid setsid sigaction siginterrupt stat64 strftime strptime symlink sync sysconf tcgetpgrp tcsetpgrp times uname waitpid strdup system usleep atexit on_exit chown link fcntl ttyname getpwent getgrent kill getppid getpgrp fork setitimer getitimer strchr strcmp index bcopy memcpy rindex truncate unsetenv isblank _NSGetEnviron])
++AC_CHECK_FUNCS([DINFINITY DQNAN chsize clog10 clog cexp ctermid fesetround ftime ftruncate fchown getcwd geteuid gettimeofday gmtime_r ioctl lstat mkdir mknod nice readdir_r readlink rename rmdir select setegid seteuid setlocale setpgid setsid sigaction siginterrupt stat64 strftime strptime symlink sync sysconf tcgetpgrp tcsetpgrp times uname waitpid strdup system usleep atexit on_exit chown link fcntl ttyname getpwent getgrent kill getppid getpgrp fork setitimer getitimer strchr strcmp index bcopy memcpy rindex truncate unsetenv isblank _NSGetEnviron])
+
+ # Reasons for testing:
+ # netdb.h - not in mingw
+Index: guile-1.8.1/libguile/numbers.c
+===================================================================
+--- guile-1.8.1.orig/libguile/numbers.c
++++ guile-1.8.1/libguile/numbers.c
+@@ -6018,7 +6018,7 @@ SCM_DEFINE (scm_log, "log", 1, 0, 0,
+ {
+ if (SCM_COMPLEXP (z))
+ {
+-#if HAVE_COMPLEX_DOUBLE
++#if HAVE_COMPLEX_DOUBLE && HAVE_CLOG
+ return scm_from_complex_double (clog (SCM_COMPLEX_VALUE (z)));
+ #else
+ double re = SCM_COMPLEX_REAL (z);
+@@ -6084,7 +6084,7 @@ SCM_DEFINE (scm_exp, "exp", 1, 0, 0,
+ {
+ if (SCM_COMPLEXP (z))
+ {
+-#if HAVE_COMPLEX_DOUBLE
++#if HAVE_COMPLEX_DOUBLE && HAVE_CEXP
+ return scm_from_complex_double (cexp (SCM_COMPLEX_VALUE (z)));
+ #else
+ return scm_c_make_polar (exp (SCM_COMPLEX_REAL (z)),
diff --git a/dev-scheme/guile/files/guile-1.8.1-defaultincludes.patch b/dev-scheme/guile/files/guile-1.8.1-defaultincludes.patch
new file mode 100644
index 000000000000..3adb844f2c32
--- /dev/null
+++ b/dev-scheme/guile/files/guile-1.8.1-defaultincludes.patch
@@ -0,0 +1,12 @@
+Index: guile-1.8.1/libguile/Makefile.am
+===================================================================
+--- guile-1.8.1.orig/libguile/Makefile.am
++++ guile-1.8.1/libguile/Makefile.am
+@@ -22,6 +22,7 @@
+ AUTOMAKE_OPTIONS = gnu
+
+ ## Prevent automake from adding extra -I options
++DEFAULT_INCLUDES =
+ DEFS = @DEFS@
+ ## Check for headers in $(srcdir)/.., so that #include
+ ## <libguile/MUMBLE.h> will find MUMBLE.h in this dir when we're
diff --git a/dev-scheme/guile/guile-1.8.1-r3.ebuild b/dev-scheme/guile/guile-1.8.1-r3.ebuild
index 9fc4aa65899c..dacf2d528bdf 100644
--- a/dev-scheme/guile/guile-1.8.1-r3.ebuild
+++ b/dev-scheme/guile/guile-1.8.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.1-r3.ebuild,v 1.1 2007/03/03 16:13:25 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.1-r3.ebuild,v 1.2 2007/05/25 12:54:36 hkbst Exp $
inherit eutils autotools
@@ -13,7 +13,9 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
DEPEND=">=dev-libs/gmp-4.1 >=sys-devel/libtool-1.5.6 sys-devel/gettext"
-# Guile seems to contain some slotting support, /usr/share/guile/ is slotted, but there are lots of collisions. Most in /usr/share/libguile. Therefore I'm slotting this in the same slot as guile-1.6* for now.
+# Guile seems to contain some slotting support, /usr/share/guile/ is slotted,
+# but there are lots of collisions. Most in /usr/share/libguile. Therefore
+# I'm slotting this in the same slot as guile-1.6* for now.
SLOT="12"
MAJOR="1.8"
@@ -30,6 +32,10 @@ src_unpack() {
# for lilypond 2.11.x
epatch ${FILESDIR}/guile-1.8-rational.patch
+
+ # for free-bsd, bug 179728
+ epatch $FILESDIR/guile-1.8.1-defaultincludes.patch
+ epatch $FILESDIR/guile-1.8.1-clog-cexp.patch
}
src_compile() {