summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2009-08-02 15:16:54 +0000
committerMarijn Schouten <hkbst@gentoo.org>2009-08-02 15:16:54 +0000
commitd910592e467bd020af00cc8817cda61674b5a693 (patch)
tree3e60ebb9d2b57251bf033f1b8f95d0a0342b01d5 /dev-scheme/plt-scheme
parentMarking pam_ssh-1.97-r1 ppc64 for bug 263579 (diff)
downloadgentoo-2-d910592e467bd020af00cc8817cda61674b5a693.tar.gz
gentoo-2-d910592e467bd020af00cc8817cda61674b5a693.tar.bz2
gentoo-2-d910592e467bd020af00cc8817cda61674b5a693.zip
bump
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-scheme/plt-scheme')
-rw-r--r--dev-scheme/plt-scheme/ChangeLog53
-rw-r--r--dev-scheme/plt-scheme/plt-scheme-4.2.1.ebuild91
2 files changed, 142 insertions, 2 deletions
diff --git a/dev-scheme/plt-scheme/ChangeLog b/dev-scheme/plt-scheme/ChangeLog
index f8f077988a70..70de1839483a 100644
--- a/dev-scheme/plt-scheme/ChangeLog
+++ b/dev-scheme/plt-scheme/ChangeLog
@@ -1,8 +1,57 @@
# ChangeLog for dev-scheme/plt-scheme
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/plt-scheme/ChangeLog,v 1.8 2009/06/04 15:35:12 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/plt-scheme/ChangeLog,v 1.9 2009/08/02 15:16:54 hkbst Exp $
-*plt-scheme-4.2 (04 Jun 2009)
+*plt-scheme-4.2.1 (02 Aug 2009)
+
+ 02 Aug 2009; Marijn Schouten <hkBst@gentoo.org> +plt-scheme-4.2.1.ebuild:
+ bump
+ * This is the last release that includes ProfessorJ. As of the
+ next release, Kathy Gray who created and maintained the
+ Professor will move the code to planet and maintain only at a
+ minimal level.
+
+ * Typed Scheme 2.0 extends the type system significantly, making
+ it more expressive. For example, predicates applied to
+ selectors, such as (number? (car x)), are meaningful to the type
+ system.
+
+ * Faster installation of Planet packages that trigger install of
+ other Planet packages, because the documentation index is
+ updated only once after a group of packages is installed.
+
+ * The `syntax/parse' library provides macro writers with an
+ enhanced syntax pattern matcher that reports errors based on the
+ patterns' declared classes of syntax.
+
+ * Identifier mappings following the v4 dictionary interface and
+ naming conventions are available from the `syntax/id-table'
+ library.
+
+ * Redex: added `define-relation' and generalized patterns that
+ appear in "where" clauses to use the full Redex pattern matcher.
+ (This is a backwards incompatible change, but one often
+ requested; see the Redex release notes for details.)
+
+ * The Web Server's serializable closures are now available for
+ other purposes through the web-server/lang/serial-lambda
+ library.
+
+ * Teachpacks: small changes to universe portion of the
+ "universe.ss" API, plus the addition of a form for launching
+ many (communicating) worlds simultaneously. Bug fixes
+ concerning conversion to strings.
+
+ * It is now possible to create custom scribble readers with a
+ command characters different than `@', see
+ `make-at-reader/inside' and `make-at-reader'
+
+ * Note: this is likely to be the last release that includes a
+ solaris distribution. If you need these builds, or if you have
+ access to a (Sparc) Solaris machine than can be used in PLT
+ builds, then please let me know.
+
+ *plt-scheme-4.2 (04 Jun 2009)
04 Jun 2009; Marijn Schouten <hkBst@gentoo.org> +plt-scheme-4.2.ebuild:
bump
diff --git a/dev-scheme/plt-scheme/plt-scheme-4.2.1.ebuild b/dev-scheme/plt-scheme/plt-scheme-4.2.1.ebuild
new file mode 100644
index 000000000000..cca81d08d556
--- /dev/null
+++ b/dev-scheme/plt-scheme/plt-scheme-4.2.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/plt-scheme/plt-scheme-4.2.1.ebuild,v 1.1 2009/08/02 15:16:54 hkbst Exp $
+
+inherit eutils latex-package
+
+SRC_URI="http://download.plt-scheme.org/bundles/${PV}/plt/plt-${PV}-src-unix.tgz
+ http://pre.plt-scheme.org/installers/plt-${PV}-src-unix.tgz"
+#"mirror://gentoo/plt-${PV%%_p*}-src-unix.tgz"
+
+DESCRIPTION="DrScheme programming environment. Includes mzscheme."
+HOMEPAGE="http://www.plt-scheme.org"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="backtrace cairo cgc llvm opengl profile X"
+
+RDEPEND="X? ( x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXaw
+ >=x11-libs/libXft-2.1.12
+ x11-libs/libXrender
+ media-libs/freetype
+ media-libs/fontconfig
+ cairo? ( x11-libs/cairo )
+ media-libs/jpeg
+ opengl? ( virtual/opengl )
+ media-libs/libpng
+ sys-libs/zlib )"
+
+DEPEND="${RDEPEND} !dev-tex/slatex"
+
+S="${WORKDIR}/plt-${PV%%_p*}/src"
+
+pkg_setup() {
+ if use cairo && use X; then
+ if ! built_with_use x11-libs/cairo X; then
+ eerror "Cairo must be built with X use flag"
+ die "Cairo must be built with X use flag"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ #remove bundled libraries
+ rm -rf wxcommon/{jpeg,libpng,zlib}
+
+ sed "s,docdir=\"\${datadir}/plt/doc,docdir=\"\${datadir}/doc/${PF}," -i configure || die
+}
+
+src_compile() {
+# according to vapier, we should use the bundled libtool
+# such that we don't preclude cross-compile. Thus don't use
+# --enable-lt=/usr/bin/libtool
+ econf $(use_enable X mred) \
+ --enable-shared \
+ --disable-perl \
+ $(use_enable backtrace) \
+ $(use_enable cairo) \
+ $(use_enable llvm) \
+ $(use_enable opengl gl) \
+ $(use_enable profile gprof) \
+ --enable-xft \
+ --enable-xrender
+
+ if use cgc; then
+ emake both || die "emake both failed"
+ else
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ # deal with slatex
+ insinto /usr/share/texmf/tex/latex/slatex/
+ doins ../collects/slatex/slatex.sty
+
+ if use cgc; then
+ emake DESTDIR="${D}" install-both || die "emake install-both failed"
+ else
+ emake DESTDIR="${D}" install || die "emake install failed"
+ fi
+
+ if use X; then
+ newicon ../collects/icons/PLT-206.png drscheme.png
+ make_desktop_entry drscheme "DrScheme" drscheme "Development"
+ fi
+}