summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-12-11 01:20:32 +0000
committerChris Reffett <creffett@gentoo.org>2013-12-11 01:20:32 +0000
commit795dc07669015daaa0b1076b4ac5948dfe06bf61 (patch)
tree11856573cdf9855cb2a120ed1b0b151995928848 /dev-scheme
parentReplace the RDEPEND with a PDEPEND - completely fix bug 489472. (diff)
downloadgentoo-2-795dc07669015daaa0b1076b4ac5948dfe06bf61.tar.gz
gentoo-2-795dc07669015daaa0b1076b4ac5948dfe06bf61.tar.bz2
gentoo-2-795dc07669015daaa0b1076b4ac5948dfe06bf61.zip
Security cleanup wrt bug 462458
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/chicken/ChangeLog6
-rw-r--r--dev-scheme/chicken/chicken-3.3.0.ebuild70
-rw-r--r--dev-scheme/chicken/chicken-4.6.0.ebuild53
-rw-r--r--dev-scheme/chicken/chicken-4.7.3-r1.ebuild67
-rw-r--r--dev-scheme/chicken/chicken-4.8.0.3.ebuild77
5 files changed, 5 insertions, 268 deletions
diff --git a/dev-scheme/chicken/ChangeLog b/dev-scheme/chicken/ChangeLog
index 692841b77c02..bfaf14af57a1 100644
--- a/dev-scheme/chicken/ChangeLog
+++ b/dev-scheme/chicken/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-scheme/chicken
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/chicken/ChangeLog,v 1.59 2013/07/14 14:18:38 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/chicken/ChangeLog,v 1.60 2013/12/11 01:20:32 creffett Exp $
+
+ 11 Dec 2013; Chris Reffett <creffett@gentoo.org> -chicken-3.3.0.ebuild,
+ -chicken-4.6.0.ebuild, -chicken-4.7.3-r1.ebuild, -chicken-4.8.0.3.ebuild:
+ Security cleanup wrt bug 462458
14 Jul 2013; Agostino Sarubbo <ago@gentoo.org> chicken-4.8.0.3-r1.ebuild:
Stable for alpha, wrt bug #476172
diff --git a/dev-scheme/chicken/chicken-3.3.0.ebuild b/dev-scheme/chicken/chicken-3.3.0.ebuild
deleted file mode 100644
index dde164bf6494..000000000000
--- a/dev-scheme/chicken/chicken-3.3.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/chicken/chicken-3.3.0.ebuild,v 1.6 2009/09/14 06:36:11 araujo Exp $
-
-inherit multilib elisp-common
-
-DESCRIPTION="Chicken is a Scheme interpreter and native Scheme to C compiler"
-SRC_URI="http://chicken.wiki.br/releases/${PV}/${P}.tar.gz"
-HOMEPAGE="http://www.call-with-current-continuation.org/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc64 x86"
-IUSE="emacs"
-
-DEPEND=">=dev-libs/libpcre-7.6
- sys-apps/texinfo
- emacs? ( virtual/emacs )"
-RDEPEND="${DEPEND}"
-
-SITEFILE=50hen-gentoo.el
-
-src_unpack() {
- unpack ${A}; cd "${S}"
- sed "s:/lib:/$(get_libdir):g" -i defaults.make
-}
-
-src_compile() {
- # $A is used by the makefile so >_>
- unset A
-
- OPTIONS="PLATFORM=linux PREFIX=/usr USE_HOST_PCRE=1"
- echo $OPTIONS
- emake ${OPTIONS} C_COMPILER_OPTIMIZATION_OPTIONS="${CFLAGS}" || die
-
- if use emacs; then
- elisp-compile hen.el || die
- fi
-}
-
-# chicken doesn't seem to honor CHICKEN_PREFIX CHICKEN_HOME or LD_LIBRARY_PATH=${S}/.libs/
-RESTRICT=test
-#src_test() {
-# cd tests
-# bash runtests.sh
-#}
-
-src_install() {
- unset A
-
- emake ${OPTIONS} DESTDIR="${D}" install || die
- dodoc ChangeLog* NEWS
- dohtml -r html/
- rm -rf "${D}"/usr/share/chicken/doc
-
- keepdir /usr/$(get_libdir)/chicken/3
-
- if use emacs; then
- elisp-install ${PN} hen.{el,elc} || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/chicken/chicken-4.6.0.ebuild b/dev-scheme/chicken/chicken-4.6.0.ebuild
deleted file mode 100644
index 0ed734fcc9aa..000000000000
--- a/dev-scheme/chicken/chicken-4.6.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/chicken/chicken-4.6.0.ebuild,v 1.1 2010/10/06 04:25:05 chiiph Exp $
-
-EAPI="3"
-
-inherit eutils multilib
-
-DESCRIPTION="Chicken is a Scheme interpreter and native Scheme to C compiler"
-HOMEPAGE="http://www.call-with-current-continuation.org/"
-SRC_URI="http://code.call-cc.org/releases/4.6.0/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
-IUSE="emacs"
-
-DEPEND="sys-apps/texinfo
- emacs? ( virtual/emacs )"
-RDEPEND="emacs? ( virtual/emacs app-emacs/scheme-complete )"
-
-src_prepare() {
- #Because chicken's Upstream have a custom to use variables that also
- #portage uses :( eg. $ARCH in this case
- for f in defaults.make Makefile.bsd Makefile.cross-linux-mingw Makefile.cygwin \
- Makefile.linux Makefile.macosx Makefile.mingw-msys Makefile.solaris \
- rules.make
- do
- sed "s,ARCH,zARCH," -i ${f} || die "sed failed"
- done
-
- sed "s,\$(PREFIX)/lib,\$(PREFIX)/$(get_libdir)," -i defaults.make || die "sed failed"
- sed "s,\$(DATADIR)/doc,\$(SHAREDIR)/doc/${P}," -i defaults.make || die "sed failed"
-}
-
-src_compile() {
- OPTIONS="PLATFORM=linux PREFIX=/usr"
- #upstream does not support parallel builds, bug 265881
- emake -j1 ${OPTIONS} C_COMPILER_OPTIMIZATION_OPTIONS="${CFLAGS}" \
- HOSTSYSTEM="${CBUILD}" || die "emake failed"
-}
-
-# chicken's testsuite is not runnable before install
-# upstream has been notified of the issue
-RESTRICT=test
-
-src_install() {
- # bug #283158
- emake -j1 ${OPTIONS} DESTDIR="${D}" HOSTSYSTEM="${CBUILD}" install || die
-
- rm "${D}"/usr/share/doc/${P}/LICENSE || die
- dodoc NEWS || die
-}
diff --git a/dev-scheme/chicken/chicken-4.7.3-r1.ebuild b/dev-scheme/chicken/chicken-4.7.3-r1.ebuild
deleted file mode 100644
index f8ccd20e1a7f..000000000000
--- a/dev-scheme/chicken/chicken-4.7.3-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/chicken/chicken-4.7.3-r1.ebuild,v 1.1 2011/12/10 13:41:55 maksbotan Exp $
-
-EAPI="3"
-
-inherit eutils multilib
-
-DESCRIPTION="Chicken is a Scheme interpreter and native Scheme to C compiler"
-HOMEPAGE="http://www.call-cc.org/"
-SRC_URI="http://code.call-cc.org/dev-snapshots/2011/08/17/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
-IUSE="emacs parallel-build"
-
-DEPEND="sys-apps/texinfo
- emacs? ( virtual/emacs )"
-RDEPEND="emacs? ( virtual/emacs app-emacs/scheme-complete )"
-
-src_prepare() {
- if use "parallel-build"
- then
- epatch "${FILESDIR}"/${P}-parallel-build.patch
- fi
-
- #Because chicken's Upstream is in the habit of using variables that
- #portage also uses :( eg. $ARCH and $A
- for f in defaults.make Makefile.bsd Makefile.cross-linux-mingw Makefile.cygwin \
- Makefile.linux Makefile.macosx Makefile.mingw-msys Makefile.solaris \
- rules.make
- do
- sed "s,ARCH,zARCH," -i ${f} || die "sed failed"
- # bug #393561: installs /usr/lib/libchickenchicken-4.7.3.tar.gz (portage pollutes ${A} variable)
- sed 's,A\(\s?=\|)\),chicken&,p' -i ${f} || die "sed failed"
- done
-
- sed "s,\$(PREFIX)/lib,\$(PREFIX)/$(get_libdir)," -i defaults.make || die "sed failed"
- sed "s,\$(DATADIR)/doc,\$(SHAREDIR)/doc/${P}," -i defaults.make || die "sed failed"
-}
-
-src_compile() {
- OPTIONS="PLATFORM=linux PREFIX=/usr"
- if use "parallel-build"
- then
- ewarn "You enabled parralel-build use flag. This feature is still"
- ewarn "in testing, try without it before filing bugs"
- emake ${OPTIONS} C_COMPILER_OPTIMIZATION_OPTIONS="${CFLAGS}" \
- HOSTSYSTEM="${CBUILD}" || die "emake failed"
- else
- emake -j1 ${OPTIONS} C_COMPILER_OPTIMIZATION_OPTIONS="${CFLAGS}" \
- HOSTSYSTEM="${CBUILD}" || die "emake failed"
- fi
-}
-
-# chicken's testsuite is not runnable before install
-# upstream has been notified of the issue
-RESTRICT=test
-
-src_install() {
- # still can't run make in parallel for the install target
- emake -j1 ${OPTIONS} DESTDIR="${D}" HOSTSYSTEM="${CBUILD}" install || die
-
- rm "${D}"/usr/share/doc/${P}/LICENSE || die
- dodoc NEWS || die
-}
diff --git a/dev-scheme/chicken/chicken-4.8.0.3.ebuild b/dev-scheme/chicken/chicken-4.8.0.3.ebuild
deleted file mode 100644
index 85b46cd9c899..000000000000
--- a/dev-scheme/chicken/chicken-4.8.0.3.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/chicken/chicken-4.8.0.3.ebuild,v 1.6 2013/04/11 21:42:52 ago Exp $
-
-EAPI="3"
-
-inherit eutils multilib versionator
-
-MY_PV=$(get_version_component_range 1-3)
-DESCRIPTION="Chicken is a Scheme interpreter and native Scheme to C compiler"
-HOMEPAGE="http://www.call-cc.org/"
-SRC_URI="http://code.call-cc.org/releases/${MY_PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc64 x86"
-IUSE="emacs parallel-build doc"
-
-DEPEND="sys-apps/texinfo
- emacs? ( virtual/emacs )"
-RDEPEND="emacs? ( virtual/emacs app-emacs/scheme-complete )"
-
-src_prepare() {
- if use "parallel-build"
- then
- epatch "${FILESDIR}"/${P}-parallel-build.patch
- fi
-
- #Because chicken's Upstream is in the habit of using variables that
- #portage also uses :( eg. $ARCH and $A
- sed 's,A\(\s?=\|)\),chicken&,' -i Makefile.cross-linux-mingw \
- defaults.make rules.make \
- || die "sed failed"
-
- sed "s,ARCH,zARCH," -i Makefile.bsd Makefile.cross-linux-mingw \
- Makefile.cygwin Makefile.haiku Makefile.linux Makefile.macosx \
- Makefile.mingw Makefile.mingw-msys Makefile.solaris \
- defaults.make rules.make \
- || die "sed failed"
-
- sed "s,\$(PREFIX)/lib,\$(PREFIX)/$(get_libdir)," -i defaults.make || die "sed failed"
- sed "s,\$(DATADIR)/doc,\$(SHAREDIR)/doc/${P}," -i defaults.make || die "sed failed"
-}
-
-src_compile() {
- OPTIONS="PLATFORM=linux PREFIX=/usr"
- if use "parallel-build"
- then
- emake ${OPTIONS} C_COMPILER_OPTIMIZATION_OPTIONS="${CFLAGS}" \
- LINKER_OPTIONS="${LDFLAGS}" \
- HOSTSYSTEM="${CBUILD}" || die "emake failed"
- else
- emake -j1 ${OPTIONS} C_COMPILER_OPTIMIZATION_OPTIONS="${CFLAGS}" \
- LINKER_OPTIONS="${LDFLAGS}" \
- HOSTSYSTEM="${CBUILD}" || die "emake failed"
- fi
-}
-
-# chicken's testsuite is not runnable before install
-# upstream has been notified of the issue
-RESTRICT=test
-
-src_install() {
- # still can't run make in parallel for the install target
- emake -j1 ${OPTIONS} DESTDIR="${D}" HOSTSYSTEM="${CBUILD}" \
- LINKER_OPTIONS="${LDFLAGS}" \
- install || die
-
- rm "${D}"/usr/share/doc/${P}/LICENSE || die
- dodoc NEWS || die
-
- # remove HTML documentation if the user doesn't USE=doc
- if ! use "doc"
- then
- rm -rf "${D}"/usr/share/doc/${P}/manual || die
- fi
-}