summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-08 10:18:22 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-08 10:18:22 +0000
commit0c64b73bb0a048c6d8eb6c0dd725d7db58691013 (patch)
treec62ce4a8e62a42986f472b4187199e6d19e7949c /dev-tcltk/blt/files
parentstable x86, bug 313815 (diff)
downloadgentoo-2-0c64b73bb0a048c6d8eb6c0dd725d7db58691013.tar.gz
gentoo-2-0c64b73bb0a048c6d8eb6c0dd725d7db58691013.tar.bz2
gentoo-2-0c64b73bb0a048c6d8eb6c0dd725d7db58691013.zip
fixed underlinking problem
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/blt/files')
-rw-r--r--dev-tcltk/blt/files/blt-2.4z-linking.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-tcltk/blt/files/blt-2.4z-linking.patch b/dev-tcltk/blt/files/blt-2.4z-linking.patch
new file mode 100644
index 000000000000..b5a5359171d3
--- /dev/null
+++ b/dev-tcltk/blt/files/blt-2.4z-linking.patch
@@ -0,0 +1,21 @@
+diff --git a/src/shared/Makefile.in b/src/shared/Makefile.in
+index db14156..a06111f 100644
+--- a/src/shared/Makefile.in
++++ b/src/shared/Makefile.in
+@@ -145,14 +145,14 @@ $(lib_so): $(OBJS)
+ $(srcdir)/bltInit.c
+ $(RM) $@
+ $(SHLIB_LD) $(SHLIB_LD_FLAGS) $(LDFLAGS) -o $@ bltInit.o $(OBJS) \
+- $(SHLIB_LIB_SPECS)
++ $(SHLIB_LIB_SPECS) $(LIBS)
+
+ $(tcl_only_lib_so): $(TCL_ONLY_OBJS)
+ $(CC) -c $(CC_SWITCHES) -DTCL_ONLY -DBLT_LIBRARY=\"$(scriptdir)\" \
+ $(srcdir)/bltInit.c
+ $(RM) $@
+ $(SHLIB_LD) $(SHLIB_LD_FLAGS) $(LDFLAGS) -o $@ bltInit.o $(TCL_ONLY_OBJS) \
+- $(SHLIB_TCL_ONLY_LIB_SPECS)
++ $(SHLIB_TCL_ONLY_LIB_SPECS) $(LIBS)
+
+ install: mkdirs install-lib install-demo
+