summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-04-07 14:45:30 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-04-07 14:45:30 +0000
commitdd8b109df086a0507eafb2722ae8e915ac118aaa (patch)
tree3b0f0626eee62fbce2643102e839482b7c8ba470 /dev-tcltk/expect/expect-5.43.0.ebuild
parentMarked ppc stable for bug #173245. (diff)
downloadgentoo-2-dd8b109df086a0507eafb2722ae8e915ac118aaa.tar.gz
gentoo-2-dd8b109df086a0507eafb2722ae8e915ac118aaa.tar.bz2
gentoo-2-dd8b109df086a0507eafb2722ae8e915ac118aaa.zip
Fix bug #160160
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-tcltk/expect/expect-5.43.0.ebuild')
-rw-r--r--dev-tcltk/expect/expect-5.43.0.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-tcltk/expect/expect-5.43.0.ebuild b/dev-tcltk/expect/expect-5.43.0.ebuild
index 64cc821b5078..f894dc4b8952 100644
--- a/dev-tcltk/expect/expect-5.43.0.ebuild
+++ b/dev-tcltk/expect/expect-5.43.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0.ebuild,v 1.6 2007/01/18 04:00:10 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0.ebuild,v 1.7 2007/04/07 14:45:30 jokey Exp $
-inherit eutils
+WANT_AUTOCONF="2.1"
+inherit autotools eutils
DESCRIPTION="tool for automating interactive applications"
HOMEPAGE="http://expect.nist.gov/"
@@ -15,10 +16,9 @@ IUSE="X doc"
# We need dejagnu for src_test, but dejagnu needs expect
# to compile/run, so we cant add dejagnu to DEPEND :/
-RDEPEND=">=dev-lang/tcl-8.2
+DEPEND=">=dev-lang/tcl-8.2
X? ( >=dev-lang/tk-8.2 )"
-DEPEND="${RDEPEND}
- =sys-devel/autoconf-2.1*"
+RDEPEND="${DEPEND}"
NON_MICRO_V=${P%.[0-9]}
S=${WORKDIR}/${NON_MICRO_V}
@@ -38,7 +38,7 @@ src_unpack() {
-e '/^install:/s/install-libraries //' \
-e 's/^SCRIPTS_MANPAGES = /_&/' \
Makefile.in
- WANT_AUTOCONF=2.1 autoconf
+ eautoconf
}
src_compile() {
@@ -73,7 +73,7 @@ src_test() {
# we need dejagnu to do tests ... but dejagnu needs
# expect ... so don't do tests unless we have dejagnu
type -p runtest || return 0
- WANT_AUTOCONF=2.1 make check || die "make check failed"
+ make check || die "make check failed"
}
src_install() {