summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-12 20:17:41 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-12 20:17:41 +0000
commitd8a0c50d29ece4731f4131ae5c93a57423d667ab (patch)
tree8c05fd2a7d1aaf0feea8dbf902e6914a67bdf7f4 /dev-tcltk/expect
parentVersion bump. (diff)
downloadgentoo-2-d8a0c50d29ece4731f4131ae5c93a57423d667ab.tar.gz
gentoo-2-d8a0c50d29ece4731f4131ae5c93a57423d667ab.tar.bz2
gentoo-2-d8a0c50d29ece4731f4131ae5c93a57423d667ab.zip
Version Bump, per 313567, thanks Harald van Dijk for patches
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/expect')
-rw-r--r--dev-tcltk/expect/ChangeLog9
-rw-r--r--dev-tcltk/expect/expect-5.44.1.15.ebuild99
-rw-r--r--dev-tcltk/expect/files/expect-5.44.1.15-gfbsd.patch17
-rw-r--r--dev-tcltk/expect/files/expect-5.44.1.15-ldflags.patch (renamed from dev-tcltk/expect/files/expect-5.44.1-ldflags.patch)0
4 files changed, 124 insertions, 1 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 97fd23557b77..43e4253c45dc 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-tcltk/expect
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.66 2010/04/08 06:19:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.67 2010/04/12 20:17:41 jlec Exp $
+
+*expect-5.44.1.15 (12 Apr 2010)
+
+ 12 Apr 2010; Justin Lecher <jlec@gentoo.org> +expect-5.44.1.15.ebuild,
+ +files/expect-5.44.1.15-gfbsd.patch,
+ +files/expect-5.44.1.15-ldflags.patch, -files/expect-5.44.1-ldflags.patch:
+ Version Bump, per 313567, thanks Harald van Dijk for patches
08 Apr 2010; Justin Lecher <jlec@gentoo.org> -expect-5.44.1.ebuild:
Removed due to a upstream recall of this version, #313567
diff --git a/dev-tcltk/expect/expect-5.44.1.15.ebuild b/dev-tcltk/expect/expect-5.44.1.15.ebuild
new file mode 100644
index 000000000000..ba7baf72fbff
--- /dev/null
+++ b/dev-tcltk/expect/expect-5.44.1.15.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.44.1.15.ebuild,v 1.1 2010/04/12 20:17:41 jlec Exp $
+
+EAPI="3"
+
+WANT_AUTOCONF="2.5"
+inherit autotools eutils
+
+DESCRIPTION="tool for automating interactive applications"
+HOMEPAGE="http://expect.nist.gov/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="X doc"
+
+# We need dejagnu for src_test, but dejagnu needs expect
+# to compile/run, so we cant add dejagnu to DEPEND :/
+DEPEND="
+ >=dev-lang/tcl-8.2
+ >=dev-lang/tk-8.2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix install_name on darwin
+ [[ ${CHOST} == *-darwin* ]] && \
+ epatch "${FILESDIR}"/${P}-darwin.patch
+
+ sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expect.man
+ sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expectk.man
+ #stops any example scripts being installed by default
+ sed -i \
+ -e '/^install:/s/install-libraries //' \
+ -e 's/^SCRIPTS_MANPAGES = /_&/' \
+ Makefile.in
+
+ epatch "${FILESDIR}/${P}-gfbsd.patch"
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+
+ eautoconf
+}
+
+src_configure() {
+ local myconf
+ local tclv
+ local tkv
+ # Find the version of tcl/tk that has headers installed.
+ # This will be the most recently merged, not necessarily the highest
+ # version number.
+ tclv=$(grep TCL_VER ${EPREFIX}/usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
+ #tkv isn't really needed, included for symmetry and the future
+ #tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
+
+ #configure needs to find the files tclConfig.sh and tclInt.h
+ myconf="--with-tcl=${EPREFIX}/usr/$(get_libdir) --with-tclinclude=${EPREFIX}/usr/$(get_libdir)/tcl${tclv}/include/generic"
+
+ if use X ; then
+ #--with-x is enabled by default
+ #configure needs to find the file tkConfig.sh and tk.h
+ #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
+ myconf="$myconf --with-tk=${EPREFIX}/usr/$(get_libdir) --with-tkinclude=${EPREFIX}/usr/include"
+ else
+ #configure knows that tk depends on X so just disable X
+ myconf="$myconf --without-x"
+ fi
+
+ econf $myconf --enable-shared || die "econf failed"
+}
+
+src_test() {
+ # we need dejagnu to do tests ... but dejagnu needs
+ # expect ... so don't do tests unless we have dejagnu
+ type -p runtest || return 0
+ emake test || die "emake test failed"
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)
+ emake install DESTDIR="${D}" || die "make install failed"
+
+ dodoc ChangeLog FAQ HISTORY NEWS README
+
+ #install examples if 'doc' is set
+ if use doc ; then
+ docinto examples
+ local scripts=$(make -qp | \
+ sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
+ exeinto /usr/share/doc/${PF}/examples
+ doexe ${scripts}
+ local scripts_manpages=$(make -qp | \
+ sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
+ for m in ${scripts_manpages}; do
+ dodoc example/${m}.man
+ done
+ dodoc example/README
+ fi
+}
diff --git a/dev-tcltk/expect/files/expect-5.44.1.15-gfbsd.patch b/dev-tcltk/expect/files/expect-5.44.1.15-gfbsd.patch
new file mode 100644
index 000000000000..d67de2126a07
--- /dev/null
+++ b/dev-tcltk/expect/files/expect-5.44.1.15-gfbsd.patch
@@ -0,0 +1,17 @@
+--- expect-5.44.1.15/tclconfig/tcl.m4.orig 2010-04-08 22:49:51.568043292 -0700
++++ expect-5.44.1.15/tclconfig/tcl.m4 2010-04-08 22:50:28.207915301 -0700
+@@ -1579,12 +1579,12 @@
+ FreeBSD-*)
+ # FreeBSD 3.* and greater have ELF.
+ SHLIB_CFLAGS="-fPIC"
+- SHLIB_LD="ld -Bshareable -x"
++ SHLIB_LD="${CC} -shared"
+ SHLIB_LD_LIBS='${LIBS}'
+ SHLIB_SUFFIX=".so"
+ DL_OBJS="tclLoadDl.o"
+ DL_LIBS=""
+- LDFLAGS="$LDFLAGS -export-dynamic"
++ LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
+ CC_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR}'
+ LD_SEARCH_FLAGS='-rpath ${LIB_RUNTIME_DIR}'
+ if test "${TCL_THREADS}" = "1" ; then
diff --git a/dev-tcltk/expect/files/expect-5.44.1-ldflags.patch b/dev-tcltk/expect/files/expect-5.44.1.15-ldflags.patch
index be3641c2105c..be3641c2105c 100644
--- a/dev-tcltk/expect/files/expect-5.44.1-ldflags.patch
+++ b/dev-tcltk/expect/files/expect-5.44.1.15-ldflags.patch