summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-08-08 02:25:55 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-08-08 02:25:55 +0000
commit4785a4a7d4795a6d83d1384b7e26c2687a86d15f (patch)
treedb11eac44d0fb622f7605f6c42439d35309325c4 /dev-tcltk/tclxml-expat
parentVersion bump, remove old (diff)
downloadgentoo-2-4785a4a7d4795a6d83d1384b7e26c2687a86d15f.tar.gz
gentoo-2-4785a4a7d4795a6d83d1384b7e26c2687a86d15f.tar.bz2
gentoo-2-4785a4a7d4795a6d83d1384b7e26c2687a86d15f.zip
bug 253515
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/tclxml-expat')
-rw-r--r--dev-tcltk/tclxml-expat/ChangeLog10
-rw-r--r--dev-tcltk/tclxml-expat/files/tclxml-expat-no-bundle.patch91
-rw-r--r--dev-tcltk/tclxml-expat/tclxml-expat-2.4-r1.ebuild41
3 files changed, 140 insertions, 2 deletions
diff --git a/dev-tcltk/tclxml-expat/ChangeLog b/dev-tcltk/tclxml-expat/ChangeLog
index 8d46aed27341..dff64dd8b309 100644
--- a/dev-tcltk/tclxml-expat/ChangeLog
+++ b/dev-tcltk/tclxml-expat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/tclxml-expat
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml-expat/ChangeLog,v 1.15 2008/08/17 03:47:16 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml-expat/ChangeLog,v 1.16 2009/08/08 02:25:55 mescalinum Exp $
+
+*tclxml-expat-2.4-r1 (08 Aug 2009)
+
+ 08 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
+ +tclxml-expat-2.4-r1.ebuild, +files/tclxml-expat-no-bundle.patch:
+ add -r1 for fixing bug 253515
17 Aug 2008; Michael Sterrett <mr_bones_@gentoo.org>
-tclxml-expat-2.6.ebuild:
diff --git a/dev-tcltk/tclxml-expat/files/tclxml-expat-no-bundle.patch b/dev-tcltk/tclxml-expat/files/tclxml-expat-no-bundle.patch
new file mode 100644
index 000000000000..cc442688173a
--- /dev/null
+++ b/dev-tcltk/tclxml-expat/files/tclxml-expat-no-bundle.patch
@@ -0,0 +1,91 @@
+diff -urpN tclxml-2.4.orig/expat/Makefile.in tclxml-2.4/expat/Makefile.in
+--- tclxml-2.4.orig/expat/Makefile.in 2009-08-08 03:56:41.000000000 +0200
++++ tclxml-2.4/expat/Makefile.in 2009-08-08 03:58:13.000000000 +0200
+@@ -31,14 +31,10 @@ FILEMAP = @FILEMAP@
+
+ Tclexpat_SOURCES = \
+ tclexpat.c \
+- xmltok.c \
+- xmlrole.c \
+- xmlwf.c \
+ xmlfile.c \
+ codepage.c \
+ hashtable.c \
+ $(FILEMAP).c \
+- xmlparse.c \
+ @EXTRA_SOURCES@
+
+ WIN_SOURCES =
+@@ -143,8 +139,8 @@ OBJEXT = @OBJEXT@
+ RANLIB = @RANLIB@
+ SHLIB_CFLAGS = @SHLIB_CFLAGS@
+ SHLIB_LD = @SHLIB_LD@
+-SHLIB_LDFLAGS = @SHLIB_LDFLAGS@
+-SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
++SHLIB_LDFLAGS = @SHLIB_LDFLAGS@ $(LDFLAGS)
++SHLIB_LD_LIBS = @SHLIB_LD_LIBS@ -lexpat
+ STLIB_LD = @STLIB_LD@
+ TCL_DEFS = @TCL_DEFS@
+ TCL_BIN_DIR = @TCL_BIN_DIR@
+@@ -230,7 +226,7 @@ install-binaries: binaries install-lib-b
+ install-libraries: libraries
+ @mkdir -p $(DESTDIR)$(includedir)
+ @echo "Installing header files in $(DESTDIR)$(includedir)"
+- @for i in $(GENERIC_HDRS) ; do \
++ @for i in ; do \
+ echo "Installing $$i" ; \
+ $(INSTALL_DATA) $$i $(DESTDIR)$(includedir) ; \
+ done;
+diff -urpN tclxml-2.4.orig/expat/xmlwf/xmlfile.c tclxml-2.4/expat/xmlwf/xmlfile.c
+--- tclxml-2.4.orig/expat/xmlwf/xmlfile.c 2009-08-08 03:56:41.000000000 +0200
++++ tclxml-2.4/expat/xmlwf/xmlfile.c 2009-08-08 03:58:56.000000000 +0200
+@@ -33,7 +33,7 @@ your version of this file under either t
+ #include <stddef.h>
+ #include <string.h>
+ #include <fcntl.h>
+-#include "xmlparse.h"
++#include <expat.h>
+ #include "xmlfile.h"
+ #include "xmltchar.h"
+ #include "filemap.h"
+diff -urpN tclxml-2.4.orig/expat/xmlwf/xmlwf.c tclxml-2.4/expat/xmlwf/xmlwf.c
+--- tclxml-2.4.orig/expat/xmlwf/xmlwf.c 2009-08-08 03:56:41.000000000 +0200
++++ tclxml-2.4/expat/xmlwf/xmlwf.c 2009-08-08 03:59:13.000000000 +0200
+@@ -33,7 +33,7 @@ your version of this file under either t
+ #include <stddef.h>
+ #include <string.h>
+
+-#include "xmlparse.h"
++#include <expat.h>
+ #include "codepage.h"
+ #include "xmlfile.h"
+ #include "xmltchar.h"
+diff -urpN tclxml-2.4.orig/tclexpat.c tclxml-2.4/tclexpat.c
+--- tclxml-2.4.orig/tclexpat.c 2009-08-08 03:56:41.000000000 +0200
++++ tclxml-2.4/tclexpat.c 2009-08-08 04:02:20.000000000 +0200
+@@ -20,7 +20,7 @@
+
+ #include <tcl.h>
+ #include "tclxml.h"
+-#include <xmlparse.h>
++#include <expat.h>
+
+ #undef TCL_STORAGE_CLASS
+ #define TCL_STORAGE_CLASS DLLEXPORT
+@@ -467,7 +467,16 @@ TclExpatConfigure (clientData, objc, obj
+ return TCL_ERROR;
+ }
+
++ /*
++ * This method is not exported, so kludge around it by calling one of the
++ * SetDefaultHandler* functions that also sets the variable to the desired
++ * value.
+ XML_SetDefaultExpandInternalEntities(expat->parser, bool);
++ */
++ if (bool)
++ XML_SetDefaultHandlerExpand(expat->parser, TclExpatDefaultHandler);
++ else
++ XML_SetDefaultHandler(expat->parser, TclExpatDefaultHandler);
+
+ break;
+
diff --git a/dev-tcltk/tclxml-expat/tclxml-expat-2.4-r1.ebuild b/dev-tcltk/tclxml-expat/tclxml-expat-2.4-r1.ebuild
new file mode 100644
index 000000000000..18d8377c1fe6
--- /dev/null
+++ b/dev-tcltk/tclxml-expat/tclxml-expat-2.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml-expat/tclxml-expat-2.4-r1.ebuild,v 1.1 2009/08/08 02:25:55 mescalinum Exp $
+
+inherit eutils
+
+DESCRIPTION="Tcl wrapper libraries for expat XML parser."
+HOMEPAGE="http://tclxml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tclxml/tclxml-${PV}.tar.gz"
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/tcl-8.3.3
+ >=dev-libs/expat-1.95.4
+ =dev-tcltk/tclxml-${PV}*"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/tclxml-${PV}/expat
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # bug 253515 - bundles an internal copy of expat
+ pushd ..
+ epatch "${FILESDIR}"/${PN}-no-bundle.patch
+ rm -f "${S}"/xmlparse/xmlparse.[ch] "${S}"/xmltok/xmltok_ns.c \
+ "${S}"/xmltok/xmltok.[ch] "${S}"/xmltok/xmlrole.[ch]
+ popd
+}
+src_compile() {
+ econf --with-tcl=/usr/lib --with-Tclxml=/usr/lib || die
+ make || die
+}
+
+src_install() {
+ einstall || die
+ dohtml expat.html
+}