summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-05-10 12:09:14 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-05-10 12:09:14 +0000
commit2bba4bd73f49318844ac97655cdc13900453f6af (patch)
tree9a3e9da1f22416fe83b187a32379a656dff99c13 /dev-tcltk/togl
parentMoved from sunrise overlay. Fixes bug 265833 (diff)
downloadgentoo-2-2bba4bd73f49318844ac97655cdc13900453f6af.tar.gz
gentoo-2-2bba4bd73f49318844ac97655cdc13900453f6af.tar.bz2
gentoo-2-2bba4bd73f49318844ac97655cdc13900453f6af.zip
initial ebuild. closes bug #149789
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/togl')
-rw-r--r--dev-tcltk/togl/ChangeLog9
-rw-r--r--dev-tcltk/togl/metadata.xml28
-rw-r--r--dev-tcltk/togl/togl-2.0.ebuild34
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-tcltk/togl/ChangeLog b/dev-tcltk/togl/ChangeLog
new file mode 100644
index 000000000000..1f9904abf0d5
--- /dev/null
+++ b/dev-tcltk/togl/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-tcltk/togl
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/togl/ChangeLog,v 1.1 2009/05/10 12:09:14 mescalinum Exp $
+
+*togl-2.0 (10 May 2009)
+
+ 10 May 2009; Federico Ferri <mescalinum@gentoo.org> +togl-2.0.ebuild:
+ initial ebuild. closes bug #149789
+
diff --git a/dev-tcltk/togl/metadata.xml b/dev-tcltk/togl/metadata.xml
new file mode 100644
index 000000000000..8e962df9b69b
--- /dev/null
+++ b/dev-tcltk/togl/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tcltk</herd>
+<maintainer>
+ <email>mescalinum@gentoo.org</email>
+</maintainer>
+<longdescription>
+Togl is a Tk widget for OpenGL rendering. Togl was originally based on
+OGLTK, written by Benjamin Bederson at the University of New Mexico. Togl's
+main features are:
+
+* unifies Microsoft Windows, X11 (Linux/IRIX/...), and Mac OS X Aqua support
+* support for requesting stencil, accumulation, alpha buffers, etc.
+* multiple OpenGL drawing windows
+* simple stereo rendering support
+* simple, portable font support
+* color-index mode support including color allocation functions
+* overlay plane support
+* OpenGL extension testing from Tcl
+* Tcl Extension Architecture (TEA) 3 compliant
+
+Togl does almost no OpenGL drawing itself, instead it manages OpenGL
+drawing by calling various Tcl commands (a.k.a., callback functions). Those
+commands can be C functions that call OpenGL (in)directly or another Tcl
+package (e.g., Tcl3D).
+</longdescription>
+</pkgmetadata>
diff --git a/dev-tcltk/togl/togl-2.0.ebuild b/dev-tcltk/togl/togl-2.0.ebuild
new file mode 100644
index 000000000000..cfe1b9689abb
--- /dev/null
+++ b/dev-tcltk/togl/togl-2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/togl/togl-2.0.ebuild,v 1.1 2009/05/10 12:09:14 mescalinum Exp $
+
+EAPI="2"
+
+MY_P="Togl${PV}"
+
+DESCRIPTION="A Tcl/Tk widget for OpenGL rendering"
+HOMEPAGE="http://togl.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +threads"
+
+RDEPEND="virtual/opengl
+ dev-lang/tk
+ dev-lang/tcl"
+DEPEND="${RDEPEND}"
+
+# tests directory is missing
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf $(use_enable debug symbols) $(use_enable threads)
+}
+
+src_install() {
+ make install DESTDIR="${D}"
+}