summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-09-15 18:37:28 +0000
committerJustin Lecher <jlec@gentoo.org>2014-09-15 18:37:28 +0000
commit601477ec8e69c8d797dd81ad26057946b4d894c4 (patch)
tree1f021415d906a767b68e43979d2c6e02b268966f /dev-tcltk
parentdev-tcltk/itcl: Version BUmp, #522092 (diff)
downloadgentoo-2-601477ec8e69c8d797dd81ad26057946b4d894c4.tar.gz
gentoo-2-601477ec8e69c8d797dd81ad26057946b4d894c4.tar.bz2
gentoo-2-601477ec8e69c8d797dd81ad26057946b4d894c4.zip
dev-tcltk/thread: Version BUmp, #522092
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/thread/ChangeLog9
-rw-r--r--dev-tcltk/thread/thread-2.7.1.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-tcltk/thread/ChangeLog b/dev-tcltk/thread/ChangeLog
index 786a27ed026c..4d44062109b4 100644
--- a/dev-tcltk/thread/ChangeLog
+++ b/dev-tcltk/thread/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tcltk/thread
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.30 2013/10/10 10:06:27 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.31 2014/09/15 18:37:28 jlec Exp $
+
+*thread-2.7.1 (15 Sep 2014)
+
+ 15 Sep 2014; Justin Lecher <jlec@gentoo.org> +thread-2.7.1.ebuild:
+ Version BUmp, #522092
10 Oct 2013; Justin Lecher <jlec@gentoo.org> -thread-2.6.2.ebuild,
-thread-2.6.6.ebuild:
diff --git a/dev-tcltk/thread/thread-2.7.1.ebuild b/dev-tcltk/thread/thread-2.7.1.ebuild
new file mode 100644
index 000000000000..2671f92ce65e
--- /dev/null
+++ b/dev-tcltk/thread/thread-2.7.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.7.1.ebuild,v 1.1 2014/09/15 18:37:28 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils multilib
+
+MY_P="${PN}${PV}"
+TCL_VER="8.6.2"
+
+DESCRIPTION="Tcl Thread extension"
+HOMEPAGE="http://www.tcl.tk/"
+SRC_URI="mirror://sourceforge/project/tcl/Tcl/${TCL_VER}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug gdbm"
+
+DEPEND="
+ dev-lang/tcl[threads]
+ gdbm? ( sys-libs/gdbm )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}${PV}
+
+RESTRICT="test"
+
+src_prepare() {
+ # Search for libs in libdir not just exec_prefix/lib
+ sed -i -e 's:${exec_prefix}/lib:${libdir}:' \
+ aclocal.m4 || die "sed failed"
+
+ sed -i -e "s/relid'/relid/" tclconfig/tcl.m4 || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-tclinclude="${EPREFIX}/usr/include"
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)"
+ )
+ use gdbm && myconf+=( --with-gdbm )
+ use debug && myconf+=( --enable-symbols )
+ autotools-utils_src_configure
+}