summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-13 07:51:21 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-13 07:51:21 +0000
commit77200a647225d18f60129f8f0ef4255cf407c5cc (patch)
treef423f0c9c53831f09af4dd8e62847eaa89043771 /dev-tcltk
parentFix yasm 1.0.0 detection wrt #314897 by Davide Pesavento. (diff)
downloadgentoo-2-77200a647225d18f60129f8f0ef4255cf407c5cc.tar.gz
gentoo-2-77200a647225d18f60129f8f0ef4255cf407c5cc.tar.bz2
gentoo-2-77200a647225d18f60129f8f0ef4255cf407c5cc.zip
Fixed credits to Tim Harder
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/expect/ChangeLog4
-rw-r--r--dev-tcltk/expect/expect-5.43.0.ebuild51
2 files changed, 31 insertions, 24 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 43e4253c45dc..c4c280aecbd3 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,13 +1,13 @@
# ChangeLog for dev-tcltk/expect
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.67 2010/04/12 20:17:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.68 2010/04/13 07:51:21 jlec Exp $
*expect-5.44.1.15 (12 Apr 2010)
12 Apr 2010; Justin Lecher <jlec@gentoo.org> +expect-5.44.1.15.ebuild,
+files/expect-5.44.1.15-gfbsd.patch,
+files/expect-5.44.1.15-ldflags.patch, -files/expect-5.44.1-ldflags.patch:
- Version Bump, per 313567, thanks Harald van Dijk for patches
+ Version Bump, per 313567, thanks Tim Harder for patches
08 Apr 2010; Justin Lecher <jlec@gentoo.org> -expect-5.44.1.ebuild:
Removed due to a upstream recall of this version, #313567
diff --git a/dev-tcltk/expect/expect-5.43.0.ebuild b/dev-tcltk/expect/expect-5.43.0.ebuild
index 5a0e9fbda2f9..7aca4e47d5a6 100644
--- a/dev-tcltk/expect/expect-5.43.0.ebuild
+++ b/dev-tcltk/expect/expect-5.43.0.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0.ebuild,v 1.20 2009/09/27 14:56:55 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0.ebuild,v 1.21 2010/04/13 07:51:21 jlec Exp $
+
+EAPI="3"
WANT_AUTOCONF="2.1"
-inherit autotools eutils versionator
+inherit autotools eutils multilib versionator
DESCRIPTION="tool for automating interactive applications"
HOMEPAGE="http://expect.nist.gov/"
@@ -11,7 +13,7 @@ SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
IUSE="X doc"
# We need dejagnu for src_test, but dejagnu needs expect
@@ -23,10 +25,11 @@ RDEPEND="${DEPEND}"
NON_MICRO_V=${PN}-$(get_version_component_range 1-2)
S=${WORKDIR}/${NON_MICRO_V}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/"${P}"-multilib.patch
+src_prepare() {
+ # fix install_name on darwin
+ [[ ${CHOST} == *-darwin* ]] && \
+ epatch "${FILESDIR}"/${P}-darwin.patch
+epatch "${FILESDIR}"/"${P}"-multilib.patch
#fix the rpath being set to /var/tmp/portage/...
epatch "${FILESDIR}"/expect-5.39.0-libdir.patch
@@ -34,8 +37,8 @@ src_unpack() {
#Removes references to functions that Tcl 8.5 no longer exposes.
epatch "${FILESDIR}"/"${P}"-avoid-tcl-internals-1.patch
- sed -i 's#/usr/local/bin#/usr/bin#' expect.man
- sed -i 's#/usr/local/bin#/usr/bin#' expectk.man
+ sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expect.man
+ sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expectk.man
#stops any example scripts being installed by default
sed -i \
-e '/^install:/s/install-libraries //' \
@@ -51,31 +54,35 @@ src_unpack() {
# fix implicit missing declarations (bug 204878)
epatch "${FILESDIR}"/"${P}"-missing-includes.patch
+# epatch "${FILESDIR}"/"${P}"-ldflags.patch
+
eautoconf
}
-src_compile() {
+src_configure() {
local myconf
local tcl_version
- local tcl_hdir
- tcl_version=$(echo 'puts [set tcl_version]' | tclsh)
- tcl_hdir="/usr/$(get_libdir)/tcl${tcl_version}/include"
+ tcl_version="$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)"
+ TCL_HDIR="${EPREFIX}/usr/$(get_libdir)/tcl${tcl_version}/include"
#configure needs to find the file tclConfig.sh is
- myconf="--with-tcl=/usr/$(get_libdir) --with-tclinclude=$tcl_hdir"
+ myconf="--with-tcl=${EPREFIX}/usr/$(get_libdir) --with-tclinclude=${TCL_HDIR}"
if use X ; then
#--with-x is enabled by default
#configure needs to find the file tkConfig.sh and tk.h
#tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=/usr/$(get_libdir)"
+ myconf="$myconf --with-tk=${EPREFIX}/usr/$(get_libdir)"
else
#configure knows that tk depends on X so just disable X
myconf="$myconf --without-x"
fi
- econf $myconf --enable-shared || die "econf failed"
- emake TCLHDIRDASHI="-I${tcl_hdir}/generic -I${tcl_hdir}/unix" \
+ econf $myconf --enable-shared
+}
+
+src_compile() {
+ emake TCLHDIRDASHI="-I${TCL_HDIR}/generic -I${TCL_HDIR}/unix" \
|| die "emake failed"
}
@@ -90,21 +97,21 @@ src_install() {
dodir /usr/$(get_libdir)
make install INSTALL_ROOT="${D}" || die "make install failed"
- dodoc ChangeLog FAQ HISTORY NEWS README
+ dodoc ChangeLog FAQ HISTORY NEWS README || die
local lib_basename="lib${NON_MICRO_V/-/}"
- rm "${D}/usr/$(get_libdir)/${NON_MICRO_V/-/}/${lib_basename}.a"
+ rm "${ED}/usr/$(get_libdir)/${NON_MICRO_V/-/}/${lib_basename}.a"
# bug #182278 - /usr/lib/expect.so symlink
- ln -s "${lib_basename}.so" "${D}/usr/$(get_libdir)/lib${PN}.so"
+ ln -s "${lib_basename}.so" "${ED}/usr/$(get_libdir)/lib${PN}.so"
#install examples if 'doc' is set
if use doc ; then
docinto examples
local scripts=$(make -qp | \
sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
- exeinto /usr/share/doc/${PF}/examples
- doexe ${scripts}
+ insinto /usr/share/doc/${PF}/examples
+ doins ${scripts} || die
local scripts_manpages=$(make -qp | \
sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
for m in ${scripts_manpages}; do