summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-02-03 01:19:27 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-02-03 01:19:27 +0000
commitd00ce67bb0420f3823ca502e0a7edc4efa1a78bf (patch)
treef3c6c441996ed525d604e2bfcfb883df9a27e2ee /dev-tcltk
parentRemoved extraneous files (diff)
downloadgentoo-2-d00ce67bb0420f3823ca502e0a7edc4efa1a78bf.tar.gz
gentoo-2-d00ce67bb0420f3823ca502e0a7edc4efa1a78bf.tar.bz2
gentoo-2-d00ce67bb0420f3823ca502e0a7edc4efa1a78bf.zip
Looks like tclxml-expat does not compile in 2.5, but does for 2.4,
hence I'm bringing 2.4 in. Also, needed to hack TclxmlConfig.sh to include the correct "-L" path to the library.
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclxml/files/digest-tclxml-2.41
-rw-r--r--dev-tcltk/tclxml/tclxml-2.4.ebuild33
-rw-r--r--dev-tcltk/tclxml/tclxml-2.5.ebuild6
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-tcltk/tclxml/files/digest-tclxml-2.4 b/dev-tcltk/tclxml/files/digest-tclxml-2.4
new file mode 100644
index 000000000000..e5b677c5a6e7
--- /dev/null
+++ b/dev-tcltk/tclxml/files/digest-tclxml-2.4
@@ -0,0 +1 @@
+MD5 4c5106de3269c8a54ff42a5cc66f40f2 tclxml-2.4.tar.gz 405119
diff --git a/dev-tcltk/tclxml/tclxml-2.4.ebuild b/dev-tcltk/tclxml/tclxml-2.4.ebuild
new file mode 100644
index 000000000000..1a4aa9c2207d
--- /dev/null
+++ b/dev-tcltk/tclxml/tclxml-2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>.
+# Distributed under the terms of the GNU General Public License v2.
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.4.ebuild,v 1.1 2003/02/03 01:19:27 agenkin Exp $
+
+DESCRIPTION="Pure Tcl implementation of an XML parser."
+HOMEPAGE="http://tclxml.sourceforge.net/"
+
+DEPEND=">=dev-lang/tcl-8.3.3"
+
+LICENSE="BSD"
+KEYWORDS="~x86"
+
+SLOT="0"
+SRC_URI="mirror://sourceforge/tclxml/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ econf || die
+ make || die
+
+ # Need to hack the config script.
+ sed 's:NONE:/usr:' < TclxmlConfig.sh > TclxmlConfig.sh.hacked
+ mv TclxmlConfig.sh.hacked TclxmlConfig.sh
+
+}
+
+src_install() {
+
+ einstall || die
+ dodoc ChangeLog LICENSE README RELNOTES
+
+}
diff --git a/dev-tcltk/tclxml/tclxml-2.5.ebuild b/dev-tcltk/tclxml/tclxml-2.5.ebuild
index 3beecb6cf372..51119fb6a24d 100644
--- a/dev-tcltk/tclxml/tclxml-2.5.ebuild
+++ b/dev-tcltk/tclxml/tclxml-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>.
# Distributed under the terms of the GNU General Public License v2.
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.5.ebuild,v 1.1 2003/02/02 04:37:49 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.5.ebuild,v 1.2 2003/02/03 01:19:27 agenkin Exp $
DESCRIPTION="Pure Tcl implementation of an XML parser."
HOMEPAGE="http://tclxml.sourceforge.net/"
@@ -19,6 +19,10 @@ src_compile() {
econf || die
make || die
+ # Need to hack the config script.
+ sed 's:NONE:/usr:' < TclxmlConfig.sh > TclxmlConfig.sh.hacked
+ mv TclxmlConfig.sh.hacked TclxmlConfig.sh
+
}
src_install() {