summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-09-03 02:50:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-09-03 02:50:29 +0000
commitb552966cf58dc03db8c9fe35e7358623026d436e (patch)
treee30bf68a2dd1def4d05282484f92fb58ced20bd6 /dev-tex/mh
parentadd particle patch from Albert Zeyer (bug #236469) (diff)
downloadgentoo-2-b552966cf58dc03db8c9fe35e7358623026d436e.tar.gz
gentoo-2-b552966cf58dc03db8c9fe35e7358623026d436e.tar.bz2
gentoo-2-b552966cf58dc03db8c9fe35e7358623026d436e.zip
bump to latest ctan version
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.3 x86_64)
Diffstat (limited to 'dev-tex/mh')
-rw-r--r--dev-tex/mh/ChangeLog7
-rw-r--r--dev-tex/mh/mh-20080903.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-tex/mh/ChangeLog b/dev-tex/mh/ChangeLog
index f5c1a6df6ecc..981f915a3334 100644
--- a/dev-tex/mh/ChangeLog
+++ b/dev-tex/mh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/mh
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/mh/ChangeLog,v 1.3 2008/05/23 13:55:37 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/mh/ChangeLog,v 1.4 2008/09/03 02:50:29 aballier Exp $
+
+*mh-20080903 (03 Sep 2008)
+
+ 03 Sep 2008; Alexis Ballier <aballier@gentoo.org> +mh-20080903.ebuild:
+ bump to latest ctan version
23 May 2008; Ferris McCormick <fmccor@gentoo.org> mh-20080407.ebuild:
Add ~sparc keyword at developer (bicatali) request --- Bug #223341 ---
diff --git a/dev-tex/mh/mh-20080903.ebuild b/dev-tex/mh/mh-20080903.ebuild
new file mode 100644
index 000000000000..41c9044c4f09
--- /dev/null
+++ b/dev-tex/mh/mh-20080903.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/mh/mh-20080903.ebuild,v 1.1 2008/09/03 02:50:29 aballier Exp $
+
+inherit latex-package
+
+DESCRIPTION="Additional LaTeX math tools."
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/mh/"
+SRC_URI="mirror://gentoo/${P}.zip"
+LICENSE="LPPL-1.3"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+TEXMF=/usr/share/texmf-site
+
+src_compile() {
+ # To avoid sandbox violations
+ export VARTEXFONTS="${T}/fonts"
+
+ # Unpacking *.dtx
+ for i in *.dtx; do
+ tex ${i} || die "TeXing ${i} failed"
+ done
+
+ latex-package_src_compile
+}
+
+src_install() {
+ latex-package_src_doinstall styles fonts bin
+
+ insinto "${TEXMF}/tex/latex/${PN}"
+ doins *.sym
+
+ use doc && latex-package_src_doinstall doc
+ dodoc README
+}