summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-05-18 14:35:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-05-18 14:35:20 +0000
commitd67320f754cd893f36500b81577b895e688fa953 (patch)
tree2bacb5ed9dddaf9582fe7bda08381be61a816735 /dev-texlive/texlive-luatex
parentfix luatools with luatex 0.65, based on https://github.com/mpg/lualibs/commit... (diff)
downloadgentoo-2-d67320f754cd893f36500b81577b895e688fa953.tar.gz
gentoo-2-d67320f754cd893f36500b81577b895e688fa953.tar.bz2
gentoo-2-d67320f754cd893f36500b81577b895e688fa953.zip
fix mkluatexfontdb with luatex 0.65, bug #357931 by Tiziano M�ller
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'dev-texlive/texlive-luatex')
-rw-r--r--dev-texlive/texlive-luatex/ChangeLog16
-rw-r--r--dev-texlive/texlive-luatex/files/lualibs.patch43
-rw-r--r--dev-texlive/texlive-luatex/texlive-luatex-2010-r1.ebuild24
3 files changed, 78 insertions, 5 deletions
diff --git a/dev-texlive/texlive-luatex/ChangeLog b/dev-texlive/texlive-luatex/ChangeLog
index afffdf827d6e..57035f061078 100644
--- a/dev-texlive/texlive-luatex/ChangeLog
+++ b/dev-texlive/texlive-luatex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-texlive/texlive-luatex
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-texlive/texlive-luatex/ChangeLog,v 1.11 2010/10/24 18:12:02 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-texlive/texlive-luatex/ChangeLog,v 1.12 2011/05/18 14:35:20 aballier Exp $
+
+*texlive-luatex-2010-r1 (18 May 2011)
+
+ 18 May 2011; Alexis Ballier <aballier@gentoo.org>
+ +texlive-luatex-2010-r1.ebuild, +files/lualibs.patch:
+ fix mkluatexfontdb with luatex 0.65, bug #357931 by Tiziano Muller
*texlive-luatex-2010 (24 Oct 2010)
@@ -11,7 +17,7 @@
01 Jun 2010; Joseph Jezak <josejx@gentoo.org> texlive-luatex-2009.ebuild:
Marked ~ppc for bug #300526.
- 13 May 2010; Raúl Porcel <armin76@gentoo.org> texlive-luatex-2009.ebuild:
+ 13 May 2010; Raúl Porcel <armin76@gentoo.org> texlive-luatex-2009.ebuild:
Add ~sparc wrt #300526
12 May 2010; Brent Baude <ranger@gentoo.org> texlive-luatex-2009.ebuild:
@@ -20,10 +26,10 @@
10 May 2010; Markus Meier <maekke@gentoo.org> texlive-luatex-2009.ebuild:
add ~arm, bug #300526
- 13 Feb 2010; Raúl Porcel <armin76@gentoo.org> texlive-luatex-2009.ebuild:
+ 13 Feb 2010; Raúl Porcel <armin76@gentoo.org> texlive-luatex-2009.ebuild:
Add ~sh wrt #300526
- 13 Feb 2010; Raúl Porcel <armin76@gentoo.org> texlive-luatex-2009.ebuild:
+ 13 Feb 2010; Raúl Porcel <armin76@gentoo.org> texlive-luatex-2009.ebuild:
Add ~alpha/~ia64 wrt #300526
03 Feb 2010; Jonathan Callen <abcd@gentoo.org> texlive-luatex-2009.ebuild:
diff --git a/dev-texlive/texlive-luatex/files/lualibs.patch b/dev-texlive/texlive-luatex/files/lualibs.patch
new file mode 100644
index 000000000000..f62d3bea44ca
--- /dev/null
+++ b/dev-texlive/texlive-luatex/files/lualibs.patch
@@ -0,0 +1,43 @@
+--- texmf-dist/tex/luatex/lualibs/lualibs-dir.lua 2010-05-29 02:25:56.000000000 -0700
++++ texmf-dist/tex/luatex/lualibs/lualibs-dir.lua 2011-01-13 22:05:56.766564001 -0800
+@@ -26,15 +26,15 @@
+ local walkdir = lfs.dir
+
+ local function glob_pattern(path,patt,recurse,action)
+- local ok, scanner
++ local ok, scanner, dirobj
+ if path == "/" then
+- ok, scanner = xpcall(function() return walkdir(path..".") end, function() end) -- kepler safe
++ ok, scanner, dirobj = xpcall(function() return walkdir(path..".") end, function() end) -- kepler safe
+ else
+- ok, scanner = xpcall(function() return walkdir(path) end, function() end) -- kepler safe
++ ok, scanner, dirobj = xpcall(function() return walkdir(path) end, function() end) -- kepler safe
+ end
+ if ok and type(scanner) == "function" then
+ if not find(path,"/$") then path = path .. '/' end
+- for name in scanner do
++ for name in scanner, dirobj do
+ local full = path .. name
+ local mode = attributes(full,'mode')
+ if mode == 'file' then
+@@ -51,16 +51,16 @@
+ dir.glob_pattern = glob_pattern
+
+ local function collect_pattern(path,patt,recurse,result)
+- local ok, scanner
++ local ok, scanner, dirobj
+ result = result or { }
+ if path == "/" then
+- ok, scanner = xpcall(function() return walkdir(path..".") end, function() end) -- kepler safe
++ ok, scanner, dirobj = xpcall(function() return walkdir(path..".") end, function() end) -- kepler safe
+ else
+- ok, scanner = xpcall(function() return walkdir(path) end, function() end) -- kepler safe
++ ok, scanner, dirobj = xpcall(function() return walkdir(path) end, function() end) -- kepler safe
+ end
+ if ok and type(scanner) == "function" then
+ if not find(path,"/$") then path = path .. '/' end
+- for name in scanner do
++ for name in scanner, dirobj do
+ local full = path .. name
+ local attr = attributes(full)
+ local mode = attr.mode
diff --git a/dev-texlive/texlive-luatex/texlive-luatex-2010-r1.ebuild b/dev-texlive/texlive-luatex/texlive-luatex-2010-r1.ebuild
new file mode 100644
index 000000000000..1ad163712c69
--- /dev/null
+++ b/dev-texlive/texlive-luatex/texlive-luatex-2010-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-texlive/texlive-luatex/texlive-luatex-2010-r1.ebuild,v 1.1 2011/05/18 14:35:20 aballier Exp $
+
+EAPI="3"
+
+TEXLIVE_MODULE_CONTENTS="luainputenc lualibs luamplib luaotfload luatexbase luatextra collection-luatex
+"
+TEXLIVE_MODULE_DOC_CONTENTS="luainputenc.doc lualibs.doc luamplib.doc luaotfload.doc luatexbase.doc luatextra.doc "
+TEXLIVE_MODULE_SRC_CONTENTS="luainputenc.source lualibs.source luamplib.source luaotfload.source luatexbase.source luatextra.source "
+inherit texlive-module
+DESCRIPTION="TeXLive LuaTeX packages"
+
+LICENSE="GPL-2 GPL-2 public-domain "
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+DEPEND=">=dev-texlive/texlive-basic-2010
+>=dev-tex/luatex-0.45
+
+"
+RDEPEND="${DEPEND} "
+TEXLIVE_MODULE_BINSCRIPTS="texmf-dist/scripts/luaotfload/mkluatexfontdb.lua"
+PATCHES=( "${FILESDIR}/lualibs.patch" )