summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-17 18:54:08 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-17 18:54:08 +0000
commit3cbcdc61e523da55ebcb8353096b828bd67c77a1 (patch)
tree21581b1f95c5915cfef2afcd1d156e1063a65c13 /dev-util/anjuta
parentNew addition imported from sci oerlay, #95178 (diff)
downloadgentoo-2-3cbcdc61e523da55ebcb8353096b828bd67c77a1.tar.gz
gentoo-2-3cbcdc61e523da55ebcb8353096b828bd67c77a1.tar.bz2
gentoo-2-3cbcdc61e523da55ebcb8353096b828bd67c77a1.zip
Version bump for Gnome 2.30
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/anjuta')
-rw-r--r--dev-util/anjuta/ChangeLog9
-rw-r--r--dev-util/anjuta/anjuta-2.30.2.0.ebuild111
-rw-r--r--dev-util/anjuta/files/anjuta-2.30.2.0-debug-mode.patch14
-rw-r--r--dev-util/anjuta/files/anjuta-2.30.2.0-symbol-db-optional.patch79
4 files changed, 212 insertions, 1 deletions
diff --git a/dev-util/anjuta/ChangeLog b/dev-util/anjuta/ChangeLog
index 2cf747301f53..254ce0e86908 100644
--- a/dev-util/anjuta/ChangeLog
+++ b/dev-util/anjuta/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/anjuta
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.111 2010/04/21 22:06:21 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.112 2010/06/17 18:54:08 pacho Exp $
+
+*anjuta-2.30.2.0 (17 Jun 2010)
+
+ 17 Jun 2010; Pacho Ramos <pacho@gentoo.org> +anjuta-2.30.2.0.ebuild,
+ +files/anjuta-2.30.2.0-debug-mode.patch,
+ +files/anjuta-2.30.2.0-symbol-db-optional.patch:
+ Version bump for Gnome 2.30
21 Apr 2010; Gilles Dartiguelongue <eva@gentoo.org>
-files/anjuta-1.2.4-gtk-fix.patch, -files/anjuta-2.1.0-sandbox-fix.patch,
diff --git a/dev-util/anjuta/anjuta-2.30.2.0.ebuild b/dev-util/anjuta/anjuta-2.30.2.0.ebuild
new file mode 100644
index 000000000000..443d21fee6cd
--- /dev/null
+++ b/dev-util/anjuta/anjuta-2.30.2.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/anjuta-2.30.2.0.ebuild,v 1.1 2010/06/17 18:54:08 pacho Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2 flag-o-matic
+
+DESCRIPTION="A versatile IDE for GNOME"
+HOMEPAGE="http://www.anjuta.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="debug devhelp doc glade +sourceview subversion +symbol-db test"
+
+# FIXME: Anjuta has some CRITICAL and WARNINGS messages, that would be nice to fix them and/or report on upstream
+RDEPEND=">=dev-libs/glib-2.18
+ >=x11-libs/gtk+-2.17.10
+ >=gnome-base/orbit-2.6
+ >=gnome-base/gconf-2.12
+ >=x11-libs/vte-0.13.1
+ >=dev-libs/libxml2-2.4.23
+ >=dev-libs/gdl-2.27.1
+ >=dev-libs/libunique-1
+
+ dev-libs/libxslt
+ >=dev-lang/perl-5
+ dev-perl/Locale-gettext
+ sys-devel/autogen
+
+ devhelp? (
+ >=dev-util/devhelp-0.22
+ >=net-libs/webkit-gtk-1 )
+ glade? ( >=dev-util/glade-3.6.0 )
+ subversion? (
+ >=dev-util/subversion-1.5.0
+ >=net-misc/neon-0.28.2
+ >=dev-libs/apr-1
+ >=dev-libs/apr-util-1 )
+ sourceview? ( >=x11-libs/gtksourceview-2.4 )
+ symbol-db? (
+ gnome-extra/libgda:4
+ dev-util/ctags )"
+DEPEND="${RDEPEND}
+ !!dev-libs/gnome-build
+ >=sys-devel/gettext-0.14
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.20
+ >=app-text/scrollkeeper-0.3.14-r2
+ >=app-text/gnome-doc-utils-0.3.2
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.4 )
+ test? (
+ ~app-text/docbook-xml-dtd-4.1.2
+ ~app-text/docbook-xml-dtd-4.5 )"
+
+DOCS="AUTHORS ChangeLog FUTURE MAINTAINERS NEWS README ROADMAP THANKS TODO"
+
+pkg_setup() {
+ if ! use symbol-db; then
+ ewarn "You have disabled symbol-db, which will disallow using projects"
+ fi
+
+ if ! use sourceview; then
+ ewarn "You have disabled sourceview, which means you now have no editor"
+ fi
+
+ G2CONF="${G2CONF}
+ --docdir=/usr/share/doc/${PF}
+ $(use_enable debug)
+ $(use_enable devhelp plugin-devhelp)
+ $(use_enable glade plugin-glade)
+ $(use_enable sourceview plugin-sourceview)
+ $(use_enable subversion plugin-subversion)
+ $(use_enable symbol-db plugin-symbol-db)"
+
+ # Conflics wiht -pg in a plugin, bug #266777
+ filter-flags -fomit-frame-pointer
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Make Symbol DB optional
+ epatch "${FILESDIR}/${PN}-2.30.2.0-symbol-db-optional.patch"
+
+ # Do not force the debugging mode when --disable-debug
+ # is given on the command line.
+ epatch "${FILESDIR}/${PN}-2.30.2.0-debug-mode.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_install() {
+ # Anjuta uses a custom rule to install DOCS, get rid of it
+ gnome2_src_install
+ rm -rf "${D}"/usr/share/doc/${PN} || die "rm failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ebeep 1
+ elog ""
+ elog "Some project templates may require additional development"
+ elog "libraries to function correctly. It goes beyond the scope"
+ elog "of this ebuild to provide them."
+ epause 5
+}
diff --git a/dev-util/anjuta/files/anjuta-2.30.2.0-debug-mode.patch b/dev-util/anjuta/files/anjuta-2.30.2.0-debug-mode.patch
new file mode 100644
index 000000000000..da1dbe191d31
--- /dev/null
+++ b/dev-util/anjuta/files/anjuta-2.30.2.0-debug-mode.patch
@@ -0,0 +1,14 @@
+Subject: [PATCH] Fix the forced debugging mode even if --disable-debug is given on the command line
+--- configure.in~ 2010-06-05 12:00:40.000000000 +0200
++++ configure.in 2010-06-13 16:56:42.000000000 +0200
+@@ -84,7 +84,9 @@
+ dnl Enable debugging mode
+ AC_ARG_ENABLE(debug,
+ AC_HELP_STRING([--enable-debug],[Enable debug messages]),
+- AM_CFLAGS="$AM_CFLAGS -DDEBUG"
++ [if test "x$enableval" = "xyes"; then
++ AM_CFLAGS="$AM_CFLAGS -DDEBUG"
++ fi]
+ AM_CXXFLAGS="$AM_CXXFLAGS -DDEBUG")
+ AC_SUBST(AM_CFLAGS)
+ AC_SUBST(AM_CXXFLAGS)
diff --git a/dev-util/anjuta/files/anjuta-2.30.2.0-symbol-db-optional.patch b/dev-util/anjuta/files/anjuta-2.30.2.0-symbol-db-optional.patch
new file mode 100644
index 000000000000..cb9eea76bc80
--- /dev/null
+++ b/dev-util/anjuta/files/anjuta-2.30.2.0-symbol-db-optional.patch
@@ -0,0 +1,79 @@
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 25 Oct 2009 20:58:15 +0100
+Subject: [PATCH] Allow disabling symbol-db plugin
+From: Pacho Ramos <pacho@gentoo.org>
+Date: Thu, 17 Jun 2010 19:33:10 +0100
+Subject: Port to 2.30
+--- configure.in.orig 2010-06-17 19:27:35.000000000 +0200
++++ configure.in 2010-06-17 19:42:15.000000000 +0200
+@@ -246,6 +246,29 @@
+
+ AM_CONDITIONAL(HAVE_PLUGIN_GLADE, [test x$gladeui_found = xyes])
+
++dnl Plugin Symbol DB
++dnl -------------------------------------------------------------
++
++AC_ARG_ENABLE(plugin-symbol-db,
++ AC_HELP_STRING([--disable-plugin-symbol-db],[libgda-4 based symbol DB]),
++ [ if test "$enableval" = "yes"; then
++ user_disabled_symbol_db=1
++ fi ],
++ [ user_disabled_symbol_db=0 ])
++
++AC_MSG_CHECKING(if symbol db plugin is disabled)
++if test "$user_disabled_symbol_db" = 1; then
++ AC_MSG_RESULT(no)
++ symbol_db="yes"
++
++ PKG_CHECK_MODULES(PLUGIN_SYMBOL_DB,
++ [libgda-4.0 >= $GDA_REQUIRED])
++else
++ AC_MSG_RESULT(yes)
++ symbol_db="no"
++fi
++AM_CONDITIONAL(HAVE_PLUGIN_SYMBOL_DB, [test x$symbol_db = xyes])
++
+ dnl Check for gtksourceview
+ dnl -------------------------------------------------------------
+
+@@ -286,9 +309,6 @@
+
+ AM_CONDITIONAL(ENABLE_VALA, [test x$enable_vala = xyes])
+
+-PKG_CHECK_MODULES(PLUGIN_SYMBOL_DB,
+- [libgda-4.0 >= $GDA_REQUIRED])
+-
+ dnl Setup Anjuta Library flags
+ dnl --------------------------
+ LIBANJUTA_CFLAGS='$(GLIB_CFLAGS) $(GTK_CFLAGS) $(GCONF_CFLAGS) $(GDL_CFLAGS) $(DEPRECATED_FLAGS) -I$(top_srcdir) -I$(top_builddir)/libanjuta -DPACKAGE_PIXMAPS_DIR=\""$(datadir)/pixmaps/$(PACKAGE)"\" -DPACKAGE_LIB_DIR=\""$(pkglibdir)"\" -DPACKAGE_DATA_DIR=\""$(datadir)/$(PACKAGE)"\"'
+@@ -917,6 +937,13 @@
+ echo " Requires devhelp >= 0.22"
+ fi
+
++if [ test x$symbol_db = xyes ]; then
++ echo "Building Symbol DB plugin: .............................YES"
++else
++ echo "Building Symbol DB plugin: .............................NO"
++ echo " Requires libgda-4"
++fi
++
+ if [ test x$sourceview = xyes ]; then
+ echo "Building GtkSourceView based editor: ...................YES"
+ else
+--- plugins/symbol-db/Makefile.am.orig 2010-06-17 19:46:26.000000000 +0200
++++ plugins/symbol-db/Makefile.am 2010-06-17 19:46:58.000000000 +0200
+@@ -1,3 +1,5 @@
++if HAVE_PLUGIN_SYMBOL_DB
++
+ SUBDIRS = . anjuta-tags images benchmark
+
+ symbol_db_datadir = $(anjuta_data_dir)
+@@ -83,6 +85,8 @@
+ prefs_ui_files = anjuta-symbol-db.ui
+ include $(top_srcdir)/scripts/build-schemas.mk
+
++endif
++
+ EXTRA_DIST = \
+ $(plugin_in_files) \
+ $(symbol_db_plugin_DATA) \