summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-08-14 22:30:34 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-08-14 22:30:34 +0000
commit63c49cfc43b2e5ff9b1bbb66823155736dceac75 (patch)
tree902daefd0befa997ea5ee3b80a49c08458e50d8a /dev-util/calltree/calltree-0.9.7-r1.ebuild
parentRemoved mask for xchat development series. (diff)
downloadgentoo-2-63c49cfc43b2e5ff9b1bbb66823155736dceac75.tar.gz
gentoo-2-63c49cfc43b2e5ff9b1bbb66823155736dceac75.tar.bz2
gentoo-2-63c49cfc43b2e5ff9b1bbb66823155736dceac75.zip
fix for valgrind2.1.2.
Diffstat (limited to 'dev-util/calltree/calltree-0.9.7-r1.ebuild')
-rw-r--r--dev-util/calltree/calltree-0.9.7-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/calltree/calltree-0.9.7-r1.ebuild b/dev-util/calltree/calltree-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..2a6f8f3f029d
--- /dev/null
+++ b/dev-util/calltree/calltree-0.9.7-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/calltree/calltree-0.9.7-r1.ebuild,v 1.1 2004/08/14 22:30:34 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="A plugin for cachegrind that adds call-graph profiling, needed by kcachegrind"
+HOMEPAGE="http://kcachegrind.sourceforge.net/"
+SRC_URI="http://kcachegrind.sourceforge.net/${P}.tar.gz"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+RDEPEND=">=dev-util/valgrind-2.1.2"
+DEPEND="${RDEPEND} sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ # valgrind 2.1.2 support
+ EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/calltree-0.9.7-valgrind2.1.2.patch
+ cd ${S}
+ WANT_AUTOCONF=2.5
+ autoconf
+}
+
+src_install() {
+ einstall || die
+ rm -rf ${D}/usr/share/doc/valgrind
+ dodoc AUTHORS INSTALL README || die "dodoc failed"
+ dohtml docs/*.html || die "dohtml failed"
+}