summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2014-01-02 20:30:23 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2014-01-02 20:30:23 +0000
commit13b2cbac991135313c32026821cce5af45d68080 (patch)
treeff2ebf6f04421a5eaf00c0a2e30534e4203bbc1a /dev-util/catalyst
parentversion bump wrt bug #495158 (diff)
downloadgentoo-2-13b2cbac991135313c32026821cce5af45d68080.tar.gz
gentoo-2-13b2cbac991135313c32026821cce5af45d68080.tar.bz2
gentoo-2-13b2cbac991135313c32026821cce5af45d68080.zip
Add live ebuild to track the new 2.X branch (2.0.9999). Thanks to - Mike Gilbert (floppym) for a complete review of the python eclass use.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key BB0E6E98)
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/ChangeLog11
-rw-r--r--dev-util/catalyst/catalyst-2.0.9999.ebuild110
2 files changed, 119 insertions, 2 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index 8b7baecf242e..e72d1835f791 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/catalyst
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.267 2013/11/14 00:46:40 mattst88 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.268 2014/01/02 20:30:23 jmbsvicetto Exp $
+
+*catalyst-2.0.9999 (02 Jan 2014)
+
+ 02 Jan 2014; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +catalyst-2.0.9999.ebuild:
+ Add live ebuild to track the new 2.X branch (2.0.9999). Thanks to - Mike
+ Gilbert (floppym) for a complete review of the python eclass use.
*catalyst-2.0.15 (14 Nov 2013)
diff --git a/dev-util/catalyst/catalyst-2.0.9999.ebuild b/dev-util/catalyst/catalyst-2.0.9999.ebuild
new file mode 100644
index 000000000000..3c7aed0a4681
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.9999.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.9999.ebuild,v 1.1 2014/01/02 20:30:23 jmbsvicetto Exp $
+
+EAPI=5
+
+if [[ ${PV} == *9999* ]]; then
+ SRC_ECLASS="git-2"
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
+ EGIT_MASTER="master"
+ EGIT_BRANCH="2.X"
+ SRC_URI=""
+ KEYWORDS=""
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2
+ http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+fi
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils multilib python-single-r1 ${SRC_ECLASS}
+
+DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ccache kernel_linux"
+
+DEPEND="
+ app-text/asciidoc
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ app-arch/lbzip2
+ app-crypt/shash
+ virtual/cdrtools
+ amd64? ( >=sys-boot/syslinux-3.72 )
+ ia64? ( sys-fs/dosfstools )
+ x86? ( >=sys-boot/syslinux-3.72 )
+ ccache? ( dev-util/ccache )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
+ ${PYTHON_DEPS}
+"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+ echo
+
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe catalyst || die "copying catalyst"
+
+ if [[ ${PV} == 3.9999* ]]; then
+ doins -r modules files || die "copying files"
+ else
+ doins -r arch modules livecd || die "copying files"
+ fi
+
+ for x in targets/*; do
+ exeinto /usr/$(get_libdir)/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+
+ # Here is where we actually enable ccache
+ use ccache && \
+ sed -i -e 's:options="autoresume kern:options="autoresume ccache kern:' \
+ files/catalyst.conf
+
+ sed -i -e "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ files/catalyst.conf
+
+ make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README AUTHORS
+ doman files/catalyst.1 files/catalyst-spec.5
+
+ python_fix_shebang "${ED}usr/$(get_libdir)/catalyst/catalyst"
+ python_optimize "${ED}"
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+}