summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-01-10 05:22:59 +0000
committerMike Frysinger <vapier@gentoo.org>2011-01-10 05:22:59 +0000
commite8747500a5525e7f38c970c7e8273d576f80b587 (patch)
treeae0abaffd6af1a17699813fdbebfa7ccb35bdb48 /dev-util/ccache
parentVersion bump, bug #343073 (diff)
downloadgentoo-2-e8747500a5525e7f38c970c7e8273d576f80b587.tar.gz
gentoo-2-e8747500a5525e7f38c970c7e8273d576f80b587.tar.bz2
gentoo-2-e8747500a5525e7f38c970c7e8273d576f80b587.zip
Version bump.
(Portage version: 2.2.0_alpha13/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog9
-rw-r--r--dev-util/ccache/ccache-3.1.4.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index fd5ee0d81b73..976324b68d79 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ccache
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.77 2010/12/29 15:47:51 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.78 2011/01/10 05:22:59 vapier Exp $
+
+*ccache-3.1.4 (10 Jan 2011)
+
+ 10 Jan 2011; Mike Frysinger <vapier@gentoo.org> +ccache-3.1.4.ebuild:
+ Version bump.
29 Dec 2010; Markos Chandras <hwoarang@gentoo.org> ccache-2.4-r9.ebuild:
Stable on amd64 wrt bug #320687
diff --git a/dev-util/ccache/ccache-3.1.4.ebuild b/dev-util/ccache/ccache-3.1.4.ebuild
new file mode 100644
index 000000000000..728b8428f88e
--- /dev/null
+++ b/dev-util/ccache/ccache-3.1.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-3.1.4.ebuild,v 1.1 2011/01/10 05:22:59 vapier Exp $
+
+inherit multilib
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="http://ccache.samba.org/"
+SRC_URI="http://samba.org/ftp/ccache/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # make sure we always use system zlib
+ rm -rf zlib
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS.txt MANUAL.txt NEWS.txt README.txt
+
+ dobin "${FILESDIR}"/ccache-config || die
+ dosed "/^LIBDIR=/s:lib:$(get_libdir):" /usr/bin/ccache-config
+
+ diropts -m0700
+ dodir /root/.ccache
+ keepdir /root/.ccache
+}
+
+pkg_postinst() {
+ "${ROOT}"/usr/bin/ccache-config --install-links
+ "${ROOT}"/usr/bin/ccache-config --install-links ${CHOST}
+
+ # nuke broken symlinks from previous versions that shouldn't exist
+ rm -f "${ROOT}/usr/$(get_libdir)/ccache/bin/${CHOST}-cc"
+ [[ -d "${ROOT}/usr/$(get_libdir)/ccache.backup" ]] && \
+ rm -rf "${ROOT}/usr/$(get_libdir)/ccache.backup"
+
+ elog "To use ccache with **non-Portage** C compiling, add"
+ elog "/usr/$(get_libdir)/ccache/bin to the beginning of your path, before /usr/bin."
+ elog "Portage 2.0.46-r11+ will automatically take advantage of ccache with"
+ elog "no additional steps. If this is your first install of ccache, type"
+ elog "something like this to set a maximum cache size of 2GB:"
+ elog "# ccache -M 2G"
+ elog
+ elog "If you are upgrading from an older version than 3.x you should clear"
+ elog "all of your caches like so:"
+ elog "# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C"
+}