summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-03-15 03:44:04 +0000
committerTim Harder <radhermit@gentoo.org>2013-03-15 03:44:04 +0000
commitb079dc08b4c5bf54e6ee9dd7732bfee7e8a64c2e (patch)
treeafb26baee75eae377b3649b1191d2cb7ed00827c /dev-util/cloc
parentInitial import. (diff)
downloadgentoo-2-b079dc08b4c5bf54e6ee9dd7732bfee7e8a64c2e.tar.gz
gentoo-2-b079dc08b4c5bf54e6ee9dd7732bfee7e8a64c2e.tar.bz2
gentoo-2-b079dc08b4c5bf54e6ee9dd7732bfee7e8a64c2e.zip
Version bump.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-util/cloc')
-rw-r--r--dev-util/cloc/ChangeLog9
-rw-r--r--dev-util/cloc/cloc-1.58.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-util/cloc/ChangeLog b/dev-util/cloc/ChangeLog
index 1e4f077022e4..c3a6561fcb56 100644
--- a/dev-util/cloc/ChangeLog
+++ b/dev-util/cloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cloc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cloc/ChangeLog,v 1.8 2012/06/27 13:07:26 kensington Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cloc/ChangeLog,v 1.9 2013/03/15 03:44:04 radhermit Exp $
+
+*cloc-1.58 (15 Mar 2013)
+
+ 15 Mar 2013; Tim Harder <radhermit@gentoo.org> +cloc-1.58.ebuild:
+ Version bump.
*cloc-1.56 (27 Jun 2012)
diff --git a/dev-util/cloc/cloc-1.58.ebuild b/dev-util/cloc/cloc-1.58.ebuild
new file mode 100644
index 000000000000..cada8eba8660
--- /dev/null
+++ b/dev-util/cloc/cloc-1.58.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cloc/cloc-1.58.ebuild,v 1.1 2013/03/15 03:44:04 radhermit Exp $
+
+EAPI=5
+
+DESCRIPTION="Count Lines of Code"
+HOMEPAGE="http://cloc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.pl mirror://sourceforge/${PN}/${PN}.1.pod"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND=">=dev-lang/perl-5.6"
+RDEPEND="${DEPEND}
+ dev-perl/Algorithm-Diff
+ dev-perl/regexp-common
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp"
+
+S=${WORKDIR}
+
+src_unpack() { :; }
+
+src_prepare() {
+ pod2man "${DISTDIR}"/${PN}.1.pod > ${PN}.1 || die
+}
+
+src_install() {
+ doman ${PN}.1
+ newbin "${DISTDIR}"/${P}.pl ${PN}
+}