summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-17 19:08:42 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-17 19:08:42 +0000
commit5768fe981f1d779a1ce22e21df3118e0bd0298b8 (patch)
tree74ffa4eba145aa35ecac4b11afea9b454eb9af1b /dev-util/cmake
parentUse.mask libnl (diff)
downloadgentoo-2-5768fe981f1d779a1ce22e21df3118e0bd0298b8.tar.gz
gentoo-2-5768fe981f1d779a1ce22e21df3118e0bd0298b8.tar.bz2
gentoo-2-5768fe981f1d779a1ce22e21df3118e0bd0298b8.zip
Support more Boost versions.
(Portage version: 13832-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog8
-rw-r--r--dev-util/cmake/cmake-2.6.4-r1.ebuild144
-rw-r--r--dev-util/cmake/files/cmake-2.6.4-FindBoost.patch22
3 files changed, 173 insertions, 1 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index dd70505da4e5..8edb4ec06e4d 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.102 2009/05/31 22:51:33 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.103 2009/07/17 19:08:42 arfrever Exp $
+
+*cmake-2.6.4-r1 (17 Jul 2009)
+
+ 17 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +cmake-2.6.4-r1.ebuild, +files/cmake-2.6.4-FindBoost.patch:
+ Support more Boost versions.
31 May 2009; Markus Meier <maekke@gentoo.org> cmake-2.6.4.ebuild:
amd64 stable, bug #271444
diff --git a/dev-util/cmake/cmake-2.6.4-r1.ebuild b/dev-util/cmake/cmake-2.6.4-r1.ebuild
new file mode 100644
index 000000000000..60d0c0ee9343
--- /dev/null
+++ b/dev-util/cmake/cmake-2.6.4-r1.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.6.4-r1.ebuild,v 1.1 2009/07/17 19:08:42 arfrever Exp $
+
+EAPI="2"
+
+inherit elisp-common toolchain-funcs eutils versionator flag-o-matic cmake-utils
+
+MY_PV="${PV/rc/RC-}"
+MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="CMake"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="emacs qt4 vim-syntax"
+
+DEPEND="
+ >=net-misc/curl-7.16.4
+ >=dev-libs/expat-2.0.1
+ >=dev-libs/libxml2-2.6.28
+ >=dev-libs/xmlrpc-c-1.06.09[curl]
+ emacs? ( virtual/emacs )
+ qt4? ( x11-libs/qt-gui:4 )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+VIMFILE="${PN}.vim"
+
+S="${WORKDIR}/${MY_P}"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}/${PN}-FindJNI.patch"
+ "${FILESDIR}/${PN}-FindPythonLibs.patch"
+ "${FILESDIR}/${PN}-FindPythonInterp.patch"
+ "${FILESDIR}/${P}-FindBoost.patch"
+)
+
+src_configure() {
+ local qt_arg par_arg
+
+ if [[ "$(gcc-major-version)" -eq "3" ]] ; then
+ append-flags "-fno-stack-protector"
+ fi
+
+ bootstrap=0
+ has_version ">=dev-util/cmake-2.6.1" || bootstrap=1
+ if [[ ${bootstrap} = 0 ]]; then
+ # Required version of CMake found, now test if it works
+ cmake --version &> /dev/null
+ if ! [[ $? = 0 ]]; then
+ bootstrap=1
+ fi
+ fi
+
+ if [[ ${bootstrap} = 1 ]]; then
+ tc-export CC CXX LD
+
+ if use qt4; then
+ qt_arg="--qt-gui"
+ else
+ qt_arg="--no-qt-gui"
+ fi
+
+ echo $MAKEOPTS | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' > /dev/null
+ if [ $? -eq 0 ]; then
+ par_arg=$(echo $MAKEOPTS | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' | egrep -o '[[:digit:]]+')
+ par_arg="--parallel=${par_arg}"
+ else
+ par_arg="--parallel=1"
+ fi
+
+ ./bootstrap \
+ --system-libs \
+ --prefix=/usr \
+ --docdir=/share/doc/${PF} \
+ --datadir=/share/${PN} \
+ --mandir=/share/man \
+ "$qt_arg" \
+ "$par_arg" || die "./bootstrap failed"
+ else
+ # this is way much faster so we should preffer it if some cmake is
+ # around.
+ use qt4 && qt_arg="ON" || qt_arg="OFF"
+ mycmakeargs="-DCMAKE_USE_SYSTEM_LIBRARIES=ON
+ -DCMAKE_DOC_DIR=/share/doc/${PF}
+ -DCMAKE_MAN_DIR=/share/man
+ -DCMAKE_DATA_DIR=/share/${PN}
+ -DBUILD_CursesDialog=ON
+ -DBUILD_QtDialog=${qt_arg}"
+ cmake-utils_src_configure
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use emacs; then
+ elisp-compile Docs/cmake-mode.el || die "elisp compile failed"
+ fi
+}
+
+src_test() {
+ einfo "Please note that test \"58 - SimpleInstall-Stage2\" might fail."
+ einfo "If any package installs with cmake, it means test failed but cmake work."
+ emake test
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use emacs; then
+ elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins "${S}"/Docs/cmake-syntax.vim
+
+ insinto /usr/share/vim/vimfiles/indent
+ doins "${S}"/Docs/cmake-indent.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}/${VIMFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cmake/files/cmake-2.6.4-FindBoost.patch b/dev-util/cmake/files/cmake-2.6.4-FindBoost.patch
new file mode 100644
index 000000000000..a251d4fd1c1a
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.6.4-FindBoost.patch
@@ -0,0 +1,22 @@
+--- Modules/FindBoost.cmake
++++ Modules/FindBoost.cmake
+@@ -57,7 +57,8 @@
+ #
+ # Currently this module searches for the following version numbers:
+ # 1.33, 1.33.0, 1.33.1, 1.34, 1.34.0, 1.34.1, 1.35, 1.35.0, 1.35.1,
+-# 1.36, 1.36.0, 1.36.1, 1.37, 1.37.0, 1.38, 1.38.0
++# 1.36, 1.36.0, 1.36.1, 1.37, 1.37.0, 1.38, 1.38.0, 1.39, 1.39.0,
++# 1.40, 1.40.0, 1.41, 1.41.0, 1.42, 1.42.0, 1.43, 1.43.0, 1.44, 1.44.0
+ #
+ # NOTE: If you add a new major 1.x version in Boost_ADDITIONAL_VERSIONS you should
+ # add both 1.x and 1.x.0 as shown above. Official Boost include directories
+@@ -271,7 +272,8 @@
+ # The user has not requested an exact version. Among known
+ # versions, find those that are acceptable to the user request.
+ set(_Boost_KNOWN_VERSIONS ${Boost_ADDITIONAL_VERSIONS}
+- "1.38.0" "1.38" "1.37.0" "1.37"
++ "1.44.0" "1.44" "1.43.0" "1.43" "1.42.0" "1.42" "1.41.0" "1.41"
++ "1.40.0" "1.40" "1.39.0" "1.39" "1.38.0" "1.38" "1.37.0" "1.37"
+ "1.36.1" "1.36.0" "1.36" "1.35.1" "1.35.0" "1.35" "1.34.1" "1.34.0"
+ "1.34" "1.33.1" "1.33.0" "1.33")
+ set(_boost_TEST_VERSIONS)