summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Duft <mduft@gentoo.org>2008-12-17 15:00:49 +0000
committerMarkus Duft <mduft@gentoo.org>2008-12-17 15:00:49 +0000
commit08ca680f6fb28b6581536c0bd4a2cc42445a9d35 (patch)
tree25a81787ac4a844453b43b8c5c935489747ee1bb /dev-util/confix
parentFix compilation with gcc-4.3. Bug #251190. (diff)
downloadgentoo-2-08ca680f6fb28b6581536c0bd4a2cc42445a9d35.tar.gz
gentoo-2-08ca680f6fb28b6581536c0bd4a2cc42445a9d35.tar.bz2
gentoo-2-08ca680f6fb28b6581536c0bd4a2cc42445a9d35.zip
updated patch for confix to work with DESTDIR installs
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-util/confix')
-rw-r--r--dev-util/confix/ChangeLog9
-rw-r--r--dev-util/confix/confix-2.1.0-r3.ebuild (renamed from dev-util/confix/confix-2.1.0-r2.ebuild)2
-rw-r--r--dev-util/confix/files/2.1.0/fast-install.patch8
3 files changed, 13 insertions, 6 deletions
diff --git a/dev-util/confix/ChangeLog b/dev-util/confix/ChangeLog
index c5bb13821f1e..18384cb66bf6 100644
--- a/dev-util/confix/ChangeLog
+++ b/dev-util/confix/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/confix
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/ChangeLog,v 1.7 2008/12/17 09:43:16 mduft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/ChangeLog,v 1.8 2008/12/17 15:00:48 mduft Exp $
+
+*confix-2.1.0-r3 (17 Dec 2008)
+
+ 17 Dec 2008; Markus Duft <mduft@gentoo.org>
+ files/2.1.0/fast-install.patch, -confix-2.1.0-r2.ebuild,
+ +confix-2.1.0-r3.ebuild:
+ updated patch for confix to work with DESTDIR installs; oops...
17 Dec 2008; Markus Duft <mduft@gentoo.org>
files/2.1.0/fast-install.patch:
diff --git a/dev-util/confix/confix-2.1.0-r2.ebuild b/dev-util/confix/confix-2.1.0-r3.ebuild
index f5e84ab8011e..9228a932b7c5 100644
--- a/dev-util/confix/confix-2.1.0-r2.ebuild
+++ b/dev-util/confix/confix-2.1.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/confix-2.1.0-r2.ebuild,v 1.1 2008/12/09 08:30:18 mduft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/confix-2.1.0-r3.ebuild,v 1.1 2008/12/17 15:00:48 mduft Exp $
inherit distutils
diff --git a/dev-util/confix/files/2.1.0/fast-install.patch b/dev-util/confix/files/2.1.0/fast-install.patch
index 4db79b837991..f64582579bab 100644
--- a/dev-util/confix/files/2.1.0/fast-install.patch
+++ b/dev-util/confix/files/2.1.0/fast-install.patch
@@ -1,6 +1,6 @@
diff -ru Confix-2.1.0.orig/libconfix/core/automake/file_installer.py Confix-2.1.0/libconfix/core/automake/file_installer.py
--- Confix-2.1.0.orig/libconfix/core/automake/file_installer.py 2008-10-21 11:17:30 +0200
-+++ Confix-2.1.0/libconfix/core/automake/file_installer.py 2008-12-17 10:35:54 +0100
++++ Confix-2.1.0/libconfix/core/automake/file_installer.py 2008-12-17 11:58:32 +0100
@@ -22,6 +22,11 @@
from libconfix.core.utils.paragraph import Paragraph
from libconfix.core.utils import const
@@ -95,7 +95,7 @@ diff -ru Confix-2.1.0.orig/libconfix/core/automake/file_installer.py Confix-2.1.
+ if len(_f) >= FileInstaller.MAX_SIMULTANOUS_INSTALL or _i >= len(files):
+ # is this rule name unique enough?
+ rulename='.installstamp.public_' + my_md5(str(hash(self)) + targetdir + str(_i)).hexdigest()
-+ self.fast_general_install(makefile_am, rulename, targetdir, _f, '0644')
++ self.fast_general_install(makefile_am, rulename, '$(DESTDIR)' + targetdir, _f, '0644')
+ install_public_rule.add_prerequisite(rulename)
+ uninstall_public_rule.add_prerequisite(rulename + '_clean')
+ _f=[]
@@ -147,7 +147,7 @@ diff -ru Confix-2.1.0.orig/libconfix/core/automake/file_installer.py Confix-2.1.
+ if len(_f) >= FileInstaller.MAX_SIMULTANOUS_INSTALL or _i >= len(files):
+ # is this rule name unique enough?
+ rulename='.installstamp.public_data_' + my_md5(str(hash(self)) + targetdir + str(_i)).hexdigest()
-+ self.fast_general_install(makefile_am, rulename, targetdir, _f, '0644')
++ self.fast_general_install(makefile_am, rulename, '$(DESTDIR)' + targetdir, _f, '0644')
+ install_public_data_rule.add_prerequisite(rulename)
+ uninstall_public_data_rule.add_prerequisite(rulename + '_clean')
+ _f=[]
@@ -200,7 +200,7 @@ diff -ru Confix-2.1.0.orig/libconfix/core/automake/file_installer.py Confix-2.1.
+ if len(_f) >= FileInstaller.MAX_SIMULTANOUS_INSTALL or _i >= len(files):
+ # is this rule name unique enough?
+ rulename='.installstamp.public_prefix_' + my_md5(str(hash(self)) + targetdir + str(_i)).hexdigest()
-+ self.fast_general_install(makefile_am, rulename, targetdir, _f, '0644')
++ self.fast_general_install(makefile_am, rulename, '$(DESTDIR)' + targetdir, _f, '0644')
+ install_public_prefix_rule.add_prerequisite(rulename)
+ uninstall_public_prefix_rule.add_prerequisite(rulename + '_clean')
+ _f=[]