summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-05-28 08:32:24 +0000
committerMichael Weber <xmw@gentoo.org>2013-05-28 08:32:24 +0000
commitf70f8d5090346fcaa06a8eea85445cca0f94a17c (patch)
treeeb16e10361511085a19f31d0c408a28a7830f0a9 /dev-util/cppcheck
parentnet-misc/cbugzilla bump to 0.1.1 (diff)
downloadgentoo-2-f70f8d5090346fcaa06a8eea85445cca0f94a17c.tar.gz
gentoo-2-f70f8d5090346fcaa06a8eea85445cca0f94a17c.tar.bz2
gentoo-2-f70f8d5090346fcaa06a8eea85445cca0f94a17c.zip
Drop old, migrate to python-r1 classes
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'dev-util/cppcheck')
-rw-r--r--dev-util/cppcheck/ChangeLog8
-rw-r--r--dev-util/cppcheck/cppcheck-1.56.ebuild80
-rw-r--r--dev-util/cppcheck/cppcheck-1.57.ebuild80
-rw-r--r--dev-util/cppcheck/cppcheck-1.58.ebuild80
-rw-r--r--dev-util/cppcheck/cppcheck-1.59-r1.ebuild59
5 files changed, 66 insertions, 241 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index d20bf9644823..a5122825a40f 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cppcheck
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.38 2013/04/08 07:43:40 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.39 2013/05/28 08:32:23 xmw Exp $
+
+*cppcheck-1.59-r1 (28 May 2013)
+
+ 28 May 2013; Michael Weber <xmw@gentoo.org> +cppcheck-1.59-r1.ebuild,
+ -cppcheck-1.56.ebuild, -cppcheck-1.57.ebuild, -cppcheck-1.58.ebuild:
+ Drop old, migrate to python-r1 classes
*cppcheck-1.59 (08 Apr 2013)
diff --git a/dev-util/cppcheck/cppcheck-1.56.ebuild b/dev-util/cppcheck/cppcheck-1.56.ebuild
deleted file mode 100644
index 59a2bd19662f..000000000000
--- a/dev-util/cppcheck/cppcheck-1.56.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.56.ebuild,v 1.3 2013/03/02 20:21:20 hwoarang Exp $
-
-EAPI="3"
-PYTHON_DEPEND="htmlreport? 2"
-
-inherit distutils eutils qt4-r2 toolchain-funcs
-
-DESCRIPTION="static analyzer of C/C++ code"
-HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
-SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="htmlreport qt4"
-
-DEPEND="htmlreport? ( dev-python/pygments )
- qt4? ( dev-qt/qtgui:4 )"
-RDEPEND="${DEPEND}"
-
-DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
-
-pkg_setup() {
- if use htmlreport ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- if use htmlreport ; then
- pushd htmlreport
- python_convert_shebangs -r 2 .
- distutils_src_prepare
- popd
- fi
-}
-
-src_configure() {
- tc-export CXX
- if use qt4 ; then
- pushd gui
- qt4-r2_src_configure
- popd
- fi
-}
-
-src_compile() {
- emake || die
- if use qt4 ; then
- pushd gui
- qt4-r2_src_compile
- popd
- fi
- use htmlreport && distutils_src_compile
- #https://sourceforge.net/apps/trac/cppcheck/ticket/4149
- #$(tc-getCXX) ${CFLAGS} ${LDFLAGS} -o ${PN}-democlient.cgi \
- # democlient.cpp -I../lib democlient.cpp
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc readme.txt || die
- if use qt4 ; then
- dobin gui/${PN}-gui || die
- dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
- fi
- use htmlreport && distutils_src_install
- #dobin ${PN}-democlient.cgi
-}
-
-pkg_postinst() {
- use htmlreport && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use htmlreport && distutils_pkg_postrm
-}
diff --git a/dev-util/cppcheck/cppcheck-1.57.ebuild b/dev-util/cppcheck/cppcheck-1.57.ebuild
deleted file mode 100644
index 4520f2dba326..000000000000
--- a/dev-util/cppcheck/cppcheck-1.57.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.57.ebuild,v 1.2 2013/03/02 20:21:20 hwoarang Exp $
-
-EAPI="3"
-PYTHON_DEPEND="htmlreport? 2"
-
-inherit distutils eutils qt4-r2 toolchain-funcs
-
-DESCRIPTION="static analyzer of C/C++ code"
-HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
-SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="htmlreport qt4"
-
-DEPEND="htmlreport? ( dev-python/pygments )
- qt4? ( dev-qt/qtgui:4 )"
-RDEPEND="${DEPEND}"
-
-DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
-
-pkg_setup() {
- if use htmlreport ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- if use htmlreport ; then
- pushd htmlreport
- python_convert_shebangs -r 2 .
- distutils_src_prepare
- popd
- fi
-}
-
-src_configure() {
- tc-export CXX
- if use qt4 ; then
- pushd gui
- qt4-r2_src_configure
- popd
- fi
-}
-
-src_compile() {
- emake || die
- if use qt4 ; then
- pushd gui
- qt4-r2_src_compile
- popd
- fi
- use htmlreport && distutils_src_compile
- #https://sourceforge.net/apps/trac/cppcheck/ticket/4149
- #$(tc-getCXX) ${CFLAGS} ${LDFLAGS} -o ${PN}-democlient.cgi \
- # democlient.cpp -I../lib democlient.cpp
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc readme.txt || die
- if use qt4 ; then
- dobin gui/${PN}-gui || die
- dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
- fi
- use htmlreport && distutils_src_install
- #dobin ${PN}-democlient.cgi
-}
-
-pkg_postinst() {
- use htmlreport && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use htmlreport && distutils_pkg_postrm
-}
diff --git a/dev-util/cppcheck/cppcheck-1.58.ebuild b/dev-util/cppcheck/cppcheck-1.58.ebuild
deleted file mode 100644
index c11988e078c6..000000000000
--- a/dev-util/cppcheck/cppcheck-1.58.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.58.ebuild,v 1.2 2013/03/02 20:21:20 hwoarang Exp $
-
-EAPI="3"
-PYTHON_DEPEND="htmlreport? 2"
-
-inherit distutils eutils qt4-r2 toolchain-funcs
-
-DESCRIPTION="static analyzer of C/C++ code"
-HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
-SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="htmlreport qt4"
-
-DEPEND="htmlreport? ( dev-python/pygments )
- qt4? ( dev-qt/qtgui:4 )"
-RDEPEND="${DEPEND}"
-
-DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
-
-pkg_setup() {
- if use htmlreport ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- if use htmlreport ; then
- pushd htmlreport
- python_convert_shebangs -r 2 .
- distutils_src_prepare
- popd
- fi
-}
-
-src_configure() {
- tc-export CXX
- if use qt4 ; then
- pushd gui
- qt4-r2_src_configure
- popd
- fi
-}
-
-src_compile() {
- emake || die
- if use qt4 ; then
- pushd gui
- qt4-r2_src_compile
- popd
- fi
- use htmlreport && distutils_src_compile
- #https://sourceforge.net/apps/trac/cppcheck/ticket/4149
- #$(tc-getCXX) ${CFLAGS} ${LDFLAGS} -o ${PN}-democlient.cgi \
- # democlient.cpp -I../lib democlient.cpp
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc readme.txt || die
- if use qt4 ; then
- dobin gui/${PN}-gui || die
- dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
- fi
- use htmlreport && distutils_src_install
- #dobin ${PN}-democlient.cgi
-}
-
-pkg_postinst() {
- use htmlreport && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use htmlreport && distutils_pkg_postrm
-}
diff --git a/dev-util/cppcheck/cppcheck-1.59-r1.ebuild b/dev-util/cppcheck/cppcheck-1.59-r1.ebuild
new file mode 100644
index 000000000000..f84881ccf285
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-1.59-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.59-r1.ebuild,v 1.1 2013/05/28 08:32:23 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1 eutils qt4-r2 toolchain-funcs
+
+DESCRIPTION="static analyzer of C/C++ code"
+HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
+SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="htmlreport qt4"
+
+DEPEND="htmlreport? ( ${PYTHON_DEPS} )
+ qt4? ( dev-qt/qtgui:4 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ tc-export CXX
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ emake
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_compile
+ popd
+ fi
+ if use htmlreport ; then
+ pushd htmlreport
+ distutils-r1_src_compile
+ popd
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc readme.txt
+ if use qt4 ; then
+ dobin gui/${PN}-gui
+ dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck}
+ fi
+ if use htmlreport ; then
+ pushd htmlreport
+ distutils-r1_src_install
+ popd
+ fi
+}