summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-03-15 17:39:45 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-03-15 17:39:45 +0000
commit429bdb89bf1c32c819d937bafb906d8c9b5999cd (patch)
treec738b3b2f8fabfd59e81f98649812982ab2c275c /dev-util/cppunit
parentAdded ~ppc wrt bug 204813 (diff)
downloadgentoo-2-429bdb89bf1c32c819d937bafb906d8c9b5999cd.tar.gz
gentoo-2-429bdb89bf1c32c819d937bafb906d8c9b5999cd.tar.bz2
gentoo-2-429bdb89bf1c32c819d937bafb906d8c9b5999cd.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util/cppunit')
-rw-r--r--dev-util/cppunit/ChangeLog7
-rw-r--r--dev-util/cppunit/cppunit-1.12.1.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/dev-util/cppunit/ChangeLog b/dev-util/cppunit/ChangeLog
index ea44fcca1ed9..3b272c0d1f50 100644
--- a/dev-util/cppunit/ChangeLog
+++ b/dev-util/cppunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cppunit
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.40 2008/01/10 05:29:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.41 2008/03/15 17:39:45 dev-zero Exp $
+
+*cppunit-1.12.1 (15 Mar 2008)
+
+ 15 Mar 2008; Tiziano Müller <dev-zero@gentoo.org> +cppunit-1.12.1.ebuild:
+ Version bump.
10 Jan 2008; Jeroen Roovers <jer@gentoo.org> cppunit-1.12.0.ebuild:
Marked ~hppa (mr_bones, media-libs/musicbrainz dep).
diff --git a/dev-util/cppunit/cppunit-1.12.1.ebuild b/dev-util/cppunit/cppunit-1.12.1.ebuild
new file mode 100644
index 000000000000..47d68f690511
--- /dev/null
+++ b/dev-util/cppunit/cppunit-1.12.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.12.1.ebuild,v 1.1 2008/03/15 17:39:45 dev-zero Exp $
+
+#WANT_AUTOCONF=latest
+#WANT_AUTOMAKE=1.9
+
+inherit eutils autotools qt3
+
+DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
+HOMEPAGE="http://cppunit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples qt3"
+
+RDEPEND="qt3? ( $(qt_min_version 3.3) )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen
+ media-gfx/graphviz )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.10.2-asneeded.patch"
+
+ sed -i \
+ -e 's|-L\($${CPPUNIT_LIB_DIR}\)|\1|' \
+ -e 's|\(../../lib\)|-L\1 -L../../src/cppunit/.libs|' \
+ examples/qt/qt_example.pro || die "sed failed"
+
+ AT_M4DIR="${S}/config"
+ eautomake
+ elibtoolize
+}
+
+src_compile() {
+ # Anything else than -O0 breaks on alpha
+ use alpha && replace-flags "-O?" -O0
+
+ econf \
+ $(use_enable doc doxygen) \
+ $(use_enable doc dot) \
+ --htmldir=/usr/share/doc/${PF}/html \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if use qt3 ; then
+ cd src/qttestrunner
+ eqmake3 qttestrunnerlib.pro || die "qmake failed"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog BUGS NEWS README THANKS TODO doc/FAQ
+
+ if use qt3 ; then
+ dolib lib/*
+ fi
+
+ if use examples ; then
+ find examples -iname "*.o" -delete
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+}