summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2011-01-26 20:51:13 +0000
committerDoug Goldstein <cardoe@gentoo.org>2011-01-26 20:51:13 +0000
commit898a63a743fe9563c1c99943bf8f34d9314a52bf (patch)
treeb40b78db1364ed9bf487d34d6abd82b4fdb86120 /dev-util/crash
parentRevision bump to fix bug #345725. Thanks to Ben Sagal for reporting. (diff)
downloadgentoo-2-898a63a743fe9563c1c99943bf8f34d9314a52bf.tar.gz
gentoo-2-898a63a743fe9563c1c99943bf8f34d9314a52bf.tar.bz2
gentoo-2-898a63a743fe9563c1c99943bf8f34d9314a52bf.zip
Add the Red Hat crash analyzer utility
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/crash')
-rw-r--r--dev-util/crash/ChangeLog10
-rw-r--r--dev-util/crash/crash-5.1.1.ebuild23
-rw-r--r--dev-util/crash/files/crash-5.1.1-install-fix.patch12
-rw-r--r--dev-util/crash/metadata.xml17
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/crash/ChangeLog b/dev-util/crash/ChangeLog
new file mode 100644
index 000000000000..b98926ec52e1
--- /dev/null
+++ b/dev-util/crash/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/crash
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/crash/ChangeLog,v 1.1 2011/01/26 20:51:13 cardoe Exp $
+
+*crash-5.1.1 (26 Jan 2011)
+
+ 26 Jan 2011; Doug Goldstein <cardoe@gentoo.org> +crash-5.1.1.ebuild,
+ +files/crash-5.1.1-install-fix.patch:
+ Add the Red Hat crash analyzer utility
+
diff --git a/dev-util/crash/crash-5.1.1.ebuild b/dev-util/crash/crash-5.1.1.ebuild
new file mode 100644
index 000000000000..760429ee4130
--- /dev/null
+++ b/dev-util/crash/crash-5.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/crash/crash-5.1.1.ebuild,v 1.1 2011/01/26 20:51:13 cardoe Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Red Hat crash utility. Used for analyzing kernel core dumps"
+HOMEPAGE="http://people.redhat.com/anderson/"
+SRC_URI="http://people.redhat.com/anderson/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~alpha ~amd64 ~arm ~ia64 ~ppc64 ~s390 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-install-fix.patch
+}
diff --git a/dev-util/crash/files/crash-5.1.1-install-fix.patch b/dev-util/crash/files/crash-5.1.1-install-fix.patch
new file mode 100644
index 000000000000..98b86759361d
--- /dev/null
+++ b/dev-util/crash/files/crash-5.1.1-install-fix.patch
@@ -0,0 +1,12 @@
+diff -Nur crash-5.1.1/Makefile crash-5.1.1-fixes//Makefile
+--- crash-5.1.1/Makefile 2010-12-23 12:59:44.000000000 -0600
++++ crash-5.1.1-fixes//Makefile 2011-01-26 13:17:11.000000000 -0600
+@@ -322,7 +322,7 @@
+ cc -c ${CRASH_CFLAGS} build_data.c ${WARNING_OPTIONS} ${WARNING_ERROR}
+
+ install:
+- /usr/bin/install ${PROGRAM} ${INSTALLDIR}
++ /usr/bin/install -D ${PROGRAM} ${INSTALLDIR}/${PROGRAM}
+ # /usr/bin/install ${PROGRAM}d ${INSTALLDIR}
+
+ unconfig: make_configure
diff --git a/dev-util/crash/metadata.xml b/dev-util/crash/metadata.xml
new file mode 100644
index 000000000000..c172a8fd9074
--- /dev/null
+++ b/dev-util/crash/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Red Hat crash analysis utility is loosely based on the SVR4 UNIX
+ crash command, but has been significantly enhanced by completely merging
+ it with the GNU gdb debugger. The marriage of the two effectively
+ combines the kernel-specific nature of the traditional UNIX crash
+ utility with the source code level debugging capabilities of gdb.
+ </longdescription>
+</pkgmetadata>
+