summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-06-16 18:14:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-06-16 18:14:45 +0000
commit0805fe5bd6473c51e6f2c730cfaee852340948de (patch)
tree1849edecfadd6e602d6cf389cbccf97ca72537a2 /dev-util/cvs
parentRepoman cleanup pass 2. (diff)
downloadgentoo-2-0805fe5bd6473c51e6f2c730cfaee852340948de.tar.gz
gentoo-2-0805fe5bd6473c51e6f2c730cfaee852340948de.tar.bz2
gentoo-2-0805fe5bd6473c51e6f2c730cfaee852340948de.zip
Bug #222341, do not install the cvs-format emacs lisp file, as it clobbers the normal C indentation when loaded.
(Portage version: 2.1.5.5)
Diffstat (limited to 'dev-util/cvs')
-rw-r--r--dev-util/cvs/ChangeLog9
-rw-r--r--dev-util/cvs/cvs-1.12.12-r5.ebuild78
-rw-r--r--dev-util/cvs/cvs-1.12.13.1.ebuild13
3 files changed, 92 insertions, 8 deletions
diff --git a/dev-util/cvs/ChangeLog b/dev-util/cvs/ChangeLog
index 05e235676b07..add9bff93632 100644
--- a/dev-util/cvs/ChangeLog
+++ b/dev-util/cvs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/cvs
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/ChangeLog,v 1.126 2008/06/16 18:11:58 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/ChangeLog,v 1.127 2008/06/16 18:14:45 robbat2 Exp $
+
+*cvs-1.12.12-r5 (16 Jun 2008)
+
+ 16 Jun 2008; Robin H. Johnson <robbat2@gentoo.org> +cvs-1.12.12-r5.ebuild,
+ cvs-1.12.13.1.ebuild:
+ Bug #222341, do not install the cvs-format emacs lisp file, as it clobbers
+ the normal C indentation when loaded.
16 Jun 2008; Robin H. Johnson <robbat2@gentoo.org> cvs-1.11.20.ebuild,
cvs-1.11.21.ebuild, cvs-1.11.22.1.ebuild, cvs-1.12.12-r2.ebuild,
diff --git a/dev-util/cvs/cvs-1.12.12-r5.ebuild b/dev-util/cvs/cvs-1.12.12-r5.ebuild
new file mode 100644
index 000000000000..180581a09e8a
--- /dev/null
+++ b/dev-util/cvs/cvs-1.12.12-r5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.12-r5.ebuild,v 1.1 2008/06/16 18:14:45 robbat2 Exp $
+
+inherit eutils pam
+
+DESCRIPTION="Concurrent Versions System - source code revision control tools"
+HOMEPAGE="http://www.nongnu.org/cvs/"
+
+SRC_URI="mirror://gnu/non-gnu/cvs/source/feature/${PV}/${P}.tar.bz2
+ doc? ( mirror://gnu/non-gnu/cvs/source/feature/${PV}/cederqvist-${PV}.html.tar.bz2
+ mirror://gnu/non-gnu/cvs/source/feature/${PV}/cederqvist-${PV}.pdf
+ mirror://gnu/non-gnu/cvs/source/feature/${PV}/cederqvist-${PV}.ps )"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+IUSE="crypt doc kerberos nls pam server"
+
+DEPEND=">=sys-libs/zlib-1.1.4
+ kerberos? ( virtual/krb5 )
+ pam? ( virtual/pam )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use doc && unpack cederqvist-${PV}.html.tar.bz2
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${P}-cvsbug-tmpfix.patch
+ epatch "${FILESDIR}"/${P}-openat.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${P}-block-requests.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-install-sh.patch
+ elog "If you want any CVS server functionality, you MUST emerge with USE=server!"
+}
+
+src_compile() {
+ econf \
+ --with-external-zlib \
+ --with-tmpdir=/tmp \
+ $(use_enable crypt encryption) \
+ $(use_with kerberos gssapi) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_enable server) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/cvspserver.xinetd.d cvspserver || die "newins failed"
+
+ dodoc BUGS ChangeLog* DEVEL* FAQ HACKING \
+ MINOR* NEWS PROJECTS README* TESTS TODO
+
+ # Not installed into emacs site-lisp because it clobbers the normal C
+ # indentations.
+ dodoc cvs-format.el || die "dodoc failed"
+
+ use server && newdoc "${FILESDIR}"/cvs-1.12.12-cvs-custom.c cvs-custom.c
+
+ if use doc; then
+ dodoc "${DISTDIR}"/cederqvist-${PV}.pdf
+ dodoc "${DISTDIR}"/cederqvist-${PV}.ps
+ tar xjf "${DISTDIR}"/cederqvist-${PV}.html.tar.bz2
+ dohtml -r cederqvist-${PV}.html/*
+ cd "${D}"/usr/share/doc/${PF}/html/
+ ln -s cvs.html index.html
+ fi
+
+ newpamd "${FILESDIR}"/cvs.pam-include-1.12.12 cvs
+}
+
+src_test() {
+ einfo "FEATURES=\"maketest\" has been disabled for dev-util/cvs"
+}
diff --git a/dev-util/cvs/cvs-1.12.13.1.ebuild b/dev-util/cvs/cvs-1.12.13.1.ebuild
index fafe3c16f407..71a48eb9e281 100644
--- a/dev-util/cvs/cvs-1.12.13.1.ebuild
+++ b/dev-util/cvs/cvs-1.12.13.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.13.1.ebuild,v 1.4 2007/12/07 01:55:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.13.1.ebuild,v 1.5 2008/06/16 18:14:45 robbat2 Exp $
inherit eutils pam versionator
@@ -24,7 +24,7 @@ LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="crypt doc emacs kerberos nls pam server"
+IUSE="crypt doc kerberos nls pam server"
DEPEND=">=sys-libs/zlib-1.1.4
kerberos? ( virtual/krb5 )
@@ -86,10 +86,9 @@ src_install() {
dodoc BUGS ChangeLog* DEVEL* FAQ HACKING \
MINOR* NEWS PROJECTS README* TESTS TODO
- if use emacs; then
- insinto /usr/share/emacs/site-lisp
- doins cvs-format.el || die "doins failed"
- fi
+ # Not installed into emacs site-lisp because it clobbers the normal C
+ # indentations.
+ dodoc cvs-format.el || die "dodoc failed"
use server && newdoc "${FILESDIR}"/${PN}-1.12.12-cvs-custom.c cvs-custom.c