summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-11-01 00:33:58 +0000
committerMax Kalika <max@gentoo.org>2003-11-01 00:33:58 +0000
commitdb7e3f4e6bd53862a37ae1e33571275477f2f72f (patch)
tree9205be1affa49d0019d3acc03118a1efeb0e37ac /dev-util/cvsd/cvsd-1.0.0.ebuild
parentVersion bump (diff)
downloadgentoo-2-db7e3f4e6bd53862a37ae1e33571275477f2f72f.tar.gz
gentoo-2-db7e3f4e6bd53862a37ae1e33571275477f2f72f.tar.bz2
gentoo-2-db7e3f4e6bd53862a37ae1e33571275477f2f72f.zip
Bump to version 1.0.0. Major cleanup.
Diffstat (limited to 'dev-util/cvsd/cvsd-1.0.0.ebuild')
-rw-r--r--dev-util/cvsd/cvsd-1.0.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/cvsd/cvsd-1.0.0.ebuild b/dev-util/cvsd/cvsd-1.0.0.ebuild
new file mode 100644
index 000000000000..8dfa38d643ea
--- /dev/null
+++ b/dev-util/cvsd/cvsd-1.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsd/cvsd-1.0.0.ebuild,v 1.1 2003/11/01 00:33:57 max Exp $
+
+DESCRIPTION="CVS pserver daemon."
+HOMEPAGE="http://tiefighter.et.tudelft.nl/~arthur/cvsd/"
+SRC_URI="http://tiefighter.et.tudelft.nl/~arthur/cvsd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="tcpd"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}
+ >=dev-lang/perl-5.8.0
+ >=dev-util/cvs-1.11.6"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} `use_with tcpd libwrap`"
+
+ econf ${myconf}
+ emake || die "compile problem"
+}
+
+src_install() {
+ enewgroup cvsd
+ enewuser cvsd -1 /bin/false /var/lib/cvsd cvsd
+
+ make DESTDIR="${D}" install || die "make install failed"
+ dosed 's:^Repos:# Repos:g' /etc/cvsd/cvsd.conf
+ keepdir /var/lib/cvsd
+
+ dodoc AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README TODO
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/cvsd.rc6" cvsd
+}
+
+pkg_postinst() {
+ einfo "To configure cvsd please read /usr/share/doc/${PF}/README.gz"
+}