summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nazaroff <naz@gentoo.org>2002-07-01 00:18:40 +0000
committerMichael Nazaroff <naz@gentoo.org>2002-07-01 00:18:40 +0000
commit2684e60a3135f267418fd663f904f4944b53a953 (patch)
tree25b2f6e2c47b8732cd85ec142451187dab94cdc7 /dev-util/ddd/ddd-3.3.1-r1.ebuild
parentFixed a problem with the libxml-2 dependence. Closes bug #4368 (diff)
downloadgentoo-2-2684e60a3135f267418fd663f904f4944b53a953.tar.gz
gentoo-2-2684e60a3135f267418fd663f904f4944b53a953.tar.bz2
gentoo-2-2684e60a3135f267418fd663f904f4944b53a953.zip
modified ebuild to make motif a dependency
Diffstat (limited to 'dev-util/ddd/ddd-3.3.1-r1.ebuild')
-rw-r--r--dev-util/ddd/ddd-3.3.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/ddd/ddd-3.3.1-r1.ebuild b/dev-util/ddd/ddd-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..c2ff38d8c6a9
--- /dev/null
+++ b/dev-util/ddd/ddd-3.3.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Geert Bevin <gbevin@theleaf.be>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ddd-3.3.1-r1.ebuild,v 1.1 2002/07/01 00:18:40 naz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU DDD is a graphical front-end for command-line debuggers"
+SRC_URI="ftp://ftp.easynet.be/gnu/ddd/${P}.tar.gz \
+ ftp://ftp.easynet.be/gnu/ddd/${P}-html-manual.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/ddd"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ >=sys-devel/gdb-4.16
+ >=x11-libs/openmotif-2.1.30"
+
+src_compile() {
+ try ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+
+ try emake
+}
+
+src_install () {
+ try make DESTDIR=${D} install
+
+ mv ${S}/doc/README ${S}/doc/README-DOC
+ dodoc ANNOUNCE AUTHORS BUGS COPYING* CREDITS INSTALL NEWS* NICKNAMES \
+ OPENBUGS PROBLEMS README* TIPS TODO doc/README-DOC
+
+ rm ${S}/doc/README-DOC
+ mv ${S}/doc/* ${D}/usr/share/doc/${PF}
+}
+