summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-05-19 04:16:05 +0000
committerJeroen Roovers <jer@gentoo.org>2015-05-19 04:16:05 +0000
commitd618b20b73324a22c9bdee28a91f62fd249f0e93 (patch)
tree5d2e83881fe95c3ae2cd2783bf1ae205879f4435 /dev-util/debootstrap
parentSet stopsig instead of retry. (diff)
downloadgentoo-2-d618b20b73324a22c9bdee28a91f62fd249f0e93.tar.gz
gentoo-2-d618b20b73324a22c9bdee28a91f62fd249f0e93.tar.bz2
gentoo-2-d618b20b73324a22c9bdee28a91f62fd249f0e93.zip
Version bump.
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-util/debootstrap')
-rw-r--r--dev-util/debootstrap/ChangeLog7
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.69.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-util/debootstrap/ChangeLog b/dev-util/debootstrap/ChangeLog
index a5fe5a5927b6..f5d7ff3a0af4 100644
--- a/dev-util/debootstrap/ChangeLog
+++ b/dev-util/debootstrap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/debootstrap
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/debootstrap/ChangeLog,v 1.283 2015/05/17 06:40:19 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debootstrap/ChangeLog,v 1.284 2015/05/19 04:16:05 jer Exp $
+
+*debootstrap-1.0.69 (19 May 2015)
+
+ 19 May 2015; Jeroen Roovers <jer@gentoo.org> +debootstrap-1.0.69.ebuild:
+ Version bump.
*debootstrap-1.0.68 (17 May 2015)
diff --git a/dev-util/debootstrap/debootstrap-1.0.69.ebuild b/dev-util/debootstrap/debootstrap-1.0.69.ebuild
new file mode 100644
index 000000000000..0be5bf9fa55a
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.69.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debootstrap/debootstrap-1.0.69.ebuild,v 1.1 2015/05/19 04:16:05 jer Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="http://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+
+DOCS=( TODO debian/changelog )
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring"
+ elog " (--keyring=K), please install app-crypt/gnupg."
+ fi
+}