summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-10 05:14:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-10 05:14:56 +0000
commit4cf28695e7b91d26972f95cef1fba16930a55796 (patch)
tree37ddd2df122c5920d41ebc92de3f3b420e16a7ae /dev-util/dwarves
parentUse pkg-config instead of glib-config. Fix parallel make. Respect LDFLAGS (bu... (diff)
downloadgentoo-2-4cf28695e7b91d26972f95cef1fba16930a55796.tar.gz
gentoo-2-4cf28695e7b91d26972f95cef1fba16930a55796.tar.bz2
gentoo-2-4cf28695e7b91d26972f95cef1fba16930a55796.zip
Fix building with recent glibc wrt #336478 by Benjamin Bannier.
(Portage version: 2.2_rc78/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/dwarves')
-rw-r--r--dev-util/dwarves/ChangeLog8
-rw-r--r--dev-util/dwarves/dwarves-1.8.ebuild6
-rw-r--r--dev-util/dwarves/files/dwarves-1.8-glibc-212.patch13
3 files changed, 23 insertions, 4 deletions
diff --git a/dev-util/dwarves/ChangeLog b/dev-util/dwarves/ChangeLog
index 67c42d45593b..b14ed5d94be0 100644
--- a/dev-util/dwarves/ChangeLog
+++ b/dev-util/dwarves/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/dwarves
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dwarves/ChangeLog,v 1.9 2009/12/08 22:10:36 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dwarves/ChangeLog,v 1.10 2010/09/10 05:14:56 ssuominen Exp $
+
+ 10 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> dwarves-1.8.ebuild,
+ +files/dwarves-1.8-glibc-212.patch:
+ Fix building with recent glibc wrt #336478 by Benjamin Bannier.
*dwarves-1.8 (08 Dec 2009)
diff --git a/dev-util/dwarves/dwarves-1.8.ebuild b/dev-util/dwarves/dwarves-1.8.ebuild
index 00433014caf7..7e3c12f68574 100644
--- a/dev-util/dwarves/dwarves-1.8.ebuild
+++ b/dev-util/dwarves/dwarves-1.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dwarves/dwarves-1.8.ebuild,v 1.1 2009/12/08 22:10:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dwarves/dwarves-1.8.ebuild,v 1.2 2010/09/10 05:14:56 ssuominen Exp $
inherit toolchain-funcs multilib cmake-utils flag-o-matic
@@ -23,6 +23,8 @@ else
SRC_URI="mirror://gentoo/${P}.tar.bz2"
fi
+PATCHES=( "${FILESDIR}"/${P}-glibc-212.patch )
+
src_compile() {
tc-export CC CXX LD
diff --git a/dev-util/dwarves/files/dwarves-1.8-glibc-212.patch b/dev-util/dwarves/files/dwarves-1.8-glibc-212.patch
new file mode 100644
index 000000000000..9da84d4b45a6
--- /dev/null
+++ b/dev-util/dwarves/files/dwarves-1.8-glibc-212.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/336478
+
+--- dwarves.c
++++ dwarves.c
+@@ -21,6 +21,8 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
++#include <sys/types.h>
++#include <sys/stat.h>
+
+ #include "config.h"
+ #include "list.h"