summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-11 11:39:23 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-11 11:39:23 +0000
commita1bc0189c79a0697ba62fc5ca57d028131b0b366 (patch)
tree73e6be4351db8660b071f7bbfe73bd1ca43d5b1e /dev-util/eggy
parentFix building against sys-libs/ncurses[tinfo] (bug #536164 by Reuben Martin). (diff)
downloadgentoo-2-a1bc0189c79a0697ba62fc5ca57d028131b0b366.tar.gz
gentoo-2-a1bc0189c79a0697ba62fc5ca57d028131b0b366.tar.bz2
gentoo-2-a1bc0189c79a0697ba62fc5ca57d028131b0b366.zip
revbump; conversion -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-util/eggy')
-rw-r--r--dev-util/eggy/ChangeLog10
-rw-r--r--dev-util/eggy/eggy-0.3.3-r1.ebuild29
-rw-r--r--dev-util/eggy/eggy-0.3.3.ebuild31
3 files changed, 37 insertions, 33 deletions
diff --git a/dev-util/eggy/ChangeLog b/dev-util/eggy/ChangeLog
index 73a767ed98fd..fe0c12ec1d66 100644
--- a/dev-util/eggy/ChangeLog
+++ b/dev-util/eggy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/eggy
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eggy/ChangeLog,v 1.3 2014/05/30 21:36:14 pesa Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eggy/ChangeLog,v 1.4 2015/01/11 11:39:23 idella4 Exp $
+
+*eggy-0.3.3-r1 (11 Jan 2015)
+
+ 11 Jan 2015; Ian Delaney <idella4@gentoo.org> +eggy-0.3.3-r1.ebuild,
+ -eggy-0.3.3.ebuild:
+ revbump; conversion -> distutils-r1, rm old
30 May 2014; Davide Pesavento <pesa@gentoo.org> metadata.xml:
Drop to maintainer-needed.
diff --git a/dev-util/eggy/eggy-0.3.3-r1.ebuild b/dev-util/eggy/eggy-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..7e9b80ef4218
--- /dev/null
+++ b/dev-util/eggy/eggy-0.3.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eggy/eggy-0.3.3-r1.ebuild,v 1.1 2015/01/11 11:39:23 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="An IDE/editor for several programming languages, including Python, Java, C, Perl and others"
+HOMEPAGE="http://eggy.yolky.org/eggy/default/about"
+SRC_URI="http://eggy.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ # remove the bundled chardet library
+ sed -i "s:'eggy\\.chardet', ::" setup.py || die
+ rm -rf ${P}/${PN}/chardet || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-util/eggy/eggy-0.3.3.ebuild b/dev-util/eggy/eggy-0.3.3.ebuild
deleted file mode 100644
index 82b74849f896..000000000000
--- a/dev-util/eggy/eggy-0.3.3.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eggy/eggy-0.3.3.ebuild,v 1.2 2010/06/29 23:20:28 arfrever Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="An IDE/editor for several programming languages, including Python, Java, C, Perl and others"
-HOMEPAGE="http://eggy.yolky.org/eggy/default/about"
-SRC_URI="http://eggy.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-python/PyQt4[X]
- dev-python/qscintilla-python
- dev-python/chardet"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # remove the bundled chardet library
- sed -i "s:'eggy\\.chardet', ::" setup.py || die "sed failed"
- rm -rf ${P}/${PN}/chardet || die "rm failed"
- distutils_src_prepare
-}