summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-06-24 02:41:52 +0000
committerMarius Mauch <genone@gentoo.org>2004-06-24 02:41:52 +0000
commit4f21a033a3dbc38ac63097dd1f1ec95d5729bd95 (patch)
treee4574e23d1130477f1851c2c3d728c485754d30e /dev-util/gambas
parentfine, I'll use export. (Manifest recommit) (diff)
downloadgentoo-2-4f21a033a3dbc38ac63097dd1f1ec95d5729bd95.tar.gz
gentoo-2-4f21a033a3dbc38ac63097dd1f1ec95d5729bd95.tar.bz2
gentoo-2-4f21a033a3dbc38ac63097dd1f1ec95d5729bd95.zip
removing old versions
Diffstat (limited to 'dev-util/gambas')
-rw-r--r--dev-util/gambas/files/digest-gambas-0.921
-rw-r--r--dev-util/gambas/files/digest-gambas-0.92-r11
-rw-r--r--dev-util/gambas/gambas-0.92-r1.ebuild79
-rw-r--r--dev-util/gambas/gambas-0.92.ebuild77
4 files changed, 0 insertions, 158 deletions
diff --git a/dev-util/gambas/files/digest-gambas-0.92 b/dev-util/gambas/files/digest-gambas-0.92
deleted file mode 100644
index cbd497f821a3..000000000000
--- a/dev-util/gambas/files/digest-gambas-0.92
+++ /dev/null
@@ -1 +0,0 @@
-MD5 06641baa8c0405a9075088690eb30a67 gambas-0.92.tar.bz2 2735305
diff --git a/dev-util/gambas/files/digest-gambas-0.92-r1 b/dev-util/gambas/files/digest-gambas-0.92-r1
deleted file mode 100644
index cbd497f821a3..000000000000
--- a/dev-util/gambas/files/digest-gambas-0.92-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 06641baa8c0405a9075088690eb30a67 gambas-0.92.tar.bz2 2735305
diff --git a/dev-util/gambas/gambas-0.92-r1.ebuild b/dev-util/gambas/gambas-0.92-r1.ebuild
deleted file mode 100644
index 07ebae3e732f..000000000000
--- a/dev-util/gambas/gambas-0.92-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.92-r1.ebuild,v 1.2 2004/04/21 13:15:55 genone Exp $
-
-inherit eutils
-
-DESCRIPTION="a RAD tool for BASIC"
-HOMEPAGE="http://gambas.sourceforge.net"
-SRC_URI="http://gambas.sourceforge.net/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="postgres mysql sdl doc curl debug"
-
-DEPEND=">=sys-devel/automake-1.7.5
- >=x11-libs/qt-3.2
- >=kde-base/kdelibs-3.2
- sdl? ( media-libs/libsdl )
- mysql? ( dev-db/mysql )
- postgres? ( dev-db/postgresql )
- curl? ( net-misc/curl )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i 's:-Os::' configure
- # replace braindead Makefile
- rm Makefile*
- cp "${FILESDIR}/Makefile.am-0.90" ./Makefile.am
- automake
- # patches against hardcoded paths
- epatch ${FILESDIR}/non-symlink-0.90.patch
- epatch ${FILESDIR}/info-location-0.90.patch
- # patch to fix bug with tabstrips
- epatch ${FILESDIR}/gbx_exec_enum-0.92.patch
-}
-
-src_compile() {
- local myconf
-
- myconf="${myconf} --enable-kde --enable-qt"
- myconf="${myconf} `use_enable mysql`"
- myconf="${myconf} `use_enable postgres`"
- myconf="${myconf} `use_enable sdl`"
- myconf="${myconf} `use_enable curl`"
-
- if use debug ; then
- myconf="${myconf} --disable-optimization --enable-debug"
- else
- myconf="${myconf} --enable-optimization --disable-debug"
- fi
-
- econf ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- export PATH="${D}/usr/bin:${PATH}"
- einstall || die
-
- dodoc README INSTALL NEWS AUTHORS ChangeLog TODO
-
- # only install the API docs and examples with USE=doc
- if use doc; then
- mv ${D}/usr/share/help ${D}/usr/share/doc/${PF}/html
- mv ${D}/usr/share/examples ${D}/usr/share/doc/${PF}/examples
- einfo "Compiling examples ..."
- cd ${D}/usr/share/doc/${PF}/examples
- for p in *; do
- cd $p
- gbc -ag
- gba
- cd ..
- done
- fi
- rm -rf ${D}/usr/share/help ${D}/usr/share/examples
-}
diff --git a/dev-util/gambas/gambas-0.92.ebuild b/dev-util/gambas/gambas-0.92.ebuild
deleted file mode 100644
index b3db6e8ba12f..000000000000
--- a/dev-util/gambas/gambas-0.92.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.92.ebuild,v 1.1 2004/04/03 13:22:28 genone Exp $
-
-inherit eutils
-
-DESCRIPTION="a RAD tool for BASIC"
-HOMEPAGE="http://gambas.sourceforge.net"
-SRC_URI="http://gambas.sourceforge.net/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="postgres mysql sdl doc curl debug"
-
-DEPEND=">=sys-devel/automake-1.7.5
- >=x11-libs/qt-3.2
- >=kde-base/kdelibs-3.2
- sdl? ( media-libs/libsdl )
- mysql? ( dev-db/mysql )
- postgres? ( dev-db/postgresql )
- curl? ( net-misc/curl )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i 's:-Os::' configure
- # replace braindead Makefile
- rm Makefile*
- cp "${FILESDIR}/Makefile.am-0.90" ./Makefile.am
- automake
- # patches against hardcoded paths
- epatch ${FILESDIR}/non-symlink-0.90.patch
- epatch ${FILESDIR}/info-location-0.90.patch
-}
-
-src_compile() {
- local myconf
-
- myconf="${myconf} --enable-kde --enable-qt"
- myconf="${myconf} `use_enable mysql`"
- myconf="${myconf} `use_enable postgres`"
- myconf="${myconf} `use_enable sdl`"
- myconf="${myconf} `use_enable curl`"
-
- if use debug; then
- myconf="${myconf} --disable-optimization --enable-debug"
- else
- myconf="${myconf} --enable-optimization --disable-debug"
- fi
-
- econf ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- export PATH="${D}/usr/bin:${PATH}"
- einstall || die
-
- dodoc README INSTALL NEWS AUTHORS ChangeLog TODO
-
- # only install the API docs and examples with USE=doc
- if use doc; then
- mv ${D}/usr/share/help ${D}/usr/share/doc/${PF}/html
- mv ${D}/usr/share/examples ${D}/usr/share/doc/${PF}/examples
- einfo "Compiling examples ..."
- cd ${D}/usr/share/doc/${PF}/examples
- for p in *; do
- cd $p
- gbc -ag
- gba
- cd ..
- done
- fi
- rm -rf ${D}/usr/share/help ${D}/usr/share/examples
-}