summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-11-24 01:08:06 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-11-24 01:08:06 +0000
commit3ed2a2791abef854c934d5487d5de0c293b9acd6 (patch)
tree29414230976ddcbcf73e9889bc5ffe3321770589 /dev-util/git/files
parentBump (diff)
downloadgentoo-2-3ed2a2791abef854c934d5487d5de0c293b9acd6.tar.gz
gentoo-2-3ed2a2791abef854c934d5487d5de0c293b9acd6.tar.bz2
gentoo-2-3ed2a2791abef854c934d5487d5de0c293b9acd6.zip
Fix bug #235393 for Emacs users. Fix bug #238351 for running the standalone init.d more safely as non-root and include the pidfile. Bug #247487, cvsserver now needs the Perl stuff. Bug #248446, fix htmldir support.
(Portage version: 2.2_rc14/cvs/Linux 2.6.28-rc5-00117-g7f0f598 x86_64)
Diffstat (limited to 'dev-util/git/files')
-rw-r--r--dev-util/git/files/20081123-git-1.6.0.4-noperl-cvsserver.patch20
-rw-r--r--dev-util/git/files/50git-gentoo.el13
-rw-r--r--dev-util/git/files/git-daemon.confd13
-rw-r--r--dev-util/git/files/git-daemon.initd10
4 files changed, 50 insertions, 6 deletions
diff --git a/dev-util/git/files/20081123-git-1.6.0.4-noperl-cvsserver.patch b/dev-util/git/files/20081123-git-1.6.0.4-noperl-cvsserver.patch
new file mode 100644
index 000000000000..3412584576c5
--- /dev/null
+++ b/dev-util/git/files/20081123-git-1.6.0.4-noperl-cvsserver.patch
@@ -0,0 +1,20 @@
+# Patch for Gentoo bug #247487
+
+# git-cvsserver is not present when NO_PERL is set in Makefile which breaks
+# install target...
+
+--- git-1.6.0.4/Makefile
++++ git-1.6.0.4/Makefile
+@@ -1376,10 +1376,11 @@
+ $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)'
+ $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(gitexec_instdir_SQ)'
+ $(INSTALL) $(ALL_PROGRAMS) '$(DESTDIR_SQ)$(gitexec_instdir_SQ)'
+- $(INSTALL) git$X git-upload-pack$X git-receive-pack$X git-upload-archive$X git-shell$X git-cvsserver '$(DESTDIR_SQ)$(bindir_SQ)'
++ $(INSTALL) git$X git-upload-pack$X git-receive-pack$X git-upload-archive$X git-shell$X '$(DESTDIR_SQ)$(bindir_SQ)'
+ $(MAKE) -C templates DESTDIR='$(DESTDIR_SQ)' install
+ ifndef NO_PERL
+ $(MAKE) -C perl prefix='$(prefix_SQ)' DESTDIR='$(DESTDIR_SQ)' install
++ $(INSTALL) git-cvsserver '$(DESTDIR_SQ)$(bindir_SQ)'
+ endif
+ ifndef NO_TCLTK
+ $(MAKE) -C gitk-git install
diff --git a/dev-util/git/files/50git-gentoo.el b/dev-util/git/files/50git-gentoo.el
new file mode 100644
index 000000000000..42edd7714f07
--- /dev/null
+++ b/dev-util/git/files/50git-gentoo.el
@@ -0,0 +1,13 @@
+
+;;; dev-util/git site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'git-status "git" "Entry point into git-status mode." t)
+;;(autoload 'git-blame-mode "git-blame"
+;; "Minor mode for incremental blame for Git." t)
+
+;; GNU Emacs >=22.2 already includes vc-git.el.
+;; Enable the following only if Emacs has no GIT support.
+(unless (fboundp 'vc-git-registered)
+ (add-to-list 'load-path "@SITELISP@/compat")
+ (add-to-list 'vc-handled-backends 'GIT))
diff --git a/dev-util/git/files/git-daemon.confd b/dev-util/git/files/git-daemon.confd
index ace9cbd85bfd..75b421680c80 100644
--- a/dev-util/git/files/git-daemon.confd
+++ b/dev-util/git/files/git-daemon.confd
@@ -1,12 +1,19 @@
# conf.d file for git-daemon
#
# Please check man 1 git-daemon for more information about the options
-# git-daemon accepts.
+# git-daemon accepts. You MUST edit this to include your repositories you wish
+# to serve.
#
-# Meaningful options are:
+# Some of the meaningful options are:
# --syslog --- Enables syslog logging
# --verbose --- Enables verbose logging
# --export-all --- Exports all repositories
# --port=XXXX --- Starts in port XXXX instead of 9418
#
-GITDAEMON_OPTS="--syslog"
+GITDAEMON_OPTS="--syslog /var/git"
+
+# To run an anonymous git safely, the following user should be able to only
+# read your Git repositories. It should not able able to write to anywhere on
+# your system, esp. not the repositories.
+GIT_USER="nobody"
+GIT_GROUP="nobody"
diff --git a/dev-util/git/files/git-daemon.initd b/dev-util/git/files/git-daemon.initd
index 60ccba02d2d9..07650ea6ff9b 100644
--- a/dev-util/git/files/git-daemon.initd
+++ b/dev-util/git/files/git-daemon.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/files/git-daemon.initd,v 1.3 2008/09/16 17:52:15 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/files/git-daemon.initd,v 1.4 2008/11/24 01:08:06 robbat2 Exp $
depend() {
need net
@@ -11,12 +11,16 @@ depend() {
start() {
ebegin "Starting git-daemon"
start-stop-daemon --start --quiet --background \
- --exec /usr/bin/git -- daemon ${GITDAEMON_OPTS}
+ --exec /usr/bin/git/git -- daemon \
+ --pid-file=/var/run/git-daemon.pid \
+ --user=${GIT_USER} --group=${GIT_GROUP} \
+ ${GITDAEMON_OPTS}
eend $?
}
stop() {
ebegin "Stopping git-daemon"
- start-stop-daemon --stop --quiet --name git-daemon
+ start-stop-daemon --stop --quiet \
+ --pidfile /var/run/git-daemon.pid
eend $?
}