summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-05-05 19:08:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-05-05 19:08:22 +0000
commitbcf68a8d25629d4c731c060e141bef51b9e5a5c2 (patch)
tree05c2afbf793b6ac84cca5e7899c1b9f9facb68f0 /dev-util/git
parentFix run.sh (diff)
downloadgentoo-2-bcf68a8d25629d4c731c060e141bef51b9e5a5c2.tar.gz
gentoo-2-bcf68a8d25629d4c731c060e141bef51b9e5a5c2.tar.bz2
gentoo-2-bcf68a8d25629d4c731c060e141bef51b9e5a5c2.zip
Fix Getopt::Long usage bug, patch submitted to upstream as well.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/git')
-rw-r--r--dev-util/git/ChangeLog6
-rw-r--r--dev-util/git/files/20090505-git-1.6.2.5-getopt-fixes.patch34
-rw-r--r--dev-util/git/git-1.6.2.5.ebuild5
-rw-r--r--dev-util/git/git-1.6.3_rc4.ebuild8
4 files changed, 50 insertions, 3 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index f3068b9d85e1..bfefbc488e89 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/git
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.335 2009/05/05 17:23:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.336 2009/05/05 19:08:21 robbat2 Exp $
+
+ 05 May 2009; Robin H. Johnson <robbat2@gentoo.org> git-1.6.2.5.ebuild,
+ +files/20090505-git-1.6.2.5-getopt-fixes.patch, git-1.6.3_rc4.ebuild:
+ Fix Getopt::Long usage bug, patch submitted to upstream as well.
*git-1.6.2.5 (05 May 2009)
diff --git a/dev-util/git/files/20090505-git-1.6.2.5-getopt-fixes.patch b/dev-util/git/files/20090505-git-1.6.2.5-getopt-fixes.patch
new file mode 100644
index 000000000000..2238107debdf
--- /dev/null
+++ b/dev-util/git/files/20090505-git-1.6.2.5-getopt-fixes.patch
@@ -0,0 +1,34 @@
+From c1a15a03af9412f2c037574f2df2587036ecb4b1 Mon Sep 17 00:00:00 2001
+From: Robin H. Johnson <robbat2@gentoo.org>
+Date: Tue, 5 May 2009 11:10:56 -0700
+Subject: [PATCH] Fix sloppy Getopt::Long.
+
+Getopt-Long v2.38 is much stricter about sloppy getopt usage. The
+trailing pipe causes git-svn testcases to fail for all of the --stdin
+argument calls.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+===
+Should be applied to both the stable 1.6.2.x tree and the new 1.6.3
+tree.
+---
+ git-svn.perl | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/git-svn.perl b/git-svn.perl
+index c5965c9..ef1d30d 100755
+--- a/git-svn.perl
++++ b/git-svn.perl
+@@ -147,7 +147,7 @@ my %cmd = (
+ 'dry-run|n' => \$_dry_run } ],
+ 'set-tree' => [ \&cmd_set_tree,
+ "Set an SVN repository to a git tree-ish",
+- { 'stdin|' => \$_stdin, %cmt_opts, %fc_opts, } ],
++ { 'stdin' => \$_stdin, %cmt_opts, %fc_opts, } ],
+ 'create-ignore' => [ \&cmd_create_ignore,
+ 'Create a .gitignore per svn:ignore',
+ { 'revision|r=i' => \$_revision
+--
+1.6.2.3
+
diff --git a/dev-util/git/git-1.6.2.5.ebuild b/dev-util/git/git-1.6.2.5.ebuild
index 58eaf71d2033..a5c6380ae9a2 100644
--- a/dev-util/git/git-1.6.2.5.ebuild
+++ b/dev-util/git/git-1.6.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.2.5.ebuild,v 1.1 2009/05/05 17:23:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.2.5.ebuild,v 1.2 2009/05/05 19:08:21 robbat2 Exp $
EAPI=2
@@ -132,6 +132,9 @@ src_prepare() {
# Noperl is being merged to upstream as of 2009/04/05
#epatch "${FILESDIR}"/20090305-git-1.6.2-noperl.patch
+ # GetOpt-Long v2.38 is strict
+ epatch "${FILESDIR}"/20090505-git-1.6.2.5-getopt-fixes.patch
+
sed -i \
-e 's:^\(CFLAGS =\).*$:\1 $(OPTCFLAGS) -Wall:' \
-e 's:^\(LDFLAGS =\).*$:\1 $(OPTLDFLAGS):' \
diff --git a/dev-util/git/git-1.6.3_rc4.ebuild b/dev-util/git/git-1.6.3_rc4.ebuild
index 1c9b66151133..85bba7a6911e 100644
--- a/dev-util/git/git-1.6.3_rc4.ebuild
+++ b/dev-util/git/git-1.6.3_rc4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.3_rc4.ebuild,v 1.1 2009/05/05 17:04:12 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.3_rc4.ebuild,v 1.2 2009/05/05 19:08:21 robbat2 Exp $
EAPI=2
@@ -126,9 +126,15 @@ src_unpack() {
#cp "${FILESDIR}"/GIT-VERSION-GEN .
fi
+}
+
+src_prepare() {
# Noperl is being merged to upstream as of 2009/04/05
#epatch "${FILESDIR}"/20090305-git-1.6.2-noperl.patch
+ # GetOpt-Long v2.38 is strict
+ epatch "${FILESDIR}"/20090505-git-1.6.2.5-getopt-fixes.patch
+
sed -i \
-e 's:^\(CFLAGS =\).*$:\1 $(OPTCFLAGS) -Wall:' \
-e 's:^\(LDFLAGS =\).*$:\1 $(OPTLDFLAGS):' \